Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EFI/nvidia/GRUB2 Damn EFI - Framebuffer issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
aleskandro
n00b
n00b


Joined: 05 Sep 2012
Posts: 13

PostPosted: Wed Jan 28, 2015 10:47 am    Post subject: EFI/nvidia/GRUB2 Damn EFI - Framebuffer issue Reply with quote

Hi all, I'm installing Gentoo with EFI (first time in EFI).
I configured all my system and GRUB2 and it starts at the boot but when I select the boot option it freeze the display on "Loading Linux 3.17.7-gentoo"
I read of similar issues about nvidia cards, efi and grub, but I don't solved trying several things (video=efifb, nomodeset, etc).
However I can log into my system via ssh.
It seems to appear that kernel doesn't load efifb driver so it can't create a vga console.
Anyone can help me?

My GPU is Nvidia 750
Here is the dmesg output: http://paste2.org/_v3cMBXgx
Here is my .config: http://paste2.org/_g7pzG23w
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2118

PostPosted: Wed Jan 28, 2015 1:53 pm    Post subject: Reply with quote

Can you boot without framebuffer?
Back to top
View user's profile Send private message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 419
Location: Hawaii

PostPosted: Thu Jan 29, 2015 5:00 pm    Post subject: Reply with quote

uvesafb instead of efifb? That's what worked for me.
_________________
Asus z97-a
Intel i7 4790k
16Gb Mushkin DDR3
Geforce GTX 970
Samsung Evo 840 500Gb +Seagate 1TB HDD
Etc....
Back to top
View user's profile Send private message
aleskandro
n00b
n00b


Joined: 05 Sep 2012
Posts: 13

PostPosted: Fri Jan 30, 2015 5:24 pm    Post subject: Reply with quote

I "solved" converting gpt label into mbr, so without efi. And it doesn't use framebuffer... If I boot via vga=ask and select anyone of available resolutions it became blank and boot.
I tried with vesafb, not uvesafb.
Back to top
View user's profile Send private message
bammbamm808
Guru
Guru


Joined: 08 Dec 2002
Posts: 419
Location: Hawaii

PostPosted: Sat Jan 31, 2015 7:05 am    Post subject: Reply with quote

My (older) Nvidia card didn't work with vesafb either, except for 640x480, and with some kernels, not even that. Uvesafb worked fully and enabled me to select a nice dense console resolution.
_________________
Asus z97-a
Intel i7 4790k
16Gb Mushkin DDR3
Geforce GTX 970
Samsung Evo 840 500Gb +Seagate 1TB HDD
Etc....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum