Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openvz with desktop
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 265

PostPosted: Fri Jan 02, 2015 5:52 am    Post subject: openvz with desktop Reply with quote

Hi all,
I want install X-server with some desktop environment on OpenVZ virtual container.
and I got this error:
Quote:
# Xorg -configure

X.Org X Server 1.14.7
Release Date: 2014-06-05
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-32-pve x86_64 Gentoo
Current Operating System: Linux konsultant 2.6.32-32-pve #1 SMP Thu Aug 21 08:50:19 CEST 2014 x86_64
Kernel command line: quiet
Build Date: 02 January 2015 04:38:54AM

Current version of pixman: 0.32.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 2 04:51:09 2015
List of video drivers:
openchrome
glint
s3virge
apm
v4l
intel
nv
ast
trident
cirrus
ati
s3
r128
chips
qxl
vesa
tga
tdfx
i128
radeon
fbdev
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
No devices to configure. Configuration failed.
(EE) Server terminated with error (2). Closing log file.


here not full
/var/log/Xorg.0.log
in first part of this log file I don't have WW or EE messages, only II.

Code:
[ 17208.977] (II) LoadModule: "fbdev"
[ 17208.977] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 17208.977] (II) Module fbdev: vendor="X.Org Foundation"
[ 17208.977]    compiled for 1.14.7, module version = 0.4.4
[ 17208.977]    Module class: X.Org Video Driver
[ 17208.977]    ABI class: X.Org Video Driver, version 14.1
[ 17208.977] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[ 17208.977] (WW) Falling back to old probe method for glint
[ 17208.977] (WW) Falling back to old probe method for s3virge
[ 17208.977] (WW) Falling back to old probe method for apm
[ 17208.977] (WW) Falling back to old probe method for v4l
[ 17208.977] (II) v4l driver for Video4Linux
[ 17208.977] (WW) Falling back to old probe method for ast
[ 17208.977] (WW) Falling back to old probe method for trident
[ 17208.977] (WW) Falling back to old probe method for cirrus
[ 17208.977] (II) Loading sub module "cirrus_laguna"
[ 17208.977] (II) LoadModule: "cirrus_laguna"
[ 17208.977] (II) Loading /usr/lib64/xorg/modules/drivers/cirrus_laguna.so
[ 17208.977] (II) Module cirrus_laguna: vendor="X.Org Foundation"
[ 17208.977]    compiled for 1.14.7, module version = 1.0.0
[ 17208.977]    ABI class: X.Org Video Driver, version 14.1
[ 17208.977] (II) Loading sub module "cirrus_alpine"
[ 17208.977] (II) LoadModule: "cirrus_alpine"
[ 17208.977] (II) Loading /usr/lib64/xorg/modules/drivers/cirrus_alpine.so
[ 17208.977] (II) Module cirrus_alpine: vendor="X.Org Foundation"
[ 17208.977]    compiled for 1.14.7, module version = 1.0.0
[ 17208.977]    ABI class: X.Org Video Driver, version 14.1
[ 17208.977] (WW) Falling back to old probe method for s3
[ 17208.977] (WW) Falling back to old probe method for vesa
[ 17208.977] (WW) Falling back to old probe method for tga
[ 17208.977] (WW) Falling back to old probe method for i128
[ 17208.977] (WW) Falling back to old probe method for fbdev
[ 17208.977] No devices to configure.  Configuration failed.
[ 17208.977] (EE) Server terminated with error (2). Closing log file.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 265

PostPosted: Tue Jan 20, 2015 12:11 pm    Post subject: Reply with quote

hi there,
I still in trouble with xorg starts on OpenVz container:

Code:
[  1680.556] (II) LoadModule: "vesa"
[  1680.557] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[  1680.557] (II) Module vesa: vendor="X.Org Foundation"
[  1680.557]    compiled for 1.14.7, module version = 2.3.3
[  1680.557]    Module class: X.Org Video Driver
[  1680.557]    ABI class: X.Org Video Driver, version 14.1
[  1680.557] (II) LoadModule: "modesetting"
[  1680.557] (WW) Warning, couldn't open module modesetting
[  1680.557] (II) UnloadModule: "modesetting"
[  1680.557] (II) Unloading modesetting
[  1680.557] (EE) Failed to load module "modesetting" (module does not exist, 0)
[  1680.557] (II) LoadModule: "fbdev"
[  1680.557] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[  1680.557] (II) Module fbdev: vendor="X.Org Foundation"
[  1680.557]    compiled for 1.14.7, module version = 0.4.4
[  1680.557]    Module class: X.Org Video Driver
[  1680.557]    ABI class: X.Org Video Driver, version 14.1
[  1680.557] (II) VESA: driver for VESA chipsets: vesa
[  1680.557] (II) FBDEV: driver for framebuffer: fbdev
[  1680.557] (++) using VT number 7
 
[  1680.557] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[  1680.557] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[  1680.557] (WW) xf86OpenConsole: VT_GETSTATE failed: Invalid argument
[  1680.557] (EE)
Fatal server error:
[  1680.557] (EE) xf86OpenConsole: VT_ACTIVATE failed: Invalid argument
[  1680.557] (EE)
[  1680.557] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  1680.557] (EE) Please also check the log file at
"/var/log/Xorg.0.log" for additional information.
[  1680.557] (EE)
[  1680.557] (WW) xf86CloseConsole: KDSETMODE failed: Invalid argument
[  1680.557] (WW) xf86CloseConsole: VT_GETMODE failed: Invalid argument
[  1680.557] (EE) Server terminated with error (1). Closing log file.


also I have made this config, but in x2go session I can't switch the kbd layount.
cat /etc/X11/xord.conf.d/20kbd.conf
Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "Protocol" "Standard"
        Option      "XkbModel" "pc105"
        Option      "xkbLayout" "us,ru(winkeys)"
        Option      "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
EndSection
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum