Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udisk & KDE problems (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 135
Location: Modena, Italy

PostPosted: Thu Jan 01, 2015 5:40 pm    Post subject: udisk & KDE problems (solved) Reply with quote

Hi to all, I have some problems with udisk.
Every media I insert (USB stick, CD-rom) will not be show by the kde device notificator.
After the gentoo installation this function was right, but after some updates/installation is totally broken
I've tryed
Code:

udisks --monitor

but inserting a CDROM or a USB stick I got nothing :/

Code:

snoopx linux # rc-status
Runlevel: default
 syslog-ng                                                                                                                                      [  started  ]
 dbus                                                                                                                                           [  started  ]
 mysql                                                                                                                                          [  started  ]
 gpm                                                                                                                                            [  started  ]
 consolekit                                                                                                                                     [  started  ]
 dhcpcd                                                                                                                                         [  started  ]
 net.eth0                                                                                                                                       [  started  ]
 netmount                                                                                                                                       [  started  ]
 xdm                                                                                                                                            [  started  ]
 bluetooth                                                                                                                                      [  started  ]
 samba                                                                                                                                          [  started  ]
 sshd                                                                                                                                           [  started  ]
 local                                                                                                                                          [  started  ]
Dynamic Runlevel: hotplugged
 net.eth0                                                                                                                                       [  started  ]
Dynamic Runlevel: needed
 lvmetad                                                                                                                                        [  started  ]
 xdm-setup                                                                                                                                      [  started  ]
Dynamic Runlevel: manual


dbus is enabled, but not udisks .. but I don't think that udisks is a daemon.

Trying to mount the device manually, i got those errors:

Code:
snoopx linux # udisksctl mount /dev/sdc1

(process:15861): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:15861): GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(process:15861): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:15861): GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(process:15861): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:15861): GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(process:15861): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:15861): GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(process:15861): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(process:15861): GLib-GObject-CRITICAL **: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(process:15861): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Error connecting to the udisks daemon: Errore nel chiamare StartServiceByName per org.freedesktop.UDisks2: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program org.freedesktop.UDisks2: Success


The kernel i'm using is the last kernel.org stable, 3.18.1 but is the same with the last gentoo source! :/
The kernel is compiled manually, is almost the same configuration I've done in the installation and the device notificator was working :/

Any issue?


Last edited by dylanmc on Sun Feb 01, 2015 10:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 135
Location: Modena, Italy

PostPosted: Sun Feb 01, 2015 10:27 pm    Post subject: Reply with quote

Solved my problem ...


Code:
chmod o+x /usr/libexec/dbus-daemon-launch-helper


Some permission were changed.. :/
Back to top
View user's profile Send private message
magoscuro
n00b
n00b


Joined: 18 Mar 2005
Posts: 32
Location: Santiago de Chile

PostPosted: Sat Oct 03, 2015 12:29 pm    Post subject: Reply with quote

dylanmc!


This works for me also!
Thank you a lot! You save me a lot of time!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Oct 03, 2015 12:47 pm    Post subject: Reply with quote

dylanmc wrote:
Code:
chmod o+x /usr/libexec/dbus-daemon-launch-helper


Some permission were changed.. :/

You should not do that. Instead your user needs to get appropriate rights within your session. Are you part of the 'users' group?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
magoscuro
n00b
n00b


Joined: 18 Mar 2005
Posts: 32
Location: Santiago de Chile

PostPosted: Sat Oct 03, 2015 1:16 pm    Post subject: Reply with quote

Hi genstorm,

I'm in all of these groups :

christian@malleco ~ $ id
uid=1000(christian) gid=1000(christian) grupos=1000(christian),10(wheel),18(audio),27(video),35(games),85(usb),100(users),103(vboxusers),122(plugdev),248(realtime),978(xenomai),998(vmware)


I've installed gnome+systemd, and then come back to kde+init.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Oct 03, 2015 1:18 pm    Post subject: Reply with quote

What login manager do you use? Is it built with consolekit support?

Code:
$ ck-list-sessions

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
magoscuro
n00b
n00b


Joined: 18 Mar 2005
Posts: 32
Location: Santiago de Chile

PostPosted: Sat Oct 03, 2015 1:31 pm    Post subject: Reply with quote

I'm using kdm iwth consolekit support :

Code:
>emerge -va kdm
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] kde-base/kdm-4.11.19:4/4.11::gentoo  USE="consolekit handbook pam (-aqua) -debug -kerberos -systemd" 0 KiB


Code:
>ck-list-sessions
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2015-10-03T12:09:06.874318Z'
        login-session-id = '4294967295'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum