Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Startx throws "screen not found error"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
3xF15h
n00b
n00b


Joined: 30 Dec 2014
Posts: 2
Location: United States

PostPosted: Wed Dec 31, 2014 10:11 pm    Post subject: Startx throws "screen not found error" Reply with quote

I've just finished the gentoo wiki on KDE and when I go to start the x server it fails and throws the error message "screen not found". I've been searching for a solution for a few days now and have yet to find one. Any help is appreciated.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42560
Location: 56N 3W

PostPosted: Wed Dec 31, 2014 10:29 pm    Post subject: Reply with quote

3xF15h,

Welcome to Gentoo.

emerge wgetpaste and use it to put your /var/log/Xorg.0.log file onto a pastebin site.
Tell us the URL you get back.

This file will tell what Xorg actually did when it started.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
3xF15h
n00b
n00b


Joined: 30 Dec 2014
Posts: 2
Location: United States

PostPosted: Wed Dec 31, 2014 10:46 pm    Post subject: Reply with quote

/var/log/Xorg.0.log:
https://bpaste.net/show/206d656e4be5

Also after doing some more research I think that this problem may be related to another problem where the boot hangs on the processing uevent section.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42560
Location: 56N 3W

PostPosted: Wed Dec 31, 2014 11:05 pm    Post subject: Reply with quote

3xF15h,

Code:
[    96.907] Build Operating System: Linux 3.17.7-gentoo x86_64 Gentoo
[    96.956] (II) NVIDIA dlloader X Driver  343.36  Mon Dec  1 15:28:39 PST 2014


Code:
[    96.944] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    96.949] (II) Module glx: vendor="X.Org Foundation"


Two things. Your system has loaded the wrong GLX driver, so you won't get any acceleration.
This is a known bug.

Secondly
Code:
[    96.924] (--) PCI:*(0:0:2:0) 8086:0416:1462:10e0 rev 6, Mem @ 0xf7400000/4194304, 0xb0000000/268435456, I/O @ 0x0000f000/64
[    96.924] (--) PCI: (0:1:0:0) 10de:11e2:1462:10e0 rev 161, Mem @ 0xf6000000/16777216, 0xc0000000/268435456, 0xd0000000/3355443

Than shows you have Intel and nVidia graphics. This combination is often found in laptops under the name Optimus.

In this arrangement you must use the Intel graphics at all times as its the only one that has a connection to the display.
You can toggle between Intel and nVidia for drawing. Follow one of the recent Optimus threads here or on the wiki if this is you.

Lastly (thats 3 things)
Code:
[    96.960] (EE) No devices detected.
usually means that another kernel driver has grabbed the nvidia graphics chip and the binary blob can't see it any more. It also occurs if your nvida chip is no longer supported by this version of the driver.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum