Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Issues with WPA supplicant
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
allenh1
n00b
n00b


Joined: 16 Jun 2014
Posts: 16
Location: Brentwood, TN

PostPosted: Wed Dec 31, 2014 6:27 am    Post subject: Issues with WPA supplicant Reply with quote

Ok. I have definitely exhausted my abilities with this issue... I installed the systemd version of gentoo with xfce (because gnome doesn't work because pulseaudio crashes from libdbus on startup). I'll give you all the information you want. I had the card scanning the network, and now it doesn't (which is super frustrating). The driver is picked up, but, according to dmesg, crashes upon booting.

Here is the relevant dmesg output (I'll post the whole file if you really need it):

Code:
[   10.030017] Intel(R) Wireless WiFi driver for Linux, in-tree:
[   10.030019] Copyright(c) 2003- 2014 Intel Corporation
[   10.058689] iwlwifi 0000:04:00.0: irq 28 for MSI/MSI-X
[   10.090269] systemd-sysctl[2082]: Overwriting earlier assignment of kernel/sysrq in file '/usr/lib64/sysctl.d/60-gentoo.conf'.
[   10.090270] systemd-sysctl[2085]: Overwriting earlier assignment of kernel/sysrq in file '/usr/lib64/sysctl.d/60-gentoo.conf'.
[   10.177013] acpi device:02: registered as cooling_device8
[   10.177074] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:01/LNXVIDEO:00/input/input15
[   10.222362] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-3160-10.ucode failed with error -2
[   10.567007] iwlwifi 0000:04:00.0: loaded firmware version 25.222.9.0 op_mode iwlmvm
[   10.584466] snd_hda_intel 0000:01:00.1: Disabling MSI
[   10.584518] snd_hda_intel 0000:00:1b.0: irq 29 for MSI/MSI-X
[   10.703813] sound hdaudioC1D0: autoconfig: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:line
[   10.703815] sound hdaudioC1D0:    speaker_outs=1 (0x14/0x0/0x0/0x0/0x0)
[   10.703816] sound hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   10.703817] sound hdaudioC1D0:    mono: mono_out=0x0
[   10.703818] sound hdaudioC1D0:    dig-out=0x1e/0x0
[   10.703819] sound hdaudioC1D0:    inputs:
[   10.703821] sound hdaudioC1D0:      Mic=0x18
[   10.703822] sound hdaudioC1D0:      Internal Mic=0x12
[   10.703823] sound hdaudioC1D0:      Line=0x1a
[   10.766338] nvidia: module license 'NVIDIA' taints kernel.
[   10.766339] Disabling lock debugging due to kernel taint
[   10.774815] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   10.775053] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 0
[   10.775057] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  343.36  Mon Dec  1 16:18:58 PST 2014
[   10.822164] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
[   10.822209] iwlwifi 0000:04:00.0: L1 Disabled - LTR Disabled
[   10.822428] iwlwifi 0000:04:00.0: L1 Disabled - LTR Disabled
[   10.933552] cfg80211: Ignoring regulatory request set by core since the driver uses its own custom regulatory domain
[   10.939441] nvidia 0000:01:00.0: irq 30 for MSI/MSI-X
[   10.941724] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   10.941751] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   10.941767] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   10.941790] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   10.941806] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   10.941832] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   10.941847] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   10.941862] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   11.041376] cfg80211: Ignoring regulatory request set by core since the driver uses its own custom regulatory domain
[   11.041377] cfg80211: World regulatory domain updated:
[   11.041378] cfg80211:  DFS Master region: unset
[   11.041379] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   11.041381] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   11.041382] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   11.041383] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[   11.041384] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   11.041385] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   11.113629] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   11.113677] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   11.121359] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   11.185954] sound hdaudioC2D0: autoconfig: line_outs=0 (0x0/0x0/0x0/0x0/0x0) type:line
[   11.185955] sound hdaudioC2D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   11.185956] sound hdaudioC2D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   11.185957] sound hdaudioC2D0:    mono: mono_out=0x0
[   11.185958] sound hdaudioC2D0:    dig-out=0x5/0x7
[   11.185959] sound hdaudioC2D0:    inputs:
[   11.428318] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   11.646670] iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
[   11.826827] systemd-udevd[2048]: renamed network interface wlan0 to wlp4s0
[   11.858983] systemd-sysctl[2111]: Overwriting earlier assignment of kernel/sysrq in file '/usr/lib64/sysctl.d/60-gentoo.conf'.
[   12.164888] BTRFS info (device sdb3): disk space caching is enabled
[   12.273024] Adding 4194300k swap on /dev/sda2.  Priority:-1 extents:1 across:4194300k
[   12.353650] EXT4-fs (sda1): mounted filesystem with writeback data mode. Opts: (null)
[   13.623429] iwlwifi 0000:04:00.0: L1 Disabled - LTR Disabled
[   13.623649] iwlwifi 0000:04:00.0: L1 Disabled - LTR Disabled
[   13.634531] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   13.791975] r8169 0000:03:00.2 enp3s0f2: link down
[   13.792003] IPv6: ADDRCONF(NETDEV_UP): enp3s0f2: link is not ready
[   30.565558] nvidia 0000:01:00.0: irq 30 for MSI/MSI-X
[   30.567871] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.567899] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.567915] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.567938] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.567953] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.567979] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.567994] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.568009] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.631075] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.631113] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   30.678815] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140724/nsarguments-95)
[   46.924476] nm-applet[2760]: segfault at 80 ip 00007f97bae68dab sp 00007fff32fc0420 error 4 in libdbus-1.so.3.8.8[7f97bae57000+42000]
[   52.331111] tracker-miner-f[2776]: segfault at 0 ip 00007f30ce6885e9 sp 00007fff863cb220 error 4 in libupower-glib.so.3.0.0[7f30ce678000+23000]


As for wpa_supplicant in /etc/conf.d/wpa_supplicant:

Code:
# conf.d file for wpa_supplicant
#
# Please check man 8 wpa_supplicant for more information about the options
# wpa_supplicant accepts.
#
wpa_supplicant_args=""


Lastly, there's the /etc/conf.d/net file:

Code:
dns_domain_lo="localnetwork"
config_eth0="dhcp"
config_wlan0="dhcp"
#wlp4s0

modules_wlp4s0="wpa_supplicant"
wpa_supplicant_wlp4s0="-Dn180211"
config_wlp4s0="dhcp"


I am using linux kernel 3.17.7.

Any help is GREATLY appreciated. Thanks in advance,
-Hunter A.

--------------------------------------------------------------------------------------------------------

UPDATE: I have the network scanning again. The solution was deleting some of the configuration files. conf.d/net does nothing now. Also, here's the output I get from wpa supplicant.

Code:
hunter-gentoo ~ # wpa_supplicant -Dnl80211 -iwlp4s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant
wlp4s0: CTRL-EVENT-SCAN-STARTED
wlp4s0: SME: Trying to authenticate with 3c:ea:4f:d2:0d:f9 (SSID='2WIRE718' freq=2462 MHz)
wlp4s0: Trying to associate with 3c:ea:4f:d2:0d:f9 (SSID='2WIRE718' freq=2462 MHz)
wlp4s0: Associated with 3c:ea:4f:d2:0d:f9
wlp4s0: CTRL-EVENT-REGDOM-CHANGE init=USER type=COUNTRY alpha2=US
wlp4s0: CTRL-EVENT-DISCONNECTED bssid=3c:ea:4f:d2:0d:f9 reason=3 locally_generated=1
wlp4s0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=WORLD
wlp4s0: CTRL-EVENT-TERMINATING


The key may be the reason=3 thing. Not sure what that is. I will be googling.
Back to top
View user's profile Send private message
prozprcek
n00b
n00b


Joined: 18 Sep 2014
Posts: 26

PostPosted: Fri Jan 02, 2015 5:31 pm    Post subject: Reply with quote

Quote:
Code:

dns_domain_lo="localnetwork"
config_eth0="dhcp"
config_wlan0="dhcp"
#wlp4s0

modules_wlp4s0="wpa_supplicant"
wpa_supplicant_wlp4s0="-Dn180211"
config_wlp4s0="dhcp"



You have a typo it's not -Dn180211 but -Dnl80211 (you typed 1 instead of lowercase L)
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Fri Jan 02, 2015 6:16 pm    Post subject: Reply with quote

prozprcek wrote:
You have a typo it's not -Dn180211 but -Dnl80211 (you typed 1 instead of lowercase L)

prozprcek ... won't make any difference as systemd is in use and /etc/conf.d/net is used by openrc/netifrc.

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum