Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nginx tries to bring up eth1 instead of eth0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 982

PostPosted: Wed Dec 31, 2014 6:25 am    Post subject: Nginx tries to bring up eth1 instead of eth0 Reply with quote

When starting Nginx on my cloud server, it tries to bring up eth1 instead of eth0. Any suggestions?

Code:

public-node app # /etc/init.d/nginx start
 * Bringing up interface eth1
 *   10.209.34.117/19 ...
RTNETLINK answers: File exists                                                                                [ !! ]
 * ERROR: net.eth1 failed to start
 * Bringing up interface eth1
 *   10.209.34.117/19 ...
RTNETLINK answers: File exists                                                                                [ !! ]
 * ERROR: net.eth1 failed to start
 * ERROR: cannot start netmount as net.eth1 would not start
 * ERROR: cannot start nginx as net.eth1 would not start
public-node app #


Code:

public-node app # lr /etc/init.d/
lrwxrwxrwx  1 root root    6 Oct 20 15:38 net.eth0 -> net.lo
lrwxrwxrwx  1 root root    6 Oct 20 15:38 net.eth1 -> net.lo
-rwxr-xr-x  1 root root  18K Oct 16 04:21 net.lo
-rwxr-xr-x  1 root root 1.6K Oct 16 04:21 netmount
-rwxr-xr-x  1 root root 2.0K Dec 31 01:16 nginx
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 792
Location: Queensland

PostPosted: Fri Jan 02, 2015 1:38 am    Post subject: Obvious stuff Reply with quote

OK, two days since you posted and no one else has stepped in. If you're running a cloud server I assume you have a bit of a clue about networking, routing and stuff but your output shows that the problem is that nginx is dependent on netmount, which in turn is dependent on net.eth1. So the question is why does netmount depend on net.eth1 ? I don't know why a network service should specify a particular interface. Try /etc/init.d/netmount start to see if it really does depend on net.eth1.

If this message is all obvious and unhelpful, say so and I'll delete it so your question still appears unanswered.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14159

PostPosted: Fri Jan 02, 2015 3:46 am    Post subject: Reply with quote

Please post the output of:
Code:
for file in /etc/rc.conf /etc/conf.d/{net,nginx}; do echo "$file"; cat -n "$file"; done ; /etc/init.d/nginx ineed
Back to top
View user's profile Send private message
dman777
l33t
l33t


Joined: 10 Jan 2007
Posts: 982

PostPosted: Thu Sep 24, 2015 2:06 am    Post subject: Reply with quote

Long time but ran into this again... you are correct. I removed 'need net' and it no longer will try to use netmount.
_________________
<h5>Checkout <em>#grandmasboy</em> on <em>freenode</em>...chat with jayP bot from the movie!</h5>
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum