Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kicad random draw when moving objects or add new
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
bdien
n00b
n00b


Joined: 01 Oct 2012
Posts: 13

PostPosted: Mon Dec 29, 2014 4:13 pm    Post subject: kicad random draw when moving objects or add new Reply with quote

I tried to install "kicad stable" from gentoo and overlay. But the result is the same I do not know where wrong. I do not know how describe it, you try to get my picture posted.
http://imageshack.com/a/img537/932/fWGiQ6.png
emerge --info kicad
Code:
Portage 2.2.15 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/gnome, gcc-4.8.3, glibc-2.20, 3.17.7-gentoo-2 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.17.7-gentoo-2-x86_64-Intel-R-_Core-TM-_i3_CPU_M_330_@_2.13GHz-with-gentoo-2.2
KiB Mem:     5908916 total,   2042524 free
KiB Swap:    2500604 total,   2500464 free
Timestamp of tree: Fri, 26 Dec 2014 09:30:02 +0000
sh bash 4.3_p30-r1
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p30-r1
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9, 3.3.5-r1
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.6
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.13.4, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.7.3-r1, 4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.4
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
sys-libs/glibc:           2.20
Repositories: gentoo ixit displacer x11
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -fPIC -pipe -O3 -msse4.2 -msse4.1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -fPIC -pipe -O3 -msse4.2 -msse4.1"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -lm"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/ixit /var/lib/layman/displacer /var/lib/layman/x11"
USE="Broadcom Intel-SDP X a52 aac aacplus acl acp acpi alsa amd64 android apache2 autoipd autotools berkdb binary bindist bluetooth branding bzip2 cairo cdda cdr cli cmake colord consolekit cracklib crypt cxx dbus directx dlna dmx dri dts dvd dvdr eds egl emboss encode evo exif fam ffmpeg firefox flac fortran g3dvl gdbm gif git glamor gles gles2 gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk hscolour iconv introspection ipv6 jpeg laptop lcms ldap libnotify libsecret mad mmx mng modemmanager modules mp3 mp4 mpeg multicore multilib mysql nautilus ncurses networkmanager nls nokia nptl ogg opengl openmp pam pango pcre pdf php png policykit ppds ppp pulseaudio readline scsi sdl session socialweb spell sse sse2 sse3 sse4.1 sse4.2 sse4_1 sse4_2 ssl ssse3 startup-notification svg systemd tcpd theora threaded threads tiff tinfo truetype udev udisks unicode upower usb uxa vaapi vala vdpau vorbis wayland wxwidgets x264 x265 xcb xcomposite xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" ENLIGHTENMENT_MODULES="appmenu backlight battery bluez4 clock conf-applications conf-bindings conf-dialogs conf-display conf-interaction conf-intl conf-menus conf-paths conf-performance conf-randr conf-shelves conf-theme conf-window-manipulation conf-window-remembers connman contact cpufreq everything fileman fileman-opinfo gadman ibox ibar lokker mixer msgbus music-control notification pager pager16 quickaccess shot start syscan systray tasks syscon teamwork temperature tiling winlist wizard" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="joystick evdev synaptics mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en vn" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="arm x86_64 i386" QEMU_USER_TARGETS="x86_64 arm" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="i915 i965 intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sci-electronics/kicad-20130518 was built with the following:
USE="-debug" ABI_X86="64" LINGUAS="en -de -es -fr -hu -it -ja -pl -pt -ru -zh_CN"
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5586
Location: Removed by Neddy

PostPosted: Tue Dec 30, 2014 7:16 pm    Post subject: Reply with quote

That looks like GNOME3.x desktop, correct? ie a composite desktop.

How often does this occur? all the time? what type of triggers can cause this reliably?

once you have narrowed down the triggers could you try them after you launching kicad in a different desktop manager (say emerge something light like ... openbox).

I suspect it is todo with the 3d aspect of gnome3 as I do not experience that
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
bdien
n00b
n00b


Joined: 01 Oct 2012
Posts: 13

PostPosted: Thu Jan 01, 2015 11:25 am    Post subject: Reply with quote

I apologize for the delayed reply. I'm using gnome desktop 3.14, do not use anything more. I do not understand "composite"? it in Xorg? Always happens whenever using it. I had to reinstall gentoo but still the same. maybe I used the wrong flag? my bad english.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum