Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDM Crashes (DBUS?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rblackthorn
n00b
n00b


Joined: 19 Jun 2012
Posts: 4

PostPosted: Fri Dec 26, 2014 5:02 am    Post subject: KDM Crashes (DBUS?) Reply with quote

KDM crashes with the following log:

Code:


Loading extension NV-CONTROL
Loading extension XINERAMA
klauncher(3194) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(3164)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"

kdmgreet(3164)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
kdmgreet: Fatal IO error: client killed
using visual class 4, id 34
(EE) Server terminated successfully (0). Closing log file.



I've been all over the internet trying to find an answer for this one. It seems lots of people have this issue but none of the solutions worked for me and KDM is still crashing. I can run X and Xfce, I can also sort of run startkde but the menus are all black.

Things I've already tried:

DBUS is running.
ConsoleKit is running.
Switching opengl modes
rebuilding everything
disabling consolekit use flag and rebuilding
starting kdm with dbus-launch
Downgrading nvidia drivers

It looks like someone else also has a similar issue here:

https://forum.kde.org/viewtopic.php?f=111&t=124166
Back to top
View user's profile Send private message
jackgentoo
n00b
n00b


Joined: 04 Apr 2003
Posts: 40
Location: Santa Barbara, CA, USA

PostPosted: Sun Dec 28, 2014 6:42 pm    Post subject: Reply with quote

You just need to start dbus. /etc/init.d/dbus start to do it manually, "rc-update add dbus default" to make it permanent.
Back to top
View user's profile Send private message
rblackthorn
n00b
n00b


Joined: 19 Jun 2012
Posts: 4

PostPosted: Sun Dec 28, 2014 9:50 pm    Post subject: Reply with quote

dbus is already running and added to the default run level. Console kit is there as well. Still having the same issue.
Back to top
View user's profile Send private message
AKreal
n00b
n00b


Joined: 15 Dec 2006
Posts: 3

PostPosted: Thu Jan 22, 2015 5:18 pm    Post subject: Reply with quote

Do you have microcode_ctl enabled? If yes, try to disable it. I had a terrible crash on KDE login because of buggy CPU firmware, I guess.
Back to top
View user's profile Send private message
rblackthorn
n00b
n00b


Joined: 19 Jun 2012
Posts: 4

PostPosted: Thu Jan 22, 2015 5:33 pm    Post subject: Reply with quote

I figured out what it was. I noticed I was having issues with other qt based desktop environments as well, which helped arrive at the final solution.

The issue was with the qtsubsystem. There seems to be some flakyness in qt with my nvidia card when the mode is set to opengl or native. Using:

eselect qtgraphicssystem

to set the mode to raster resolved the issue.

NOTE: The log message relating to DBUS has nothing to do with it. That message appears in the log even when KDE starts normally.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum