Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Intel Wireless 3160ac showing but not connecting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
victorsk
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 92

PostPosted: Thu Dec 25, 2014 4:25 pm    Post subject: [SOLVED] Intel Wireless 3160ac showing but not connecting Reply with quote

Hi everyone,

I've got a strange problem. In my NetworkManager I see a list of wireless networks but when I try to connect, I type in the password, but the message is saying indefinitely: "configuring interface" and connection never happens. I tried this on an insecure connection and message was the same.

I followed the WiFi setup instructions from here:

http://wiki.gentoo.org/wiki/Wifi

The problem I had was trying to set kernel parameters to "*" as per documentation but I am never able to make it so and I am only left with "M" (module?) setting in the kernel. I am not sure why I cannot set to "*" beside the required fields. Here is my kernel .config file:

https://bpaste.net/show/8af3c263f03b

And results of my 'dmesg' command:

https://bpaste.net/show/b3f5aa785a4d

And 'lspci -k':

https://bpaste.net/show/ce6c49a4a0c2

And 'ifconfig -a':

https://bpaste.net/show/87a9ec75450b

I am really at a loss as to why I cannot complete wireless connection successfully. My wireless device is obviously picking up wireless networks, so it's working partially, but doesn't complete the connection for some reason.

My guess is it has something to do with my kernel not being set to "*" as per docs and it only has "M" beside those fields, but I cannot set to "*". If this is the problem, could somebody please suggest how I can make "*" instead of "M"? It's just not switching.

Other than that, I really have no idea. Could somebody assist me please?

Thank you,
Victor.

Also this command:
Code:

 /etc/init.d/net.wlp2s0 restart
 * Bringing down interface wlp2s0
 *   Stopping wpa_cli on wlp2s0 ...                                                                                    [ ok ]
 *   Stopping wpa_supplicant on wlp2s0 ...                                                                             [ ok ]
 * Bringing up interface wlp2s0
 *   Starting wpa_supplicant on wlp2s0 ...
Successfully initialized wpa_supplicant                                                                                [ ok ]
 *   Starting wpa_cli on wlp2s0 ...                                                                                    [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlp2s0 has started, but is inactive


Last edited by victorsk on Fri Dec 26, 2014 3:04 am; edited 2 times in total
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 925
Location: Sun City Center, Florida

PostPosted: Thu Dec 25, 2014 7:15 pm    Post subject: Reply with quote

I would put "Intel Wireless 3160ac" in your title as that is the adapter that is giving you troubles.
Using modules is fine, in your case better so you can see errors when you load it.
I would turn on debuging in the kernel.
Code:

# CONFIG_LIBIPW_DEBUG is not set
CONFIG_IWLWIFI=m
CONFIG_IWLDVM=m
CONFIG_IWLMVM=m
CONFIG_IWLWIFI_OPMODE_MODULAR=y

#
# Debugging Options
#
# CONFIG_IWLWIFI_DEBUG is not set
CONFIG_IWLEGACY=m
CONFIG_IWL4965=m
CONFIG_IWL3945=m


I found this;
http://askubuntu.com/questions/540580/ubuntu-intel-wireless-3160-ac-not-working-slow-disconnecting-unstable
I would try the latest kernel and firmware and see it that fixes it, it not try to play with the power save talked about here;
http://people.canonical.com/~sforshee/iwl-ltr/trusty/0001-iwlwifi-configure-the-LTR.patch

I don't have that adapter so can't be of much help.
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
victorsk
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 92

PostPosted: Fri Dec 26, 2014 3:16 am    Post subject: Reply with quote

Writing on WiFi connection :D

The problem I had too many configurations I set up by reading docs and solution was to:

- disable/comment out everything in /etc/conf.d/net
- remove net.enp1s0 and net.wlp2s0 from runlevel and remove links I created in /etc/init.d (by following docs on network installation) :

So basically I had to undo everything I did in section "Automatically Start Networking at Boot"
https://www.gentoo.org/doc/en/handbook/2004.3/handbook-x86.xml?part=1&chap=8

But add NetworkManager to runlevel.

The solution came after I examine how Calculate Linux handles networking and I applied similar changes in my Gentoo installation. Now my Gentoo system is completely set up :)

Cheers!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum