Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Apache2 - crash during webpage opening
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Mati-PL
n00b
n00b


Joined: 14 Dec 2014
Posts: 3

PostPosted: Sun Dec 21, 2014 4:50 pm    Post subject: Apache2 - crash during webpage opening Reply with quote

Hi

Few days ago I updated whole system and from that moment Apache constantly crashing with "Segmentation fault (11)" when I trying open web page. I tried rebuild packages, change USE flags, disable some Apache modules, but without success. So, i installed GDB and I recived this:

Code:
(gdb) run -X
Starting program: /usr/sbin/apache2 -X
Cannot access memory at address 0x0
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0xb6ece938 in apr_bucket_alloc () from /usr/lib/libaprutil-1.so.0
(gdb) bt
#0  0xb6ece938 in apr_bucket_alloc () from /usr/lib/libaprutil-1.so.0
#1  0xb6ecee68 in apr_bucket_file_create () from /usr/lib/libaprutil-1.so.0
#2  0x0002df10 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb)


I have tried rebuild "apr-utils" and change USE flags, but still nothing.
Intersting is that PHP works without any problem.

Code:
Cubietruck / # emerge --info
Portage 2.2.8-r2 (default/linux/arm/13.0/armv7a, gcc-4.8.3, glibc-2.17, 3.4.90+ armv7l)
=================================================================
System uname: Linux-3.4.90+-armv7l-ARMv7_Processor_rev_4_-v7l-with-gentoo-2.2
KiB Mem:     2015844 total,    628124 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Fri, 12 Dec 2014 11:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 armv7a-hardfloat-linux-gnueabi [enabled]
app-shells/bash:          4.2_p53
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.7, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo gentoo-pakiety-wlasne
ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="* -@EULA"
CBUILD="armv7a-hardfloat-linux-gnueabi"
CFLAGS="-O2 -pipe -march=armv7-a -mtune=cortex-a7  -mfpu=neon-vfpv4 -mfloat-abi=hard"
CHOST="armv7a-hardfloat-linux-gnueabi"
CONFIG_PROTECT="/etc /usr/share/easy-rsa /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=armv7-a -mtune=cortex-a7  -mfpu=neon-vfpv4 -mfloat-abi=hard"
DISTDIR="/DYSK-PRZETWARZALNIA/usr/portage/distfiles"
FCFLAGS="-O2 -pipe -march=armv7-a"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distcc distcc-pump distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -march=armv7-a"
GENTOO_MIRRORS="http://gentoo.prz.rzeszow.pl"
LANG="pl_PL.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j12 -l12"
PKGDIR="/DYSK-PRZETWARZALNIA/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/DYSK-PRZETWARZALNIA/usr/portage"
PORTDIR_OVERLAY="/DYSK-PRZETWARZALNIA/usr/local/portage"
SYNC="rsync://rsync3.pl.gentoo.org/gentoo-portage"
USE="X acl apache2 arm armv5te armv6 armv6t2 berkdb bindist bzip2 cli cracklib crypt cxx dbus dri egl fortran gdbm gles gles1 gles2 iconv ipv6 libkms libmpeg2 modules ncurses nls nptl openmp openssl pam pcre policykit readline sensord session ssl tcpd thunar unicode zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="mali exynos omap" XFCE_PLUGINS="brightness clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



----------------------------------------------------------------------------------------------------------------------------------

I managed to pull out a little more from GDB.

Code:
Cubietruck etc # gdb /usr/sbin/apache2 -core /var/log/apache2/coredumps/core
GNU gdb (Gentoo 7.7.1 p1) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "armv7a-hardfloat-linux-gnueabi".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/sbin/apache2...Reading symbols from /usr/lib/debug//usr/sbin/apache2.debug...done.
done.
[New LWP 6195]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
Core was generated by `/usr/sbin/apache2 -D DEFAULT_VHOST -D INFO -D LANGUAGE -D SSL -D SSL_DEFAULT_VH'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0xb6eb3938 in apr_bucket_alloc () from /usr/lib/libaprutil-1.so.0
(gdb) bt
#0  0xb6eb3938 in apr_bucket_alloc () from /usr/lib/libaprutil-1.so.0
#1  0xb6eb3e68 in apr_bucket_file_create () from /usr/lib/libaprutil-1.so.0
#2  0x0003af80 in default_handler (r=0x1e1dba8) at core.c:3800
#3  0x00043ecc in ap_run_handler (r=0x1e1dba8) at config.c:157
#4  0x000449f0 in ap_invoke_handler (r=0x1e1dba8) at config.c:376
#5  0x00058f80 in ap_process_request (r=0x1e1dba8) at http_request.c:282
#6  0x000553d4 in ap_process_http_connection (c=0x1e17ad0) at http_core.c:190
#7  0x0004f34c in ap_run_process_connection (c=0x1e17ad0) at connection.c:43
#8  0x0004f90c in ap_process_connection (c=0x1e17ad0, csd=0x1e17938) at connection.c:190
#9  0x00060c84 in child_main (child_num_arg=3) at prefork.c:667
#10 0x00060ea8 in make_child (s=0x1ccefb8, slot=3) at prefork.c:768
#11 0x00060f40 in startup_children (number_to_start=7) at prefork.c:786
#12 0x00061668 in ap_mpm_run (_pconf=0x1ccd0a8, plog=0x1cd30c0, s=0x1ccefb8) at prefork.c:1007
#13 0x00024bfc in main (argc=19, argv=0xbeb59854) at main.c:753
(gdb)


Please help, I have no idea what is wrong.

---------------------------------------------------------------------------------

Good news, I resolved problem with this guide:
http://www.gentoo.org/proj/en/apache/doc/troubleshooting.xml#doc_chap3
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 598

PostPosted: Sat Jan 24, 2015 5:10 pm    Post subject: Re: Apache2 - crash during webpage opening Reply with quote

Mati-PL wrote:
Good news, I resolved problem with this guide:
http://www.gentoo.org/proj/en/apache/doc/troubleshooting.xml#doc_chap3


Please edit your post and add "SOLVED" to the subject line.

:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum