Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[FIXED] Borked keyboard onX
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Mon Dec 15, 2014 11:06 pm    Post subject: [FIXED] Borked keyboard onX Reply with quote

Hi all!
i am configuring an Asus TF700T ARM tablet with dock. Everything works, including X with proprietary Nvidia Tegra3 drivers.

My issue at the moment is with the keyboard layout under X (Xorg server 1.13, since from 1.14 the driver is not stable). The US layout works great, but if i try by layout (the italian layout) it's not working properly, i get a bunch of ? characters from most of the non-ASCII7 keys.

I am using lxde and i set the keymap with setxkbmap "it"...
_________________
Willy Gardiol
willy@gardiol.org


Last edited by shimitar on Tue Dec 16, 2014 1:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Dec 16, 2014 6:45 am    Post subject: Reply with quote

Does your system have an Italian UTF-8 locale installed? Check with "eselect locale list" or "locale -a", and if necessary adjust /etc/locale.gen before running "locale-gen".

If the locale is installed, run "locale" to see if a UTF-8 locale is actually active on your system.

http://wiki.gentoo.org/wiki/Localization/HOWTO#Setting_a_locale
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Tue Dec 16, 2014 9:31 am    Post subject: Reply with quote

Yes i have the it_IT.UTF8 locale in /etc/locale.gen, eselect locale list shows it, and i have set it wwith eselect locale set.

I have also did a reboot, with no luck.

It seems the fonts are missing for some special letters...
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 419

PostPosted: Tue Dec 16, 2014 11:06 am    Post subject: Reply with quote

You could set the expected keyboard layout systemwide on X11 level, instead of user/lxde-settings:

/etc/X11/xorg.conf.d/10-keyboard.conf

Code:
Section "InputClass"
        Identifier      "system-keyboard"
        MatchIsKeyboard "on"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "it"
EndSection


See also here: https://forums.gentoo.org/viewtopic-t-1006274.html
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Tue Dec 16, 2014 1:31 pm    Post subject: Reply with quote

This thing i have is not a pc (it's an Asus ARM tablet with keyboard dock) and definitely it does not have a pc104 keyboard. I will give it a try, but that should not help much i guess
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Tue Dec 16, 2014 1:47 pm    Post subject: Reply with quote

that fixed it...

thank you!
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 419

PostPosted: Tue Dec 16, 2014 8:02 pm    Post subject: Reply with quote

Glad to help. Regarding XkbModel - I guess you could research other options in Xkb documention (103,102?) but if it works for now, might as well leave it there, some scancodes will never be used but who cares ;-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum