Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Solved) Intel 3945ABG
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ALF__
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2003
Posts: 143

PostPosted: Sun Dec 14, 2014 4:19 pm    Post subject: (Solved) Intel 3945ABG Reply with quote

Hello!


Im trying to get wlan working on a freshly installed laptop with Intel 3945ABG wificard in it.

I added the driver built in to my kernel, after that i just emerge wicd.

After that my ethernetcard broke, and for some reason, ifconfig -a shows eth0 and wlan0 (before merging wicd they hade the long names, link enp0blaha)
I cannot put the eth0 up, also, wicd dont find any wireles networks, and the LED for wifi is not lit (the switch for RF is on on the side).

Both card as stated do show up with ifconfig -a though..


any ideas?


Last edited by ALF__ on Mon Jan 05, 2015 8:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
b0nafide
Apprentice
Apprentice


Joined: 17 Feb 2008
Posts: 171
Location: ~/

PostPosted: Sun Dec 14, 2014 7:45 pm    Post subject: Reply with quote

I use openrc, wicd and eudev on my netbook

Code:

# ifconfig | grep "wlan0\|eth0"
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
# ls /etc/init.d/net.eth*
ls: cannot access /etc/init.d/net.eth*: No such file or directory
# grep ^rc_hotplug /etc/rc.conf
rc_hotplug="!net.eth* !net.wlan*"
# rc-update show | grep wicd
    wicd | default


Everything is working for me, I can scan for networks and join them.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Dec 15, 2014 11:28 am    Post subject: Reply with quote

wicd parses iwconfig output, and iwconfig uses the legacy wireless extensions in the kernel. Modern drivers are however nl80211 based.

In order to use iwconfig, backwards compatibility has to be enabled in the kernel configuration through CONFIG_CFG80211_WEXT=y
ALF__ wrote:
I cannot put the eth0 up

What happens when you try?
Back to top
View user's profile Send private message
geraldraaf
n00b
n00b


Joined: 18 Nov 2012
Posts: 7

PostPosted: Mon Dec 15, 2014 1:55 pm    Post subject: Reply with quote

I had the same Problem with builtin kernel driver with my Lenovo Laptop.
The problem was that the Firmware wasn't loaded, after compiling driver as modul everything works fine for me.
Back to top
View user's profile Send private message
ALF__
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2003
Posts: 143

PostPosted: Mon Dec 15, 2014 5:30 pm    Post subject: Reply with quote

chithanh wrote:
wicd parses iwconfig output, and iwconfig uses the legacy wireless extensions in the kernel. Modern drivers are however nl80211 based.

In order to use iwconfig, backwards compatibility has to be enabled in the kernel configuration through CONFIG_CFG80211_WEXT=y
ALF__ wrote:
I cannot put the eth0 up

What happens when you try?


Hello, thanks for your reply.

I do actually have CONFIG_CFG80211_WEXT=y enabled..

After Reading the log for wicd, i see it uses the command ifconfig wlan0 up. And when i try to run that manually i get "cannot allocate memory"
The same goes for starting wpa_supplicant manually, cannot allocate memory. (Dont even know if it should be started)
When i use rfkill i see that none are blocked, however, it reacts to the button on the side, and then sets hardblocked to yes.

Also sorry about the eth0 confusion, i did a stupid mistake and had the laptop in the Ultrabase, ofcourse the LAN Cable needed to be attached to the base instead. Really sorry for that.

geraldraaf wrote:


Thanks for your reply. I was really hoping for it to be this simple, but no :)
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Dec 16, 2014 7:16 am    Post subject: Reply with quote

It seems to be a problem in the kernel iwl3945 causing the memory allocation failure. Check in dmesg if there is more detail about the failure.

This thread suggests a few workarounds, such as "echo 3 > /proc/sys/vm/drop_caches" before running ifconfig wlan0 up.

https://groups.google.com/forum/#%21topic/linux.kernel/Btf81GShwFc

If kernel 3.18 is affected too, you will probably have to report to kernel bugzilla or this issue will be forgotten again.
Back to top
View user's profile Send private message
ALF__
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2003
Posts: 143

PostPosted: Tue Dec 16, 2014 5:49 pm    Post subject: Reply with quote

Hello, and thank you again.

I tried the echo option, and no change..

Also dmesg doesnt output any problem, just that the driver starts and actually finds the card..

Wich makes this even harder to grasp?
Back to top
View user's profile Send private message
ALF__
Tux's lil' helper
Tux's lil' helper


Joined: 30 Nov 2003
Posts: 143

PostPosted: Mon Jan 05, 2015 8:43 pm    Post subject: Reply with quote

Hello!

Well i managed to solve it.

I had no idea i needed a custom firmware for the card. I thought that the kernel-module would do the trick. But you need that and also the custom firmware from intel..

Thanks everyone for your help
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum