Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Genkernel nvidia-drivers fails to build (340.xx and less)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
braindead0
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2003
Posts: 146
Location: Ohio

PostPosted: Sun Dec 14, 2014 1:59 pm    Post subject: Genkernel nvidia-drivers fails to build (340.xx and less) Reply with quote

I updated my system and it upgraded nvidia-drivers to latest (which turns out to not support my 9500 GT). So I package.mask for anything higher than I can us and emerge. To my surprise that failed (it was working fine prior to my update). There were a lot of misleading/incorrect errors in the output that led me down many paths and wasted hours researching on-line.

Key turned out to be missing /usr/src/linux/Modules.symvers something to do with the way Genkernel functions. I ran make modules_install and that build Modules.symvers and nvidia-drivers 340.65 installed fine.

Thought I'd document what I recall of the issue in the hopes that it saves someone else a hassle. Seems every time I use genkernel I regret it doing so, figured I'd use it on this box for simplicity.....ack.
_________________
Poxart
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum