Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] gdm crashes/restarts when logging in
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Forsaken87
n00b
n00b


Joined: 12 Dec 2014
Posts: 1

PostPosted: Sat Dec 13, 2014 1:47 am    Post subject: [solved] gdm crashes/restarts when logging in Reply with quote

Hi there,

I started installing gentoo on my new laptop (Lenovo Thinkpad L540 20AV005KGE) using the eselect-profile "default/linux/amd64/13.0/desktop/gnome/systemd". After resolving some blocks and systemd issues the "emerge gone" worked fine. But when I start gdm (gnome login screen with lockscreen/volume control/networkmanager etc. works fine) and login with my user account the screen turns black (with a cursor in the upper left) and the gnome login screen loads again.
I tried quite a lot:
- Updated all packets
- Fixed every error in logs that looked serious (and was solvable for me)
- Checked owner/access rights for the users home directory (even deleted the user and created it again)
- Started gnome-shell using "startx", exiting the minimal window manager and type gnome-shell into the terminal (worked fine as root and as user, but is no permanent solution)

I would be glad about any idea about what the source of my problem is :?

Edit: Here's my current config-files and logs, if there's anything important missing or you need to know something else just ask me.
https://drive.google.com/file/d/0B_Rx7MRU9jFIRkNoTXNMN3lpVjQ/view?usp=sharing
Edit2: Due making it easier accessibility the most important config files and shortened log entries:
/etc/portage/package.unmask is empty.

Solution: Obviously my attempt to fix the problem by deleting the user and creating it again was successful, but by this the users session was reset to "xsession", which (for some reason) crashed on login. Since I'm going to use gnome i changed this and now everything works fine. Thx and sorry for everyone who took a look.

/etc/portage/make.conf:
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=core-avx2 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j4"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist mmx sse sse2 systemd xa networkmanager"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

# Standard PC (BIOS)
GRUB_PLATFORMS="pc"

ACCEPT_KEYWORDS="~amd64"

# xorg settings
VIDEO_CARDS="intel"
INPUT_DEVICES="evdev"


~/.xsession-error:
Code:
/etc/X11/Sessions/Xsession: Zeile 106: exec: xsm: Nicht gefunden.


/etc/portage/package.use:
Code:
dev-libs/openssl -bindist
net-misc/openssh -bindist


/etc/gdm/custom.conf:
Code:
# GDM configuration storage

[daemon]
AutomaticLoginEnable = false

[security]

[xdmcp]

[greeter]

[chooser]

[debug]


Journal of the login process:
Code:
Dez 13 20:15:49 localhost systemd[11756]: pam_unix(systemd-user:session): session opened for user jens by (uid=0)
Dez 13 20:15:49 localhost systemd[1]: Starting user-1000.slice.
Dez 13 20:15:49 localhost systemd[1]: Created slice user-1000.slice.
Dez 13 20:15:49 localhost systemd[1]: Starting User Manager for UID 1000...
Dez 13 20:15:49 localhost systemd[1]: Starting Session 4 of user jens.
Dez 13 20:15:49 localhost systemd[1]: Started Session 4 of user jens.
Dez 13 20:15:49 localhost systemd-logind[1985]: New session 4 of user jens.
Dez 13 20:15:49 localhost systemd[11756]: Starting Paths.
Dez 13 20:15:49 localhost systemd[11756]: Reached target Paths.
Dez 13 20:15:49 localhost systemd[11756]: Starting Timers.
Dez 13 20:15:49 localhost systemd[11756]: Reached target Timers.
Dez 13 20:15:49 localhost systemd[11756]: Starting Sockets.
Dez 13 20:15:49 localhost systemd[11756]: Reached target Sockets.
Dez 13 20:15:49 localhost systemd[11756]: Starting Basic System.
Dez 13 20:15:49 localhost systemd[11756]: Reached target Basic System.
Dez 13 20:15:49 localhost systemd[11756]: Starting Default.
Dez 13 20:15:49 localhost systemd[11756]: Reached target Default.
Dez 13 20:15:49 localhost systemd[11756]: Startup finished in 13ms.
Dez 13 20:15:49 localhost systemd[1]: Started User Manager for UID 1000.
Dez 13 20:15:49 localhost org.a11y.atspi.Registry[2552]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Dez 13 20:15:49 localhost gdm-session-worker[2537]: <3>GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Dez 13 20:15:49 localhost org.gtk.vfs.Daemon[2545]: A connection to the bus can't be made
Dez 13 20:15:49 localhost org.gtk.vfs.Daemon[2545]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Dez 13 20:15:49 localhost ca.desrt.dconf[2545]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Dez 13 20:15:49 localhost org.freedesktop.IBus[2545]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Dez 13 20:15:49 localhost org.gnome.OnlineAccounts[2545]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Dez 13 20:15:49 localhost org.gtk.Private.UDisks2VolumeMonitor[2545]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0
Dez 13 20:15:49 localhost org.gtk.Private.GoaVolumeMonitor[2545]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). E
Dez 13 20:15:49 localhost org.a11y.Bus[2545]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Dez 13 20:15:49 localhost gnome-session[2541]: (gnome-settings-daemon:2562): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon: Verbindung ist geschlossen
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum