Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kscreen flakey
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dmoulding
n00b
n00b


Joined: 03 Jun 2014
Posts: 18

PostPosted: Fri Dec 12, 2014 6:01 pm    Post subject: kscreen flakey Reply with quote

I did a world update yesterday, and got a huge KDE update. As part of that update, I got kscreen which advised me to do this:

Quote:
Disable the old screen management:
# qdbus org.kde.kded /kded org.kde.kded.unloadModule randrmonitor
# qdbus org.kde.kded /kded org.kde.kded.setModuleAutoloading randrmonitor false

Enable the kded module for the kscreen based screen management:
# qdbus org.kde.kded /kded org.kde.kded.loadModule kscreen

Now simply (un-)plugging displays should enable/disable them, while
the last state is remembered.


I dutifully followed those instructions, but upon reboot my two monitors were now in mirrored mode. So I went into KDE System Settings => Display and Monitor => Display Configuration. Here's where things really started looking horribly wrong. First, it only showed me one monitor, but I had two connected: HDMI-1 and DVI-I-1. It was only showing me HDMI-1. My first thought was, "Uh, oh, it's failing to detect the second monitor."

But then I realized, "How is it mirroring to the second display if it thinks there is only 1?" So I clicked the "i" button to identify displays. BOTH monitors identified themselves as HDMI-1! After a while, I realized that the Display Configuration GUI was hiding DVI-I-1 behind HDMI-1 (out of frustration I tried moving the monitor in the GUI and discovered the other one hiding behind it). Now I could see that it was detecting both monitors.

Clicking the "identify" button still displayed HDMI-1 on both monitors (crazy right?)

So I disabled and reenabled DVI-I-1 in the GUI by deselecting and then re-selecting the checkbox on it. Voila! Now it stopped mirroring the displays and clicking the "identify" button finally showed DVI-I-1 on one monitor and HDMI-1 on the other. All good, right? Problem solved?

Nope. This *same* thing happens everytime I reboot the machine now. It's like kscreen always incorrectly thinks that both monitors are HDMI-1, until I go in and disable/reenable DVI-I-1.

I'm almost tempted to go back to the older KDE so that I can use randrmonitor instead of kscreen again.

Anyone else noticing flakey kscreen behavior?
Back to top
View user's profile Send private message
bensimons
n00b
n00b


Joined: 20 Feb 2014
Posts: 8

PostPosted: Thu Jan 15, 2015 11:55 am    Post subject: Re: kscreen flakey Reply with quote

Yes. It's taken a while to track down. It is the introduction of KScreen.
This post helped clear up what's going on.
http://www.spinics.net/lists/kde/msg21102.html
Check the whole thread.

Also, noted elsewhere, those "qdbus" commands should be run as a regular user, not as root.

I think i'm seeing the same problem as you - 2 screens mirrored - and i think it is because my 2 LG screens are reporting the same EDID so KScreen makes them mirror each other! I have 2 Dell screens, and 2 LG Monitors attached.

Yes, 4 screens. eg:
Code:
   $ kscreen-console |grep ID
  EDID Info:
          Device ID:  "xrandr-LG TV-16843009"
          EISA ID:  ""
  EDID Info:
          Device ID:  "xrandr-DELL P2412H-T0T3836Q17JU"
          EISA ID:  ""
  EDID Info:
          Device ID:  "xrandr-DELL P2412H-T0T3836Q2FEU"
          EISA ID:  ""
  EDID Info:
          Device ID:  "xrandr-LG TV-16843009"
          EISA ID:  ""
  ^C

Note the LG's have the same EDID. I wonder if the KDE KScreen people are reading this?

To see what kscreen offers, you can run:
Code:
  $ kcmshell4 kcm_kscreen

yeh, nvidia-settings is better. I couldn't see where the rules are kept for kscreen, and frankly IDC. Sorry, but it wasn't broken till now..

During the emerge, my primary screen went from screen 1 to screen 3. I created a new user to see what was now happening and KDE would create screens in an odd order. Instead of 1,2,3,4 it was like 3,2,4,1 or approx. Kinda nuts. I logged out, as root moved my ~/.kde4 to a new name, and experimented a bit, but couldn't get it to work or make any sense of it. The fact the 2 LG's had the same EDID didn't seem promising. So i decided to go back to what worked, and back out from kscreen.

I first backed out from KScreen by adding "-kscreen" as a flag in /etc/portage/package.use
Code:
# Thu Jan 15 20:31:47 AEDT 2015
# Undo the default use of kscreen, because it doesn't recognise
# our LG screens - sees them both the same EDID.
# This page: http://www.spinics.net/lists/kde/msg21102.html
# shows how you can get the old krandr kcm and krandrtray applet back.
# [ben 15Jan15]
>=kde-base/systemsettings-4.11.14 -kscreen

But then, to be sure, i changed this by adding "-kscreen" to the USE line in /etc/portage/make.conf
in case kscreen turned up anywhere else. But it doesn't. Setting /etc/portage/package.use will be enough.
Note that "-kscreen" in Gentoo speak means "not" kscreen.

Then you emerge kde-base/systemsettings again, and it will rebuild such that you don't use kscreen.
You will see emerge colouring the "-kscreen" option, telling you it's changed for this emerge:
Code:
Calculating dependencies... done!
[ebuild   R    ] kde-base/systemsettings-4.11.14:4/4.11  USE="gtk handbook opengl usb (-aqua) -debug -kscreen* -nepomuk {-test}" 0 KiB


Doing this means you go back to using krandr or xrandr (which worked just fine for me!!).
It's what's suggested in the post at the top, by Duncan on http://lists.kde.org/ (THANKS Duncan).

As a last step, if you then run "emerge --depclean" you will see kscreen go away...
Code:
 # emerge --depclean
 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
>>> Calculating removal order...

 kde-misc/kscreen
    selected: 1.0.2.1
   protected: none
     omitted: none

 x11-libs/libkscreen
    selected: 1.0.5
   protected: none
     omitted: none
:
:

hope that helps. I have just done this, and it worked. My 4 screens are back to normal.
ben.
Back to top
View user's profile Send private message
dmoulding
n00b
n00b


Joined: 03 Jun 2014
Posts: 18

PostPosted: Fri Jan 16, 2015 7:16 pm    Post subject: Reply with quote

Thanks for the reply ben. I had just been living with the flakey kscreen behavior since the upgrade. I guess I was hoping an update would come out soon that would fix it. But your reply motivated me to do something about it. So I added -kscreen and went back to good-ol randrmonitor, which "just works".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum