Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kmail can't start after upgrade vs akonadi and mysql
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
phd
n00b
n00b


Joined: 12 Oct 2005
Posts: 65
Location: Warszawa (Poland)

PostPosted: Mon Dec 01, 2014 2:29 pm    Post subject: kmail can't start after upgrade vs akonadi and mysql Reply with quote

After upgrade (emerge -uDN @world) I have problem with running kmail. There is some problem with akonadi-server. I would like to remove competently old kmail config files and set up kmail from the beginning. To this aim, due to some errors with opening kmail, I had removed the file /home/user/.local/share/akonadi/db_data/mysql.err but didn't helped and still I cannot restart kmail. I have upgraded mysql by using the option --socket=/tmp/akonadi-.../mysql.socket . Still the same.

This is akonadi-selftest-report-20141201.txt https://bpaste.net/show/e4c3e6beab73

Edit:
I added a new user, started kde, and checked that there is no problem to setup the personal data and start akonadi server for a new user. This proves that something was going wrong with upgrade of my personal account data (mysql? akonadi?) and/or in another program. Maybe I changed unfortunately the access to some configuration files. Previously, I had noted that my account was available for other users and I was forced to limit the access for my all account.

To avoid hacking my KDE session by anybody having access to my keyboard
Quote:
Ctr+Alt+F1 and next Ctr+C
I used to start KDE manually from terminal by means
Quote:
startx& logout
maybe this caused a problem. For me, the most convenient would be to recover the access to the old KDE user account than to move my personal data and setup a new KDE user account. Any suggestions what was going wrong?
Back to top
View user's profile Send private message
gigel
Guru
Guru


Joined: 14 Jan 2003
Posts: 350
Location: .se/.ro

PostPosted: Mon Dec 22, 2014 3:51 pm    Post subject: Reply with quote

emerge -C akonadi-server kmail
emerge thunderbird or whatever. this should fix your problems!
_________________
$emerge sux
:D
Back to top
View user's profile Send private message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 639

PostPosted: Tue Dec 23, 2014 10:16 am    Post subject: Reply with quote

Try deleting the akonadi database directory. As it's just a cache, KDE will rebuild it from scratch.

See https://forums.gentoo.org/viewtopic-t-1002506-highlight-akonadi.html
_________________
Greybeard
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum