Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia-optimus+xrandr+xfce: how to cfg multihead [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
SemmZemm
n00b
n00b


Joined: 05 Jul 2013
Posts: 62
Location: France, Russia

PostPosted: Fri Nov 28, 2014 8:13 pm    Post subject: nvidia-optimus+xrandr+xfce: how to cfg multihead [SOLVED] Reply with quote

Hi,

I have a laptop with optimus videocard configured with randr.
Here is my .xinitrc

Code:
#!/bin/sh
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
startxfce4


It worked until I wanted to connect an external screen.

With external screen I can see terminal.
If the screen is connected before I execute "startx" I see the same picture on both screens.

But when I try to modify my .xinitrc like this:
Code:
#!/bin/sh
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --output LVDS-1-0 --auto --output VGA-1-0 --auto --left-of LVDS-1-0
startxfce4

both screens are black. What do I do wrong?


Last edited by SemmZemm on Sun Nov 30, 2014 2:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
SemmZemm
n00b
n00b


Joined: 05 Jul 2013
Posts: 62
Location: France, Russia

PostPosted: Sun Nov 30, 2014 2:10 pm    Post subject: Reply with quote

solved changing XFCE settings:

Applications > Settings > Settings Manager > Display. Check on and check off "Mirror display" checkbox.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum