Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] syslog : annoying msg : "json-parser() is missing"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3710
Location: Hamburg

PostPosted: Thu Nov 27, 2014 6:25 pm    Post subject: [solved] syslog : annoying msg : "json-parser() is miss Reply with quote

I do get it during (re)start:
Code:
$ sudo /etc/init.d/syslog-ng restart
 * Stopping syslog-ng ...                                                                         [ ok ]
 * Checking your configfile (/etc/syslog-ng/syslog-ng.conf) ...
[2014-11-27T19:22:52.086582] system(): json-parser() is missing, skipping the automatic JSON parsing of messages submitted via syslog(3), Please install the json module;                                 [ ok ]
 * Starting syslog-ng ...
[2014-11-27T19:22:52.213893] system(): json-parser() is missing, skipping the automatic JSON parsing of messages submitted via syslog(3), Please install the json module;       
, and yes, I do have USE=-json, should I just ignore thatmessage or is this an (ebuild) bug ?

Last edited by toralf on Wed Dec 10, 2014 7:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
mahdi1234
Guru
Guru


Joined: 19 Feb 2005
Posts: 539
Location: far from new world orderia

PostPosted: Thu Nov 27, 2014 9:47 pm    Post subject: Reply with quote

There's already a bug for this one - https://bugs.gentoo.org/show_bug.cgi?id=528882 ... doesn't answer your question completely though
_________________
http://gentoo.mahdi.cz <-- gentoo package search engine
Back to top
View user's profile Send private message
lmiphay
n00b
n00b


Joined: 10 Dec 2007
Posts: 4
Location: Dublin, Ireland

PostPosted: Mon Dec 08, 2014 1:17 pm    Post subject: Reply with quote

mahdi1234 wrote:
There's already a bug for this one - https://bugs.gentoo.org/show_bug.cgi?id=528882 ... doesn't answer your question completely though


Thanks for this - adding the json use flag as suggested in the first comment fixed this for me.

The missing json parser message was accompanied by this error message, which I haven't yet seen repeated however:

syslog-ng[1293]: Unable to detect fully qualified hostname for localhost, use_fqdn() will use the short hostname;
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum