Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] /etc/fstab partizione NTFS
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrfabiolo
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2011
Posts: 88

PostPosted: Wed Nov 26, 2014 7:07 pm    Post subject: [RISOLTO] /etc/fstab partizione NTFS Reply with quote

Ho una partizione NTFS sull'hard disk:
Generalmente posso montarla senza problemi così:
Code:
sudo mount /dev/sda5 /archive


Però anche se metto la riga in /etc/fstab non viene montata in automatico.
Code:
┌❨0 ✓❩─[mrlogick@tux]─[3, 636KB]─[20:06]
└[~] ➤ cat /etc/fstab
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sdb2      /      ext4      noatime,discard   0 1
/dev/sdb1      none      swap      sw      0 0
/dev/sd5      /archive   ntfs-3g      defaults   0 0

/dev/cdrom      /mnt/cdrom   auto      noauto,ro   0 0




Code:
┌❨0 ✓❩─[mrlogick@tux]─[3, 636KB]─[20:04]
└[~] ➤ sudo fdisk -l
Password:

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x5ccf1688
Partition 3 does not start on physical sector boundary.

Device    Boot     Start       End    Blocks  Id System
/dev/sda1 *         2048    718847    358400   7 HPFS/NTFS/exFAT
/dev/sda2         718848 307202047 153241600   7 HPFS/NTFS/exFAT
/dev/sda3      307204094 976773119 334784513   5 Extended
/dev/sda5      567173120 976773119 204800000   7 HPFS/NTFS/exFAT
/dev/sda6      307206144 404862975  48828416  83 Linux
/dev/sda7      404865024 502521855  48828416  83 Linux
/dev/sda8      502523904 567173119  32324608  83 Linux

Partition table entries are not in disk order.

Disk /dev/sdb: 22.4 GiB, 24015495168 bytes, 46905264 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0003a70a

Device    Boot     Start       End   Blocks  Id System
/dev/sdb1           2048   1050623   524288  82 Linux swap / Solaris
/dev/sdb2        1050624  46905263 22927320  83 Linux


Last edited by mrfabiolo on Wed Nov 26, 2014 8:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Wed Nov 26, 2014 7:12 pm    Post subject: Re: /etc/fstab partizione NTFS Reply with quote

mrfabiolo wrote:

# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs> <mountpoint> <type> <opts> <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sdb2 / ext4 noatime,discard 0 1
/dev/sdb1 none swap sw 0 0
/dev/sd 5 /archive ntfs-3g defaults 0 0

/dev/cdrom /mnt/cdrom auto noauto,ro 0 0[/code]

Manca una lettera :P
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
mrfabiolo
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2011
Posts: 88

PostPosted: Wed Nov 26, 2014 8:34 pm    Post subject: Reply with quote

Scusate... che vergogna.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Wed Nov 26, 2014 8:41 pm    Post subject: Reply with quote

Ma sì, capita a tutti :wink: ... Visto che usi ntfs-3g, considera anche le opzioni "locale" (nel caso trovassi caratteri strani nei nomi file) e "permissions":

Code:

permissions
              Set standard permissions on created files and use standard access control.  This option is set  by
              default when a user mapping file is present.

locale=value
              This option can be useful when wanting a language specific locale environment.  It is however dis‐
              couraged as it leads to files with untranslatable chars to not be visible.

_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum