Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
plasma-desktop and kwin segfault on a brand new system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
filo1234
n00b
n00b


Joined: 23 Nov 2014
Posts: 3

PostPosted: Sun Nov 23, 2014 8:39 am    Post subject: plasma-desktop and kwin segfault on a brand new system Reply with quote

I recently installed Gentoo on a brand new laptop, plasma-desktop and kwin segfault when I start KDE.

  1. I compiled everything with x86_64-pc-linux-gnu-4.8.3 (the default from recent stage3) kwin and plasma-workspaces were 4.11.9
  2. I had it with Qt 4.8.5
  3. I tried recompiling the same Qt version with gcc 4.9.2
  4. I tried it with Qt 4.8.6-r1 (compiled with gcc 4.9.2)
  5. then I tried kwin and plasma-workspaces 4.11.14 (gcc 4.9.2) - did not help :(


I thought that maybe it is caused by moving my whole ~/ from a different machine, so I created a new empty user account, logged in successfully, but when I tried to log in again everything fails the same way.

plasma segfault:
Code:

Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0ab8d88780 (LWP 3391))]

Thread 2 (Thread 0x7f0a925d5700 (LWP 3392)):
#0  0x00007f0ab763f42c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0aac8f92e4 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#2  0x00007f0aac8f933a in ?? () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007f0ab763b213 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0ab63944ad in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f0ab8d88780 (LWP 3391)):
[KCrash Handler]
#5  0x00007f0aac8917f4 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#6  0x00007f0aac8d0c1a in ?? () from /usr/lib64/qt4/libQtScript.so.4
#7  0x00007f0aac8d0d10 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#8  0x00007f0aac8cf713 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#9  0x00007f0aac8cfb8f in ?? () from /usr/lib64/qt4/libQtScript.so.4
#10 0x00007f0aac917369 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#11 0x00007f0aac917caf in QScriptEngine::QScriptEngine() () from /usr/lib64/qt4/libQtScript.so.4
#12 0x00007f0aac1d3bff in ?? () from /usr/lib64/qt4/libQtDeclarative.so.4
#13 0x00007f0aac1da29b in ?? () from /usr/lib64/qt4/libQtDeclarative.so.4
#14 0x00007f0aac1da572 in QDeclarativeEngine::QDeclarativeEngine(QObject*) () from /usr/lib64/qt4/libQtDeclarative.so.4
#15 0x00007f0aaea3328c in Plasma::DeclarativeWidget::DeclarativeWidget(QGraphicsWidget*) () from /usr/lib64/libplasma.so.3
#16 0x00007f0a9423f69e in ?? () from /usr/lib64/kde4/plasma_applet_pager.so
#17 0x00007f0a94242e19 in ?? () from /usr/lib64/kde4/plasma_applet_pager.so
#18 0x00007f0aae97ff7c in ?? () from /usr/lib64/libplasma.so.3
#19 0x00007f0aae98ce7c in ?? () from /usr/lib64/libplasma.so.3
#20 0x00007f0aae98d87a in Plasma::Corona::loadLayout(QString const&) () from /usr/lib64/libplasma.so.3
#21 0x00007f0aae98d934 in Plasma::Corona::initializeLayout(QString const&) () from /usr/lib64/libplasma.so.3
#22 0x00007f0aa5c835e7 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#23 0x00007f0aa5c83a84 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#24 0x00007f0aa5c87a65 in ?? () from /usr/lib64/libkdeinit4_plasma-desktop.so
#25 0x00007f0ab79f1e91 in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00007f0ab6b2a143 in QApplication::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#27 0x00007f0ab6b24d4c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#28 0x00007f0ab6b2b96b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#29 0x00007f0ab878c21a in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#30 0x00007f0ab79d879d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#31 0x00007f0ab79dbc9c in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#32 0x00007f0ab7a081ee in ?? () from /usr/lib64/qt4/libQtCore.so.4
#33 0x00007f0ab3259c64 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f0ab3259ea8 in ?? () from /usr/lib64/libglib-2.0.so.0
#35 0x00007f0ab3259f4c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f0ab7a08361 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#37 0x00007f0ab6bc9b86 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#38 0x00007f0ab79d72f1 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#39 0x00007f0ab79d7655 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#40 0x00007f0ab79dce49 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#41 0x00007f0aa5c683dd in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#42 0x00000000004080d5 in _start ()


First kwin segfault:
Code:

Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3aded967c0 (LWP 3351))]

Thread 2 (Thread 0x7f3ac505f700 (LWP 3354)):
#0  0x00007f3ad906e42c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3add7c82e4 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#2  0x00007f3add7c833a in ?? () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007f3ad906a213 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f3ade59c4ad in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f3aded967c0 (LWP 3351)):
[KCrash Handler]
#5  0x00007f3add7607f4 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#6  0x00007f3add79fc1a in ?? () from /usr/lib64/qt4/libQtScript.so.4
#7  0x00007f3add79fd10 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#8  0x00007f3add79e713 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#9  0x00007f3add79eb8f in ?? () from /usr/lib64/qt4/libQtScript.so.4
#10 0x00007f3add7e6369 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#11 0x00007f3add7e6caf in QScriptEngine::QScriptEngine() () from /usr/lib64/qt4/libQtScript.so.4
#12 0x00007f3addc57bff in ?? () from /usr/lib64/qt4/libQtDeclarative.so.4
#13 0x00007f3addc5e29b in ?? () from /usr/lib64/qt4/libQtDeclarative.so.4
#14 0x00007f3addc5e572 in QDeclarativeEngine::QDeclarativeEngine(QObject*) () from /usr/lib64/qt4/libQtDeclarative.so.4
#15 0x00007f3ac50699ba in ?? () from /usr/lib64/kde4/kwin3_aurorae.so
#16 0x00007f3ac5069a36 in ?? () from /usr/lib64/kde4/kwin3_aurorae.so
#17 0x00007f3ac506a629 in create_factory () from /usr/lib64/kde4/kwin3_aurorae.so
#18 0x00007f3ade2a624c in KDecorationPlugins::loadPlugin(QString) () from /usr/lib64/libkdecorations.so.4
#19 0x00007f3ade8d8e25 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#20 0x00007f3ade8d8ea1 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#21 0x00007f3ade8af210 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#22 0x00007f3ade8cfdb7 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#23 0x00007f3ade8d191d in kdemain () from /usr/lib64/libkdeinit4_kwin.so
#24 0x00007f3ade4d5a65 in __libc_start_main () from /lib64/libc.so.6
#25 0x000000000040076e in _start ()


Second kwin crash (both happen at the same time)
Code:

Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f42675a27c0 (LWP 3365))]

Thread 2 (Thread 0x7f424d86b700 (LWP 3368)):
#0  0x00007f426187a42c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4265fd42e4 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#2  0x00007f4265fd433a in ?? () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007f4261876213 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f4266da84ad in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f42675a27c0 (LWP 3365)):
[KCrash Handler]
#5  0x00007f4265f6c7f4 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#6  0x00007f4265fabc1a in ?? () from /usr/lib64/qt4/libQtScript.so.4
#7  0x00007f4265fabd10 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#8  0x00007f4265faa713 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#9  0x00007f4265faab8f in ?? () from /usr/lib64/qt4/libQtScript.so.4
#10 0x00007f4265ff2369 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#11 0x00007f4265ff2caf in QScriptEngine::QScriptEngine() () from /usr/lib64/qt4/libQtScript.so.4
#12 0x00007f4266463bff in ?? () from /usr/lib64/qt4/libQtDeclarative.so.4
#13 0x00007f426646a29b in ?? () from /usr/lib64/qt4/libQtDeclarative.so.4
#14 0x00007f426646a572 in QDeclarativeEngine::QDeclarativeEngine(QObject*) () from /usr/lib64/qt4/libQtDeclarative.so.4
#15 0x00007f424d8759ba in ?? () from /usr/lib64/kde4/kwin3_aurorae.so
#16 0x00007f424d875a36 in ?? () from /usr/lib64/kde4/kwin3_aurorae.so
#17 0x00007f424d876629 in create_factory () from /usr/lib64/kde4/kwin3_aurorae.so
#18 0x00007f4266ab224c in KDecorationPlugins::loadPlugin(QString) () from /usr/lib64/libkdecorations.so.4
#19 0x00007f42670e4e25 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#20 0x00007f42670e4ea1 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#21 0x00007f42670bb210 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#22 0x00007f42670dbdb7 in ?? () from /usr/lib64/libkdeinit4_kwin.so
#23 0x00007f42670dd91d in kdemain () from /usr/lib64/libkdeinit4_kwin.so
#24 0x00007f4266ce1a65 in __libc_start_main () from /lib64/libc.so.6
#25 0x000000000040076e in _start ()


emerge --info
Code:

Portage 2.2.8-r2 (default/linux/amd64/13.0/desktop/kde, gcc-4.9.2, glibc-2.19-r1, 3.18.0-rc5-non x86_64)
=================================================================
System uname: Linux-3.18.0-rc5-[/list][/list]x86_64-Intel-R-_Core-TM-_i5-4210U_CPU_@_1.70GHz-with-gentoo-2.2
KiB Mem:     8103288 total,   7398408 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Fri, 21 Nov 2014 09:30:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.7, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3, 4.9.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/home/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 ao audiofile bash-completion bcmath berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt css cups curl cvs cxx dbus declarative djvu dri dts dv dvb dvd dvdr emboss encode exif extraengine fam fbcondecor ffmpeg fftw firefox flac fortran ftp gd gdbm gif git glamor glut gnuplot gnutls gpm gsm gstreamer gtk gzip iconv imagemagick imap ipv6 jabber java javascript jpeg jpeg2k kde kipi lame lcms ldap libnotify libsamplerate lm_sensors lzma lzo mad matroska mhash mime mmx mng modules mozilla mp3 mp4 mpeg mplayer multilib mysql ncurses nls nptl offensive ogg opengl openmp pam pango pcntl pcre pdf phonon php plasma png policykit portaudio postgres postscript ppds pulseaudio qt3support qt4 quicktime rdesktop readline rss sdl semantic-desktop session smartcard sound sox speex spell sqlite sqlite3 sse sse2 sse3 sse4_1 ssl ssse3 startup-notification subversion svg syslog sysvipc tcpd theora threads tidy tiff truetype udev udisks unicode upower usb v4l vnc vorbis webkit wifi wmf wxwidgets x264 xcb xcomposite xine xinerama xinted xml xmlrpc xmpp xpm xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 216
Location: Cali - Colombia

PostPosted: Wed Nov 26, 2014 3:46 pm    Post subject: Reply with quote

Have you rebuilt kdelibs and kwebkitpart?
_________________
abe
Back to top
View user's profile Send private message
filo1234
n00b
n00b


Joined: 23 Nov 2014
Posts: 3

PostPosted: Thu Nov 27, 2014 3:18 pm    Post subject: Reply with quote

I did a complete emerge -e world with gcc 4.8.3. It did not help.

I have segfaults with other applications like kadu (a Qt IM)
Code:

======= BEGIN OF BACKTRACE =====
[0] kadu() [0x404d80]
[1] /lib64/libc.so.6(+0x34ee0) [0x7f52e1e9eee0]
[2] /usr/lib64/qt4/libQtWebKit.so.4(+0x1143789) [0x7f52e5d66789]
[3] /usr/lib64/qt4/libQtWebKit.so.4(+0x122c6a4) [0x7f52e5e4f6a4]
[4] /usr/lib64/qt4/libQtWebKit.so.4(+0x118f19c) [0x7f52e5db219c]
[5] /usr/lib64/qt4/libQtWebKit.so.4(+0x11917f4) [0x7f52e5db47f4]
[6] /usr/lib64/qt4/libQtWebKit.so.4(+0x907f22) [0x7f52e552af22]
[7] /usr/lib64/qt4/libQtWebKit.so.4(+0x8ec90d) [0x7f52e550f90d]
[8] /usr/lib64/qt4/libQtWebKit.so.4(+0x954492) [0x7f52e5577492]
[9] /usr/lib64/qt4/libQtWebKit.so.4(+0x8ebeee) [0x7f52e550eeee]
[10] /usr/lib64/qt4/libQtWebKit.so.4(_ZN9QWebFrame18evaluateJavaScriptERK7QString+0x242) [0x7f52e54b9ee2]
[11] /usr/local/lib64/kadu/libkadu.so(+0x212038) [0x7f52e763f038]
[12] /usr/local/lib64/kadu/libkadu.so(_ZN10KaduWindow9createGuiEv+0xd9) [0x7f52e76b0099]
[13] /usr/local/lib64/kadu/libkadu.so(_ZN10KaduWindowC1Ev+0x18c) [0x7f52e76b062c]
[14] /usr/local/lib64/kadu/libkadu.so(_ZN4Core9createGuiEv+0x1e) [0x7f52e75f693e]
[15] kadu() [0x403a5d]
[16] /lib64/libc.so.6(__libc_start_main+0xf5) [0x7f52e1e8baa5]
[17] kadu() [0x404091]
======= END OF BACKTRACE  ======
Aborted


I thought that it might be a Qt issue but Midori also crashes (it's based on GTK webkit, so no Qt dependencies here):
Code:

1   0x7f85f7eae1e7 /usr/lib64/libjavascriptcoregtk-3.0.so.0(WTFCrash+0x17) [0x7f85f7eae1e7]
2   0x7f85f7ec9e55 /usr/lib64/libjavascriptcoregtk-3.0.so.0(_ZN3WTF11OSAllocator18reserveUncommittedEmNS0_5UsageEbbb+0x55) [0x7f85f7ec9e55]
3   0x7f85f7c456c8 /usr/lib64/libjavascriptcoregtk-3.0.so.0(_ZN3JSC19ExecutableAllocator19initializeAllocatorEv+0x98) [0x7f85f7c456c8]
4   0x7f85f7d8f3c2 /usr/lib64/libjavascriptcoregtk-3.0.so.0(+0x4993c2) [0x7f85f7d8f3c2]
5   0x7f85f74e08e0 /lib64/libpthread.so.0(pthread_once+0x50) [0x7f85f74e08e0]
6   0x7f85f7d8f426 /usr/lib64/libjavascriptcoregtk-3.0.so.0(_ZN3JSC19initializeThreadingEv+0x56) [0x7f85f7d8f426]
7   0x7f85fae4efb9 /usr/lib64/libwebkit2gtk-3.0.so.25(+0x48dfb9) [0x7f85fae4efb9]
8   0x7f85faed9f68 /usr/lib64/libwebkit2gtk-3.0.so.25(+0x518f68) [0x7f85faed9f68]
9   0x7f85fae8a3ec /usr/lib64/libwebkit2gtk-3.0.so.25(+0x4c93ec) [0x7f85fae8a3ec]
10  0x7f85fd80f858 /usr/lib64/libglib-2.0.so.0(g_once_impl+0x58) [0x7f85fd80f858]
11  0x7f85fae8a8b1 /usr/lib64/libwebkit2gtk-3.0.so.25(webkit_web_context_get_default+0x31) [0x7f85fae8a8b1]
12  0x7f85fdd9a625 /usr/lib64/libmidori-core.so.1(midori_paths_init+0x6f5) [0x7f85fdd9a625]
13  0x7f85fdd862cc /usr/lib64/libmidori-core.so.1(midori_normal_app_new+0x47c) [0x7f85fdd862cc]
14  0x402f2d midori(main+0xd7d) [0x402f2d]
15  0x7f85fa64daa5 /lib64/libc.so.6(__libc_start_main+0xf5) [0x7f85fa64daa5]
16  0x402fd5 midori() [0x402fd5]
Segmentation fault


Openbox, Konsole, Chrome, Firefox-bin and some other X applications work fine, so X is not that much broken, direct rendering is enabled. The system was installed using sysrescuecd from a recent amd64 stage3 tarball. It is a Toshiba Tecra Z50 laptop with Intel i5-4210U.
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 216
Location: Cali - Colombia

PostPosted: Thu Nov 27, 2014 4:02 pm    Post subject: Reply with quote

Your CXXFLAGS and LDFLAGS look ok and gcc-4.9.2 is discarded. Could it be a (physical) memory problem?
_________________
abe
Back to top
View user's profile Send private message
filo1234
n00b
n00b


Joined: 23 Nov 2014
Posts: 3

PostPosted: Thu Nov 27, 2014 4:45 pm    Post subject: Reply with quote

I don't think so. Windows 7 runs just fine. Right now I ran memtest86+ for 9 minutes - zero errors.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum