Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Display manager problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tomosius
n00b
n00b


Joined: 19 Jun 2005
Posts: 49

PostPosted: Tue Nov 18, 2014 10:00 am    Post subject: Display manager problems Reply with quote

Hello,

Sorry i am having again few questions:

Id i use nvidia optimus, and use xorg.conf with my custom setup and .xinitrc, it is fine, i can use optimus with XRAND settings:
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

but problem starts here:
if i try to setup any of these managers, that support xrandr commands (i tried all i could find display managers, even kdm), all of them give me black screen and xfce4 is not loading. i would say it is quite strange, because startx is working, optimus is working. what could be wrong?

xorg.conf:
ection "ServerLayout"
Identifier "layout"
Screen 0 "nvidia"
Inactive "intel"
EndSection

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:01:00:0"
EndSection

Section "Screen"
Identifier "nvidia"
Device "nvidia"
# Uncomment this line if your computer has no display devices connected to
# the NVIDIA GPU. Leave it commented if you have display devices
# connected to the NVIDIA GPU that you would like to use.
Option "UseDisplayDevice" "none"
EndSection

Section "Device"
Identifier "intel"
Driver "modesetting"
EndSection

Section "Screen"
Identifier "intel"
Device "intel"
EndSection




P.S.: i have no idea, but in section "BusID "PCI:01:00:0" i had to put this way, because BusID "PCI:01:00.0" was not working. maybe this is a problem?
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 738

PostPosted: Tue Nov 18, 2014 9:48 pm    Post subject: Reply with quote

lightdm works well. The xrandr setup script goes into /etc/lightdm/lightdm.conf:display-setup-script
Code:

display-setup-script=/usr/bin/lightdmxrandr

For xorg, try BusID "PCI:1:0:0" in the nvidia Device section, and add BusID "PCI:0:2:0" to the intel Device section.
Back to top
View user's profile Send private message
Tomosius
n00b
n00b


Joined: 19 Jun 2005
Posts: 49

PostPosted: Tue Nov 18, 2014 10:29 pm    Post subject: Reply with quote

Hi Nell,

Than you for reply, but it does not work, as i have mentioned above. it is very strange for me, but it does not work...
i have looked on Gentoo wiki, arch linux wiki, all those Display managers... nothing works.....
but startx is fine, and i get it working when try to run test: glxspheres64.

Tonight i will try to recompile all system and tomorrow will give another try.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum