Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge: there are no ebuilds to satisfy ">=x11-libs/libX11..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
zarere
n00b
n00b


Joined: 11 Nov 2014
Posts: 2

PostPosted: Tue Nov 11, 2014 3:51 pm    Post subject: emerge: there are no ebuilds to satisfy ">=x11-libs/ Reply with quote

Hi All,

Can someone help me to solve this issue?



alias |grep emrun
alias emrun='sudo emerge --update --newuse --deep --with-bdeps=y world -a'
$ emrun

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "sys-apps/tcp-wrappers[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
!!! One of the following packages is required to complete your request:
- media-sound/pulseaudio-5.0-r5::gentoo (Change USE: -abi_x86_32)
(dependency required by "media-sound/pulseaudio-5.0-r5" [ebuild])
(dependency required by "net-im/skype-4.3.0.37-r2[pulseaudio]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

10x in advance

P.S. i just read this
Code:
Code Listing 5.6: Portage error about USE flag change requirement

emerge: there are no ebuilds built with USE flags to satisfy "app-text/feelings[test]".
!!! One of the following packages is required to complete your request:
- app-text/feelings-1.0.0 (Change USE: +test)
(dependency required by "app-text/happypackage-2.0" [ebuild])
(dependency required by "happypackage" [argument])

Such warning or error occurs when you want to install a package which not only depends on another package, but also requires that that package is built with a particular USE flag (or set of USE flags). In the given example, the package app-text/feelings needs to be built with USE="test", but this USE flag is not set on the system.

To resolve this, either add the requested USE flag to your global USE flags in /etc/portage/make.conf, or set it for the specific package in /etc/portage/package.use.

from handbook :-)


Last edited by zarere on Tue Nov 11, 2014 5:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1423

PostPosted: Tue Nov 11, 2014 5:31 pm    Post subject: Reply with quote

This is a nonsense.
Are you bot o human?
Back to top
View user's profile Send private message
zarere
n00b
n00b


Joined: 11 Nov 2014
Posts: 2

PostPosted: Tue Nov 11, 2014 5:37 pm    Post subject: Reply with quote

What is non sense you decide if I'm bot or not :-)
I fixed the issue so the topic can be closed,

Cheers
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum