Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ON HOLD] Installing KDE - what's needed?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Thu Nov 06, 2014 9:59 am    Post subject: [ON HOLD] Installing KDE - what's needed? Reply with quote

In the wiki it says that these services should be set up before installing KDE:
Quote:
D-Bus: Enables use of the D-Bus message bus system.
polkit: Enables the polkit framework for controlling privileges for system-wide services.
udev: Enables support for udev Linux dynamic and persistent device naming.
udisks: Enables support for some storage related services.

How can I check if they are there?

And what should I do with:
Quote:

[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1.10-r2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-fs/eudev-1.10-r2::gentoo, ebuild scheduled for merge) pulled in by
>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1::gentoo, ebuild scheduled for merge)

(sys-fs/udev-215::gentoo, installed) pulled in by
>=sys-fs/udev-208-r1 required by (virtual/udev-215::gentoo, installed)
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-)]) required by (virtual/libudev-215-r1::gentoo, installed)

Got that when I tried 'pretended'-install of kde.

Also, I seem to get those version conflicts every now and then, so should I update more often or what?
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)


Last edited by turboscrew on Sat Nov 08, 2014 9:33 am; edited 1 time in total
Back to top
View user's profile Send private message
sera
Retired Dev
Retired Dev


Joined: 29 Feb 2008
Posts: 1017
Location: CET

PostPosted: Thu Nov 06, 2014 10:11 am    Post subject: Re: Installing KDE - what's needed? Reply with quote

turboscrew wrote:
In the wiki it says that these services should be set up before installing KDE:
Quote:
D-Bus: Enables use of the D-Bus message bus system.
polkit: Enables the polkit framework for controlling privileges for system-wide services.
udev: Enables support for udev Linux dynamic and persistent device naming.
udisks: Enables support for some storage related services.

How can I check if they are there?

They will be pulled in if needed, if there are useflags it's up to you whether to use them or not.

Quote:

And what should I do with:
Quote:

[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1.10-r2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-fs/eudev-1.10-r2::gentoo, ebuild scheduled for merge) pulled in by
>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1::gentoo, ebuild scheduled for merge)

(sys-fs/udev-215::gentoo, installed) pulled in by
>=sys-fs/udev-208-r1 required by (virtual/udev-215::gentoo, installed)
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-)]) required by (virtual/libudev-215-r1::gentoo, installed)

Got that when I tried 'pretended'-install of kde.

Also, I seem to get those version conflicts every now and then, so should I update more often or what?

You can help Portage a great deal by cutting off parts of the tree you aren't going to use anyway, just package.mask what you do not want.
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Sat Nov 08, 2014 9:31 am    Post subject: Reply with quote

Thanks, I'll look into it, but now I have to put KDE installing on hold. Severe illness case in family. I won't have time for a while.
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Wed Mar 04, 2015 4:24 pm    Post subject: Reply with quote

The illness case was fatal - I'm a widower now.
Maybe I'll continue (or restart) the installation in the near future.
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum