Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Composition not working with urxvt
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
aditya3098
n00b
n00b


Joined: 05 Nov 2014
Posts: 19
Location: India

PostPosted: Wed Nov 05, 2014 10:42 am    Post subject: Composition not working with urxvt Reply with quote

I compiled urxvt with the following use flags for true transparency:
x11-terms/rxvt-unicode fading-colors font-styles mousewheel perl truetype -256-color -afterimage -alt-font-width -blink -focused-urgency -iso14755 -pixbuf -startup-notification -unicode3 -vanilla -wcwidth

I get true transparency, but it is unable to control the opacity. The terminals are completely transparent. This happens with xcompmgr or compton. I tried both awesome and openbox wm.

I dont have this error on other terminal emulators.

[img]http://postimg.com/thumbs/174000/error-173480.jpg[/img]
[img]http://postimg.com/thumbs/174000/error2-173481.jpg[/img]
[img]http://postimg.com/thumbs/174000/yetanothererror-173482.jpg[/img]
_________________
The day microsoft makes a product that doesn't suck, is the day they make a vacuum cleaner.
https://forums.gentoo.org/viewtopic-t-1002264.html systemd-kerneld is comming...(dramatic pause)...soon
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Thu Nov 06, 2014 11:02 pm    Post subject: Reply with quote

Not sure, posting the output from `xrdb -query` and your actual .Xresources file would be useful.
Back to top
View user's profile Send private message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Wed Nov 12, 2014 9:16 am    Post subject: Reply with quote

Looking at your third thumb I don't see it completely transparent as the background changes color. I guess this is an issue on your .Xdefaults?

For what its worth, here are my USE flags
Code:
$ emerge -pv rxvt-unicode

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-terms/rxvt-unicode-9.20  USE="256-color focused-urgency font-styles mousewheel perl pixbuf vanilla xft -alt-font-width -blink -buffer-on-clear -fading-colors -iso14755 -secondary-wheel -startup-notification -unicode3 -wcwidth" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

and transparency I set with my .Xdefaults which is
Code:
 $ cat .Xdefaults
URxvt.font:                     xft:monospace:size=8:antialias=false
!CTRL+SHIFT+V to paste and select to copy.
URxvt.keysym.Shift-Control-V:      perl:clipboard:paste
URxvt.iso14755:   True
URxvt.perl-ext-common:            default,clipboard,matcher,font-size
!CTRL+SHIFT+N to new window!
URxvt.keysim.Shift-Control-N:      command:urxvt&
!Mark and make links clickable
URxvt.url-launcher:               /usr/bin/firefox-bin
URxvt.matcher.button:            1
URxvt.colorUL:                  #4682B4
!Make the window slightly transparent
URxvt.depth:                  32
URxvt.background:               rgba:0000/0000/0000/aaff
URxvt.foreground:               [80]white
!Change Font size on the fly
URxvt.keysym.Shift-Control-Up:      perl:font-size:increase
URxvt.keysym.Shift-Control-Down:   perl:font-size:decrease
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3690
Location: Dallas area

PostPosted: Wed Nov 12, 2014 12:14 pm    Post subject: Re: Composition not working with urxvt Reply with quote

aditya3098 wrote:
I compiled urxvt with the following use flags for true transparency:
x11-terms/rxvt-unicode fading-colors font-styles mousewheel perl truetype -256-color -afterimage -alt-font-width -blink -focused-urgency -iso14755 -pixbuf -startup-notification -unicode3 -vanilla -wcwidth


I would turn fading-colors and pixbuf off

My use flags
Quote:
x11-terms/rxvt-unicode-9.20 USE="focused-urgency font-styles mousewheel perl startup-notification vanilla xft -256-color -alt-font-width -blink -buffer-on-clear -fading-colors -iso14755 -pixbuf -secondary-wheel -unicode3 -wcwidth"

_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
bytetrip
n00b
n00b


Joined: 02 Jan 2015
Posts: 17

PostPosted: Fri Jan 02, 2015 5:43 pm    Post subject: [Solved] urxvt compton transparency. Reply with quote

Edit: For anyone that comes across this later, emerging urxvt with the xft use flag resolved this issue for me.

I am having the same issue, on both a laptop and desktop, my problem exactly matches thumbs 1 and 2 (3 doesn't seem so bad...).

Both use urxvt, and compton. Laptop uses bswpm and desktop uses i3.

I have tried rgba and [opacity]color for background settings.
I have tried with and without fading, and currently the ONLY active settings are depth 32 and background: rgba:0000/0000/1000/ff00.
I have tried a large variety of compton configs from all over the internet, tweaked configs for hours, and even tried no configs (compton -b).
My background *color* changes as expected, but the opacity is always basically the same, which results in it being almost completely unreadable when moved over certain other applications, or parts of my wallpapers.
This also seems to be causing the font itself to become mostly transparent as well when it is moved over a light colored backdrop.

The only difference between moose and my USE flags are that he is using xft and I am not. I am rebuilding it this moment.

Thanks in advance to anyone who can help here.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum