Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] startx fails - what's wrong?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Tue Nov 04, 2014 9:32 am    Post subject: [SOLVED] startx fails - what's wrong? Reply with quote

I tried to install Xorg (and planned to install KDE too), but startx fails.

This is from Xorg.0.log:
Code:

Release Date: 2013-12-27
[   194.205] X Protocol Version 11, Revision 0
[   194.205] Build Operating System: Linux 3.12.21-gentoo-r1 x86_64 Gentoo
[   194.206] Current Operating System: Linux JAA-GENTOO 3.12.21-gentoo-r1 #2 SMP Sun Jul 27 15:39:04 Local time zone must be set--see zic  x86_64
[   194.206] Kernel command line: root=/dev/ram0 real_root=/dev/sdb3
[   194.207] Build Date: 30 October 2014  03:08:18PM
[   194.207] 
[   194.208] Current version of pixman: 0.32.4
[   194.208]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   194.209] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   194.210] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov  1 16:16:16 2014
[   194.211] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   194.211] (==) No Layout section.  Using the first Screen section.
[   194.211] (==) No screen section available. Using defaults.
[   194.211] (**) |-->Screen "Default Screen Section" (0)
[   194.211] (**) |   |-->Monitor "<default monitor>"
[   194.211] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   194.211] (==) Automatically adding devices
[   194.211] (==) Automatically enabling devices
[   194.211] (==) Automatically adding GPU devices
[   194.211] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[   194.211] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   194.211] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   194.211] (II) Loader magic: 0x811c60
[   194.211] (II) Module ABI versions:
[   194.211]    X.Org ANSI C Emulation: 0.4
[   194.211]    X.Org Video Driver: 15.0
[   194.211]    X.Org XInput driver : 20.0
[   194.211]    X.Org Server Extension : 8.0
[   194.211] (II) xfree86: Adding drm device (/dev/dri/card0)
[   194.213] (--) PCI:*(0:2:0:0) 10de:06e0:1b0a:9004 rev 161, Mem @ 0xfa000000/16777216, 0xe0000000/268435456, 0xf8000000/33554432, I/O @ 0x0000ac00/128, BIOS @ 0x????????/131072
[   194.213] Initializing built-in extension Generic Event Extension
[   194.213] Initializing built-in extension SHAPE
[   194.214] Initializing built-in extension MIT-SHM
[   194.214] Initializing built-in extension XInputExtension
[   194.214] Initializing built-in extension XTEST
[   194.215] Initializing built-in extension BIG-REQUESTS
[   194.215] Initializing built-in extension SYNC
[   194.216] Initializing built-in extension XKEYBOARD
[   194.216] Initializing built-in extension XC-MISC
[   194.217] Initializing built-in extension XINERAMA
[   194.217] Initializing built-in extension XFIXES
[   194.217] Initializing built-in extension RENDER
[   194.218] Initializing built-in extension RANDR
[   194.218] Initializing built-in extension COMPOSITE
[   194.219] Initializing built-in extension DAMAGE
[   194.219] Initializing built-in extension MIT-SCREEN-SAVER
[   194.219] Initializing built-in extension DOUBLE-BUFFER
[   194.220] Initializing built-in extension RECORD
[   194.220] Initializing built-in extension DPMS
[   194.221] Initializing built-in extension Present
[   194.221] Initializing built-in extension DRI3
[   194.221] Initializing built-in extension X-Resource
[   194.222] Initializing built-in extension XVideo
[   194.222] Initializing built-in extension XVideo-MotionCompensation
[   194.222] Initializing built-in extension XFree86-VidModeExtension
[   194.223] Initializing built-in extension XFree86-DGA
[   194.223] Initializing built-in extension XFree86-DRI
[   194.223] Initializing built-in extension DRI2
[   194.223] (II) LoadModule: "glx"
[   194.223] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   194.225] (II) Module glx: vendor="X.Org Foundation"
[   194.225]    compiled for 1.15.0, module version = 1.0.0
[   194.225]    ABI class: X.Org Server Extension, version 8.0
[   194.225] (==) AIGLX enabled
[   194.225] Loading extension GLX
[   194.225] (==) Matched nouveau as autoconfigured driver 0
[   194.225] (==) Matched nv as autoconfigured driver 1
[   194.225] (==) Matched nouveau as autoconfigured driver 2
[   194.225] (==) Matched nv as autoconfigured driver 3
[   194.225] (==) Matched modesetting as autoconfigured driver 4
[   194.225] (==) Matched fbdev as autoconfigured driver 5
[   194.225] (==) Matched vesa as autoconfigured driver 6
[   194.225] (==) Assigned the driver to the xf86ConfigLayout
[   194.225] (II) LoadModule: "nouveau"
[   194.225] (WW) Warning, couldn't open module nouveau
[   194.225] (II) UnloadModule: "nouveau"
[   194.225] (II) Unloading nouveau
[   194.225] (EE) Failed to load module "nouveau" (module does not exist, 0)
[   194.225] (II) LoadModule: "nv"
[   194.225] (II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
[   194.225] (II) Module nv: vendor="X.Org Foundation"
[   194.225]    compiled for 1.15.0, module version = 2.1.20
[   194.225]    Module class: X.Org Video Driver
[   194.225]    ABI class: X.Org Video Driver, version 15.0
[   194.225] (II) LoadModule: "modesetting"
[   194.226] (WW) Warning, couldn't open module modesetting
[   194.226] (II) UnloadModule: "modesetting"
[   194.226] (II) Unloading modesetting
[   194.226] (EE) Failed to load module "modesetting" (module does not exist, 0)
[   194.226] (II) LoadModule: "fbdev"

   GeForce3 Ti 200, GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600,
   GeForce4 Ti 4400, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
   Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
   GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
   Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
   GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
   GeForce FX 5600 Ultra, GeForce FX 5600, GeForce FX 5600XT,
   GeForce FX Go5600, GeForce FX Go5650, Quadro FX Go700,
   GeForce FX 5200, GeForce FX 5200 Ultra, GeForce FX 5200,
   GeForce FX 5200LE, GeForce FX Go5200, GeForce FX Go5250,
   GeForce FX 5500, GeForce FX 5100, GeForce FX Go5200 32M/64M,
   Quadro NVS 55/280 PCI, Quadro FX 500/600 PCI,
   GeForce FX Go53xx Series, GeForce FX Go5100, GeForce FX 5900 Ultra,
   GeForce FX 5900, GeForce FX 5900XT, GeForce FX 5950 Ultra,
   GeForce FX 5900ZT, Quadro FX 3000, Quadro FX 700,
   GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
   GeForce FX 5700VE, GeForce FX Go5700, GeForce FX Go5700,
   Quadro FX Go1000, Quadro FX 1100, GeForce 6800 Ultra, GeForce 6800,
   GeForce 6800 LE, GeForce 6800 XE, GeForce 6800 XT, GeForce 6800 GT,
   GeForce 6800 GT, GeForce 6800 GS, GeForce 6800 XT, Quadro FX 4000,
   GeForce 6800 GS, GeForce 6800, GeForce 6800 LE, GeForce 6800 XT,
   GeForce Go 6800, GeForce Go 6800 Ultra, Quadro FX Go1400,
   Quadro FX 3450/4000 SDI, Quadro FX 1400, GeForce 6600 GT,
   GeForce 6600, GeForce 6600 LE, GeForce 6600 VE, GeForce Go 6600,
   GeForce 6610 XL, GeForce Go 6600 TE/6200 TE, GeForce 6700 XL,
   GeForce Go 6600, GeForce Go 6600 GT, Quadro NVS 440, Quadro FX 550,
   Quadro FX 550, Quadro FX 540, GeForce 6200, GeForce 6500,
   GeForce 6200 TurboCache(TM), GeForce 6200SE TurboCache(TM),
   GeForce 6200 LE, GeForce Go 6200, Quadro NVS 285, GeForce Go 6400,
   GeForce Go 6200, GeForce Go 6400, GeForce 6250, GeForce 7100 GS,
   GeForce 6800, GeForce 6800 LE, GeForce 6800 GT, GeForce 6800 XT,
   GeForce 6200, GeForce 6200 A-LE, GeForce 7800 GTX, GeForce 7800 GTX,
   GeForce 7800 GT, GeForce 7800 GS, GeForce 7800 SLI, GeForce Go 7800,
   GeForce Go 7800 GTX, Quadro FX 4500, GeForce 7350 LE,
   GeForce 7300 LE, GeForce 7300 SE, GeForce Go 7200, GeForce Go 7300,
   GeForce Go 7400, GeForce Go 7400 GS, Quadro NVS 110M,
   Quadro NVS 120M, Quadro FX 350M, GeForce 7500 LE, Quadro FX 350,
   GeForce 7300 GS, GeForce 7650 GS, GeForce 7600 GT, GeForce 7600 GS,
   GeForce 7300 GT, GeForce 7600 LE, GeForce 7300 GT, GeForce Go 7700,
   GeForce Go 7600, GeForce Go 7600 GT, Quadro NVS 300M,
   GeForce Go 7900 SE, Quadro FX 550M, Quadro FX 560, GeForce 7900 GTX,
   GeForce 7900 GT, GeForce 7900 GS, GeForce 7950 GX2, GeForce 7950 GX2,
   GeForce 7950 GT, GeForce Go 7950 GTX, GeForce Go 7900 GS,
   GeForce Go 7900 GTX, Quadro FX 2500M, Quadro FX 1500M,
   Quadro FX 5500, Quadro FX 3500, Quadro FX 1500, Quadro FX 4500 X2,
   GeForce 6150, GeForce 6150 LE, GeForce 6100, GeForce Go 6150,
   Quadro NVS 210S / NVIDIA GeForce 6150LE, GeForce Go 6100,
   GeForce 6150SE, GeForce 6100 nForce 405, GeForce 6100 nForce 400,
   GeForce 6100 nForce 420, GeForce 7150M / nForce 630M,
   GeForce 7000M / nForce 610M, GeForce 7050 PV / nForce 630a,
   GeForce 7050 PV / nForce 630a, GeForce 7025 / nForce 630a,
   GeForce 8800 GTX, GeForce 8800 GTS, GeForce 8800 Ultra,
   Quadro FX 5600, Quadro FX 4600, GeForce 8600 GTS, GeForce 8600 GT,
   GeForce 8600 GT, GeForce 8600 GS, GeForce 8400 GS, GeForce 9500M GS,
   GeForce 8300 GS, GeForce 8600M GT, GeForce 9650M GS,
   GeForce 8700M GT, Quadro FX 370, Quadro NVS 320M, Quadro FX 570M,
   Quadro FX 1600M, Quadro FX 570, Quadro FX 1700, GeForce GT 330,
   GeForce 8400 SE, GeForce 8500 GT, GeForce 8400 GS, GeForce 8300 GS,
   GeForce 8400 GS, GeForce 8600M GS, GeForce 8400M GT,
   GeForce 8400M GS, GeForce 8400M G, Quadro NVS 140M, Quadro NVS 130M,
   Quadro NVS 135M, GeForce 9400 GT, Quadro FX 360M, GeForce 9300M G,
   Quadro NVS 290, GeForce GTX 295, GeForce GTX 280, GeForce GTX 260,
   GeForce GTX 285, GeForce GTX 275, GeForce GTX 260, GeForce GTX 295,
   Quadroplex 2200 D2, Quadroplex 2200 S4, Quadro CX, Quadro FX 5800,
   Quadro FX 4800, Quadro FX 3800, GeForce 8800 GTS 512,
   GeForce 9800 GT, GeForce 8800 GT, GeForce GT 230, GeForce 9800 GX2,
   GeForce 9800 GT, GeForce 8800 GS, GeForce GTS 240, GeForce 9800M GTX,
   GeForce 8800M GTS, GeForce GTX 280M, GeForce 9800M GT,
   GeForce 8800M GTX, GeForce 8800 GS, GeForce GTX 285M,
   GeForce 9600 GSO, GeForce 8800 GT, GeForce 9800 GTX/9800 GTX+,
   GeForce 9800 GTX+, GeForce 9800 GT, GeForce GTS 250,
   GeForce 9800M GTX, GeForce GTX 260M, Quadro FX 4700 X2,
   Quadro FX 3700, Quadro VX 200, Quadro FX 3600M, Quadro FX 2800M,
   Quadro FX 3700M, Quadro FX 3800M, GeForce 9600 GT, GeForce 9600 GS,
   GeForce 9600 GSO 512, GeForce GT 130, GeForce GT 140,
   GeForce 9800M GTS, GeForce 9700M GTS, GeForce 9800M GS,
   GeForce 9800M GTS, GeForce 9600 GT, GeForce 9600 GT,
   GeForce GTS 160M, GeForce GTS 150M, GeForce 9600 GSO,
   GeForce 9600 GT, Quadro FX 1800, Quadro FX 2700M, GeForce 9500 GT,
   GeForce 9400 GT, GeForce 9500 GT, GeForce 9500 GS, GeForce 9500 GS,
   GeForce GT 120, GeForce 9600M GT, GeForce 9600M GS, GeForce 9600M GT,
   GeForce 9700M GT, GeForce 9500M G, GeForce 9650M GT, GeForce G 110M,
   GeForce GT 130M, GeForce GT 120M, GeForce GT 220M, GeForce 9650 S,
   Quadro FX 380, Quadro FX 580, Quadro FX 1700M, GeForce 9400 GT,
   Quadro FX 770M, GeForce 9300 GE, GeForce 9300 GS, GeForce 8400,
   GeForce 8400 SE, GeForce 8400 GS, GeForce 9300M GS, GeForce G100,
   GeForce 9300 SE, GeForce 9200M GS, GeForce 9300M GS, Quadro NVS 150M,
   Quadro NVS 160M, GeForce G 105M, GeForce G 103M, GeForce G105M,
   Quadro NVS 420, Quadro FX 370 LP, Quadro NVS 450, Quadro FX 370M,
   Quadro NVS 295, GeForce 9100M G, GeForce 8200M G, GeForce 9200,
   GeForce 9100, GeForce 8300, GeForce 8200, nForce 730a, GeForce 9200,
   nForce 980a/780a SLI, nForce 750a SLI, GeForce 8100 / nForce 720a,
   GeForce 9400, GeForce 9400, GeForce 9400M G, GeForce 9400M,
   GeForce 9300, ION, GeForce 9400M G, GeForce 9400, nForce 760i SLI,
   GeForce 9400, GeForce 9300 / nForce 730i, GeForce 9200,
   GeForce 9100M G, GeForce 8200M G, GeForce 9400M, GeForce 9200,
   GeForce G102M, GeForce G102M, ION, ION, GeForce 9400, ION, ION LE,
   ION LE, GeForce GT 220, GeForce 315, GeForce 210, GeForce GT 230M,
   GeForce GT 330M, GeForce GT 230M, GeForce GT 330M, NVS 5100M,
   GeForce GT 320M, GeForce GT 240M, GeForce GT 325M, Quadro FX 880M,
   GeForce G210, GeForce 205, GeForce 310, ION, GeForce 210,
   GeForce 310, GeForce 315, GeForce G105M, GeForce G105M, NVS 2100M,
   NVS 3100M, GeForce 305M, ION, GeForce 310M, GeForce 305M,
   GeForce 310M, GeForce 305M, GeForce G210M, GeForce 310M,
   Quadro FX 380 LP, Quadro FX 380M, GeForce GT 330, GeForce GT 320,
   GeForce GT 240, GeForce GT 340, GeForce GT 330, GeForce GTS 260M,
   GeForce GTS 250M, GeForce 315, GeForce GT 335M, GeForce GTS 350M,
   GeForce GTS 360M, Quadro FX 1800M
[   194.227] (--) using VT number 7

[   194.229] (EE) NV: The PCI device 0x10de06e0 (GeForce 9300 GE) at 02@00:00:0 has a kernel module claiming it.
[   194.229] (EE) NV: This driver cannot operate until it has been unloaded.
[   194.229] (EE) NV: The PCI device 0x10de06e0 (GeForce 9300 GE) at 02@00:00:0 haFunny, I couldn't find nouveau driver, but at least:s a kernel module claiming it.
[   194.229] (EE) NV: This driver cannot operate until it has been unloaded.
[   194.229] (EE) No devices detected.
[   194.229] (EE)
Fatal server error:
[   194.229] (EE) no screens found(EE)
[   194.229] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   194.229] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   194.229] (EE)



Emerging xorg-x11 seemed to go through:
Code:

1414681872:  === (95 of 95) Post-Build Cleaning (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414681872:  ::: completed emerge (95 of 95) x11-base/xorg-x11-7.4-r2 to /
1414681872:  *** Finished. Cleaning up...
1414681873:  *** exiting successfully.
1414681873:  *** terminating.
1414684035: Started emerge on: Oct 30, 2014 15:47:14
1414684035:  *** emerge  xorg-drivers
1414684038:  >>> emerge (1 of 1) x11-base/xorg-drivers-1.15 to /
1414684038:  === (1 of 1) Cleaning (x11-base/xorg-drivers-1.15::/usr/portage/x11-base/xorg-drivers/xorg-drivers-1.15.ebuild)
1414684038:  === (1 of 1) Compiling/Merging (x11-base/xorg-drivers-1.15::/usr/portage/x11-base/xorg-drivers/xorg-drivers-1.15.ebuild)
1414684041:  === (1 of 1) Merging (x11-base/xorg-drivers-1.15::/usr/portage/x11-base/xorg-drivers/xorg-drivers-1.15.ebuild)
1414684042:  >>> AUTOCLEAN: x11-base/xorg-drivers:0
1414684042:  === Unmerging... (x11-base/xorg-drivers-1.15)
1414684044:  >>> unmerge success: x11-base/xorg-drivers-1.15
1414684045:  === (1 of 1) Updating world file (x11-base/xorg-drivers-1.15)
1414684045:  === (1 of 1) Post-Build Cleaning (x11-base/xorg-drivers-1.15::/usr/portage/x11-base/xorg-drivers/xorg-drivers-1.15.ebuild)
1414684045:  ::: completed emerge (1 of 1) x11-base/xorg-drivers-1.15 to /
1414684045:  *** Finished. Cleaning up...
1414684045:  *** exiting successfully.
1414684046:  *** terminating.
1414858497: Started emerge on: Nov 01, 2014 16:14:56
1414858497:  *** emerge --ask xorg-x11
1414858532:  >>> emerge (1 of 1) x11-base/xorg-x11-7.4-r2 to /
1414858533:  === (1 of 1) Cleaning (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414858533:  === (1 of 1) Compiling/Merging (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414858536:  === (1 of 1) Merging (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414858536:  >>> AUTOCLEAN: x11-base/xorg-x11:0
1414858536:  === Unmerging... (x11-base/xorg-x11-7.4-r2)
1414858539:  >>> unmerge success: x11-base/xorg-x11-7.4-r2
1414858540:  === (1 of 1) Post-Build Cleaning (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414858540:  ::: completed emerge (1 of 1) x11-base/xorg-x11-7.4-r2 to /
1414858540:  *** Finished. Cleaning up...
1414858540:  *** exiting successfully.
1414858541:  *** terminating.
1414858629: Started emerge on: Nov 01, 2014 16:17:08
1414858629:  *** emerge --ask xorg-x11
1414858644:  >>> emerge (1 of 1) x11-base/xorg-x11-7.4-r2 to /
1414858645:  === (1 of 1) Cleaning (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414858645:  === (1 of 1) Compiling/Merging (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414858647:  === (1 of 1) Merging (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414858648:  >>> AUTOCLEAN: x11-base/xorg-x11:0
1414858648:  === Unmerging... (x11-base/xorg-x11-7.4-r2)
1414858648:  >>> unmerge success: x11-base/xorg-x11-7.4-r2
1414858649:  === (1 of 1) Post-Build Cleaning (x11-base/xorg-x11-7.4-r2::/usr/portage/x11-base/xorg-x11/xorg-x11-7.4-r2.ebuild)
1414858649:  ::: completed emerge (1 of 1) x11-base/xorg-x11-7.4-r2 to /
1414858649:  *** Finished. Cleaning up...
1414858650:  *** exiting successfully.
1414858650:  *** terminating.


lspci:
Code:

lspci
00:00.0 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: NVIDIA Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: NVIDIA Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: NVIDIA Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB controller: NVIDIA Corporation MCP61 USB 1.1 Controller (rev a3)
00:02.1 USB controller: NVIDIA Corporation MCP61 USB 2.0 Controller (rev a3)
00:04.0 PCI bridge: NVIDIA Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: NVIDIA Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: NVIDIA Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: NVIDIA Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: NVIDIA Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
01:09.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev 80)
02:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 9300 GE] (rev a1)
04:00.0 Network controller: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe


Code:

/lib64/modules/3.12.21-gentoo-r1/kernel/drivers/gpu/drm/nouveau $ ls -ls
total 58032
58032 -rw-r--r-- 1 root root 59357226 Jul 27 19:03 nouveau.ko

Code:

/usr/lib64/xorg/modules/drivers $ ls -ls
total 176
176 -rwxr-xr-x 1 root root 175848 Oct 30 17:11 nv_drv.so


What else should show here?
(I'm writing this on a different OS because it's easier with a GUI and graphical web browser than with 'links'.)
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)


Last edited by turboscrew on Wed Nov 05, 2014 2:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Tue Nov 04, 2014 9:58 am    Post subject: Reply with quote

Code:
[   194.229] (EE) NV: The PCI device 0x10de06e0 (GeForce 9300 GE) at 02@00:00:0 has a kernel module claiming it.
[   194.229] (EE) NV: This driver cannot operate until it has been unloaded.
[   194.229] (EE) NV: The PCI device 0x10de06e0 (GeForce 9300 GE) at 02@00:00:0 has a kernel module claiming it.
[   194.229] (EE) NV: This driver cannot operate until it has been unloaded.


This means that X is trying to use the "nv" driver but failing to do so because some kernel module is already managing your video card.

The first question is what driver do you intend to use. You have two choices: "nvidia" is the binary proprietary driver, the fastest and more featureful one. Then you have "nouveau" which is the open source driver, and might or might not work for your video c ard and concrete setup.

In any case, you should include a line like this in your make.conf:

Code:
VIDEO_CARDS="nouveau"


or

Code:
VIDEO_CARDS="nvidia"


Depending on which driver you want to use. Then

Code:
emerge -aDN @world


to rebuild xorg-drivers and probably a few other packages.

Just for your info, the "nv" driver which X is trying to use right now is an old driver with only 2D capabilities and no acceleration, not much better than "vesa", so you definitely don't want that unless you don't have any other choice.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Tue Nov 04, 2014 1:16 pm    Post subject: Reply with quote

I think nvidia would be better - I have been thinking of learning about GPGPU. (I understand X should not be running at the same time.)
Nouveau works with mu graphics card, but maybe I'd still use nvidia.

Thanks. I'll start finding out about the loaded driver. I wonder if it's nouveau. kernel module loaded at startup...

[edit]

Yes, there was nouveau that I couldn't rmmod, because "the kernel module is in use".
I also checked that the graphics drives should have been compiled to modules.
(Both nouveau and nv. are)

Neither nvidia nor nouveau is found in the /etc/conf.d/modules.
Where the heck could that nouveau get loaded?
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6968

PostPosted: Tue Nov 04, 2014 2:23 pm    Post subject: Reply with quote

turboscrew wrote:
Where the heck could that nouveau get loaded?

You answer yourself already...
turboscrew wrote:
I also checked that the graphics drives should have been compiled to modules.
(Both nouveau and nv. are)


Module could be load by your device manager (udev...). So if you have the module, and the hardware that match it, it will get load if your device manager handle that.
/etc/conf.d/modules is to load a module yourself or provide an option to the module when loading, so it could be empty, but the module could still be load with default options, even the file is empty.
Back to top
View user's profile Send private message
RazielFMX
l33t
l33t


Joined: 23 Apr 2005
Posts: 835
Location: NY, USA

PostPosted: Tue Nov 04, 2014 3:08 pm    Post subject: Reply with quote

I have found that you can't really have the nouveau and nvidia drivers co-exist. If you want to use the both drivers you will need to follow this guide:

http://wiki.gentoo.org/wiki/Nouveau_%26_nvidia-drivers_switching

You will need two kernels.
_________________
I am not anti-systemd; I am pro-choice. If being the latter makes you feel that I am the former, then so be it.
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Tue Nov 04, 2014 11:46 pm    Post subject: Reply with quote

I thought the drivers could co-exist, but only one can be loaded.

How could I sort that out? Should I delete nouveau or move it?
Or should I figure out some udev-rule to exclude nouveau?
Or should I reconfigure+recompile the kernel?
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Wed Nov 05, 2014 8:54 am    Post subject: Reply with quote

I renamed the /lib/modules/3.12.21-gentoo-r1/kernel/drivers/gpu/drm/nouveau/nouveau.ko and rebooted.
Then I modprobed /usr/lib64/xorg/modules/drivers/nv_drv.so.
No errorrs were reported (but there didn't seem to be 'nv' or 'nvidia' in the output of lsmod.

Then I tried startx and got:

Code:

[   853.278] (II) config/udev: Adding input device HDA NVidia Front Mic (/dev/input/event13)
[   853.278] (II) No input driver specified, ignoring this device.
[   853.278] (II) This device may have been added with another device file.
[   853.278] (II) config/udev: Adding input device HDA NVidia Rear Mic (/dev/input/event12)
[   853.278] (II) No input driver specified, ignoring this device.
[   853.278] (II) This device may have been added with another device file.
[   853.278] (II) config/udev: Adding input device HDA NVidia Line (/dev/input/event11)
[   853.279] (II) No input driver specified, ignoring this device.
[   853.279] (II) This device may have been added with another device file.
[   853.279] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[   853.279] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev key[urlboard catchall"
[   853.279] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[   853.279] (**) AT Translated Set 2 keyboard: always reports core events
[   853.279] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[   853.279] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[   853.279] (--) evdev: AT Translated Set 2 keyboard: Found keys
[   853.279] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[   853.279] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/eve[urlnt0"
[   853.279] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 8)
[   853.279] (**) Option "xkb_rules" "evdev"
[   853.279] (**) Option "xkb_model" "pc104"
[   853.279] (**) Option "xkb_layout" "us"
[   853.279] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/event1)
[   853.279] (**) ImPS/2 Generic Wheel Mouse: Applying InputClass "evdev pointer catchall"
[   853.279] (II) Using input driver 'evdev' for 'ImPS/2 Generic Wheel Mouse'
[   853.279] (**) ImPS/2 Generic Wheel Mouse: always reports core events
[   853.279] (**) evdev: ImPS/2 Generic Wheel Mouse: Device: "/dev/input/event1"
[   853.279] (--) evdev: ImPS/2 Generic Wheel Mouse: Vendor 0x2 Product 0x5
[   853.279] (--) evdev: ImPS/2 Generic Wheel Mouse: Found 3 mouse buttons
[   853.279] (--) evdev: ImPS/2 Generic Wheel Mouse: Found scroll wheel(s)
[   853.279] (--) evdev: ImPS/2 Generic Wheel Mouse: Found relative axes
[   853.279] (--) evdev: ImPS/2 Generic Wheel Mouse: Found x and y relative axes
[   853.279] (II) evdev: ImPS/2 Generic Wheel Mouse: Configuring as mouse
[   853.279] (II) evdev: ImPS/2 Generic Wheel Mouse: Adding scrollwheel support
[   853.279] (**) evdev: ImPS/2 Generic Wheel Mouse: YAxisMapping: buttons 4 and 5
[   853.279] (**) evdev: ImPS/2 Generic Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   853.279] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input2/event1"
[   853.279] (II) XINPUT: Adding extended input device "ImPS/2 Generic Wheel Mouse" (type: MOUSE, id 9)
[   853.280] (II) evdev: ImPS/2 Generic Wheel Mouse: initialized for relative axes.
[   853.280] (**) ImPS/2 Generic Wheel Mouse: (accel) keeping acceleration scheme 1
[   853.280] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration profile 0
[   853.280] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration factor: 2.000
[   853.280] (**) ImPS/2 Generic Wheel Mouse: (accel) acceleration threshold: 4
[   853.280] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/mouse0)
[   853.280] (II) No input driver specified, ignoring this device.
[   853.280] (II) This device may have been added with another device file.
[   853.280] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
[   853.280] (II) No input driver specified, ignoring this device.
[   853.280] (II) This device may have been added with another device file.
[   853.352] (II) evdev: ImPS/2 Generic Wheel Mouse: Close
[   853.352] (II) UnloadModule: "evdev"
[   853.352] (II) evdev: AT Translated Set 2 keyboard: Close
[   853.352] (II) UnloadModule: "evdev"
[   853.352] (II) evdev: Power Button: Close
[   853.352] (II) UnloadModule: "evdev"
[   853.352] (II) evdev: Power Button: Close
[   853.352] (II) UnloadModule: "evdev"
[   853.480] (EE) Server terminated successfully (0). Closing log file.


The whole log is here: https://www.dropbox.com/s/21qd564sv0dgozq/Xorg.0.log?dl=0

What's the problem now?

From this:
Code:

[   852.978] (**) NV(0):  Driver mode "640x480": 31.5 MHz (scaled from 0.0 MHz), 37.9 kHz, 72.8 Hz
[   852.978] (II) NV(0): Modeline "640x480"x72.8   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz e)
[   852.978] (**) NV(0):  Driver mode "640x480": 25.2 MHz (scaled from 0.0 MHz), 31.5 kHz, 59.9 Hz
[   852.978] (II) NV(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
[   852.978] (**) NV(0):  Driver mode "720x400": 28.3 MHz (scaled from 0.0 MHz), 31.5 kHz, 70.1 Hz
[   852.978] (II) NV(0): Modeline "720x400"x70.1   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
[   852.978] (==) NV(0): DPI set to (96, 96)
[   852.978] (II) Loading sub module "fb"
[   852.978] (II) LoadModule: "fb"
[   852.978] (II) Loading /usr/lib64/xorg/modules/libfb.so
[   852.979] (II) Module fb: vendor="X.Org Foundation"
[   852.979]    compiled for 1.15.0, module version = 1.0.0
[   852.979]    ABI class: X.Org ANSI C Emulation, version 0.4

I understand that nvidia did initialize, and it also detected my monitor:
Code:

[   852.975] (II) NV(0): Supported standard timings:
[   852.975] (II) NV(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
[   852.975] (II) NV(0): #1: hsize: 1680  vsize 1050  refresh: 60  vid: 179
[   852.975] (II) NV(0): #2: hsize: 1440  vsize 900  refresh: 60  vid: 149
[   852.975] (II) NV(0): #3: hsize: 1440  vsize 900  refresh: 75  vid: 3989
[   852.975] (II) NV(0): Supported detailed timing:
[   852.975] (II) NV(0): clock: 146.2 MHz   Image Size:  474 x 296 mm
[   852.975] (II) NV(0): h_active: 1680  h_sync: 1784  h_sync_end 1960 h_blank_end 2240 h_border: 0
[   852.975] (II) NV(0): v_active: 1050  v_sync: 1053  v_sync_end 1059 v_blanking: 1089 v_border: 0
[   852.975] (II) NV(0): Monitor name: N220W D-sub
[   852.975] (II) NV(0): Ranges: V min: 56 V max: 76 Hz, H min: 31 H max: 80 kHz, PixClock max 155 MHz
[   852.975] (II) NV(0): Serial No: 0WASPE8A05107

but did it try with too high resolution?
Code:

[   852.978] (II) NV(0): EDID for output DVI1
[   852.978] (II) NV(0): Output VGA1 connected
[   852.978] (II) NV(0): Output DVI0 disconnected
[   852.978] (II) NV(0): Output DVI1 disconnected
[   852.978] (II) NV(0): Using exact sizes for initial modes
[   852.978] (II) NV(0): Output VGA1 using initial mode 1680x1050
[   852.978] (II) NV(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.

_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Nov 05, 2014 9:29 am    Post subject: Reply with quote

That seems ok. Did you set up an ~/.xinitrc file or are you booting using a DM such as gdm, kdm or whatever else?

If no WM grabs the server it will just run and exit.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Wed Nov 05, 2014 12:20 pm    Post subject: Reply with quote

Thanks, I guess that's what happened.
Shouldn't there be somet WM (by default) when one installs xorg-x11? Even if there is no DE?

I didn't check the xinitrc, though. I'll check.
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Nov 05, 2014 12:53 pm    Post subject: Reply with quote

There's no default WM since Xorg went modular.

Time ago, when you installed Xorg or XFree or whatever X under the sun you also got for free xterm, xclock, xfoobarmoocow... and then twm, which is the window manager that is shipped with X. But now you only get the pieces of X you need to run your concrete setup.

So, if you wanted a typical X session as we used to get in the past we need to emerge xterm, xclock and twm. The default session file seems to be still under /etc/X11/xinit/xinitrc if you want to take a look.

Since twm is not installed by default, you usually need to define your own ~/.xinitrc file and put a line like this on it (at the very least).

Code:
exec openbox


or whatever wm you want.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Wed Nov 05, 2014 1:47 pm    Post subject: Reply with quote

Thanks.
I'll emerge the pieces and figure out some .xinitrc (didn't have one in ~, but had a .Xauthority).
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
turboscrew
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2014
Posts: 88
Location: Nokia (town), Finland

PostPosted: Wed Nov 05, 2014 2:00 pm    Post subject: Reply with quote

Truckload of thanks for all involved: openbox opened.
_________________
3.12.21-gentoo-r1 on HP Pavilion a6622sc (CPU: Phenom 8550, Graphics: NVIDIA GeForce 9300GS, Chipset: NVIDIA GeForce 6150SE nForce 430, RAM: 3GB)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum