Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WLAN adaper doesn't receive broadcast packet?!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
fpemud
Apprentice
Apprentice


Joined: 15 Feb 2012
Posts: 264

PostPosted: Sun Nov 02, 2014 10:56 am    Post subject: WLAN adaper doesn't receive broadcast packet?! Reply with quote

I have 2 computers, fpemud-workstation and fpemud-notebook.
The problem phenomena is notebook can not solve workstation's ip address with samba protocol.
I found through tcpdump it is because workstation doesn't receive samba broadcast packet that sent by notebook.

Is it the hardware problem, driver problem, kernel configuration, sysctl setting or something else?
I can't do further test sine I don't have any other OS.

Code:
fpemud-workstation / # lsusb
...
Bus 001 Device 004: ID 0846:9030 NetGear, Inc. WNA1100 Wireless-N 150 [Atheros AR9271]
...

Code:
fpemud-workstation / # iwconfig
lo        no wireless extensions.

enp2s0    no wireless extensions.

tap0      no wireless extensions.

tap1      no wireless extensions.

wlp0s26u1u2  IEEE 802.11bgn  ESSID:"FpemudHome" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 38:83:45:41:DB:B8   
          Bit Rate=135 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=46/70  Signal level=-64 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:197  Invalid misc:23475   Missed beacon:0

Code:
fpemud-workstation / # ifconfig
enp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 8c:89:a5:67:bd:72  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 7046  bytes 578013 (564.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 7046  bytes 578013 (564.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp0s26u1u2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.103  netmask 255.255.255.0  broadcast 192.168.1.255
        ether e0:91:f5:5b:13:5d  txqueuelen 1000  (Ethernet)
        RX packets 392976  bytes 500925828 (477.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 281161  bytes 29513348 (28.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum