Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba share is blocking access to home folder
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Thu Oct 30, 2014 8:26 am    Post subject: Samba share is blocking access to home folder Reply with quote

I have samba folder is mounted to local folder in home directory.
Samba connection has some issue. It's a different topic.

Why I can't access other files in my home directory by using mc or other file browsers?

It looks to be general behavior for any flavor of Linux. Why not just give an empty folder
if some one entering that directory and don't bother at all if nobody trying to access the shared data.

Unlimited loop without possibility to interrupt it is not the best solution for obviously predicted and normal issue
with remote data access.

Of course, if there any solution for that problem existing I would like to know. But then it should be a default behavior.
_________________
Lefsha
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Thu Oct 30, 2014 9:46 pm    Post subject: Reply with quote

I think I finally understand what you're asking here... having a bit of trouble understanding the question.

What's happening is that the mounted directory is being polled when the program you're using is reading all directory entries in the parent directory. The directory entry read is stuck in kernel code. Directories are "files" in the Unix point of view hence they all get treated similarly.

Unfortunately there's no real way for the user to tell the kernel to "give up" early on that read - the kernel stays in "D" state and it itself determines when it should give up and return to the user - if at all.

Ideally there's some sort of timeout that the kernel should respect, but what would be nice is some way for the user to tell the kernel to give up on the call before timeout - and have that program stop trying again unless a change in status comes back from the kernel. This is especially a problem with networks where you can't really tell if the other machine is either busy or will never come back.

Not sure if there's a clean solution here unfortunately.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Fri Oct 31, 2014 5:09 am    Post subject: Reply with quote

Sorry for making my question so unclear.

Is it not a common issue, every one knows about?

I will try to disable all kind of oplocks in smb.conf not quite sure, but may be it will help.
Unfortunately it's a server setting, so no user can control it. So bad.

Code:

[global]
kernel oplocks = no

[share]
oplocks = no
level2 oplocks = no

_________________
Lefsha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum