Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto]problema alsa
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
la papera
n00b
n00b


Joined: 18 Sep 2014
Posts: 14

PostPosted: Tue Oct 28, 2014 12:06 am    Post subject: [risolto]problema alsa Reply with quote

ragazzi, scusatemi ma prorpio non riesco a far funzionare l'audio:
sto seguendo questa guida: https://www.gentoo.org/doc/it/alsa-guide.xml#doc_chap2_pre3
faccio tuto passo passo ma non ce' il comando alsasound,
poi in alsamixer ce' solo il beep del pc:

lspci
Code:

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
05:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)


e per queste ho messo nel kernel " Intel HD Audio"---> "Build HDMI/Display support HD-audio eccc
e " Intel/SiS/nVidia/AMD/ALi AC97 Controller"

poi installo alsa-utils e mi da questo messaggio:
Code:

 *
 * The ALSA core should be built into the kernel or loaded through other
 * means. There is no longer any modular auto(un)loading in alsa-utils.

>>> Recording media-sound/alsa-utils in "world" favorites file...

 * Messages for package media-sound/alsa-utils-1.0.27.2:

 *
 * To take advantage of the init script, and automate the process of
 * saving and restoring sound-card mixer levels you should
 * add alsasound to the boot runlevel. You can do this as
 * root like so:
 * # rc-update add alsasound boot
 *
 * The ALSA core should be built into the kernel or loaded through other
 * means. There is no longer any modular auto(un)loading in alsa-utils.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

nonostante il pacchetto venga installato.

unica cosa funzionante e' il beep del pc hehhehe!!!!!


Last edited by la papera on Mon Nov 10, 2014 8:24 am; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 671

PostPosted: Tue Oct 28, 2014 11:28 am    Post subject: Reply with quote

ciao

hai aggiunto alsa al runlevel di avvio ?
te lo dice pure l'output a fine installazione
Quote:
* To take advantage of the init script, and automate the process of
* saving and restoring sound-card mixer levels you should
* add alsasound to the boot runlevel. You can do this as
* root like so:
* # rc-update add alsasound boot
*


Code:
# rc-update add alsasound boot

riavvia
o prova ad eseguirlo
Code:
# rc-service alsasound start


PS : alsasound non è un comando ma uno script di avvio
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
la papera
n00b
n00b


Joined: 18 Sep 2014
Posts: 14

PostPosted: Tue Oct 28, 2014 1:21 pm    Post subject: Reply with quote

yessss

Code:

rc-update add alsasound boot
 * rc-update: alsasound already installed in runlevel `boot'; skipping


Code:

 rc-service alsasound start
 * WARNING: alsasound has already been started
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Oct 29, 2014 4:43 pm    Post subject: Reply with quote

lspci:
quel che esce
dmesg:
le righe che seguono "ALSA device list:"
nella conf del kernel SND_VERBOSE_PROCFS=Y
ls /dev/snd/by-path/:
...
così dovresti inizare a capirci qualcosa. Vedi se per NVIDIA (sto tirando ad indovinare... tanto per cambiare) c'è qualcosa di simile al radeon.audio=0 che uso nella mia conf del kernel e nel caso prova a gestire modularmente per stabilire un diverso ordine dei device (prima la scheda audio e poi l'uscita hdmi della scheda grafica). Poi passi al builtin.
Inutile dire che devi pensare di configurare /etc/alsa.d.

Credo che l'initscript si blocchi perchè prova a configurare l'uscita dmi che non ha mixer.

La documentazione è datata c'è un solo pacchetto semideprecato (non ricordo quale) che richiede ancora il supporto oss, puoi rimuoverlo del tutto (anche dalle use, esplicitamente, ovvero con USE="-oss" etc. considera che alcuni pacchetti come pulseaudio vanno ricompilati quando sia dal kernel corrente che dalla sua conf che dalle librerie il supporto è stato rimosso o comunque lo abilitano).
Code:
alsamixer -c 0
Code:
alsamixer -c 1
bada che il driver intel è bastardo (c'è intel di mezzo cosa vuoi aspettarti...) e prova a prendere il controllo delle schede supportate da ac97 in certi casi e conviene compilare solo il supporto che ti occorre perchè facilmente prova ad usare il driver sbagliato con le rogne del caso.

Non ti assicuro la risposta (sono altrimenti incasinato) ma ti assicuro che report incompleti e mal-formattati mi faranno astenere da qualsivoglia ulteriore commento. :P :lol:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
la papera
n00b
n00b


Joined: 18 Sep 2014
Posts: 14

PostPosted: Sat Nov 08, 2014 9:24 am    Post subject: Reply with quote

salve ragazzi scusate l'assenza ma ero fuori citta per lavoro!!!
grazi djinnz... piacere micaela
vorrei aggiungere che al momento non mi interessa configurare l'audio dell'NVIDIA, ma slo quello integrato nella scheda madre

lspci
Code:

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx0 port B) (rev 02)
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port B)
00:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port D)
00:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port G)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
00:16.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
03:00.0 USB controller: ASMedia Technology Inc. Device 1142
04:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)
05:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 640] (rev a1)
05:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)


dmesg
Code:

non ce' traccia di alsa


alsamixer -c 1
Code:

 Card: HDA ATI SB
This sound device does not have any controls.


ls /dev/snd/by-path/
Code:

pci-0000:00:14.2  pci-0000:05:00.1  platform-pcspkr


posso aggiungere:

alsactl init
Code:

Found hardware: "PC-Speaker" "PC-Speaker" "" "" ""
Hardware is initialized using a generic method


aplay -l
Code:

**** List of PLAYBACK Hardware Devices ****
card 0: pcsp [pcsp], device 0: pcspeaker [pcsp]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


lsmod|grep '^snd'| column -t
Code:

snd_hda_codec_hdmi  35299  1
snd_hda_intel       29528  2
snd_hda_codec       81180  2   snd_hda_codec_hdmi,snd_hda_intel
snd_pcsp            7694   2
snd_pcm             77744  4   snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_pcsp
snd_timer           17758  1   snd_pcm
snd                 53949  14  snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel,snd_pcsp


ls -l /dev/snd/
Code:

total 0
drwxr-xr-x 2 root root      100 Nov  8 10:02 by-path
crw-rw---- 1 root audio 116,  0 Nov  8 10:02 controlC0
crw-rw---- 1 root audio 116, 32 Nov  8 10:02 controlC1
crw-rw---- 1 root audio 116, 64 Nov  8 10:02 controlC2
crw-rw---- 1 root audio 116, 16 Nov  8 10:22 pcmC0D0p
crw-rw---- 1 root audio 116, 83 Nov  8 10:02 pcmC2D3p
crw-rw---- 1 root audio 116, 87 Nov  8 10:02 pcmC2D7p
crw-rw---- 1 root audio 116,  1 Nov  8 10:02 seq
crw-rw---- 1 root audio 116, 33 Nov  8 10:02 timer



questo e' quanto...
spero che la formattazione vda bene :))))
Back to top
View user's profile Send private message
la papera
n00b
n00b


Joined: 18 Sep 2014
Posts: 14

PostPosted: Mon Nov 10, 2014 8:24 am    Post subject: Reply with quote

piccola rivincita presa...
dopo tre giorni di sbattimenti ci sono riuscita finalmente..... come al solito era nà....
omettevo completamente qualsiasi tipo di codec audio nel kernel, il dubbio mi e' venuto quando
mi sono imbattuta su questo topic: https://forums.gentoo.org/viewtopic-t-836637-highlight-alsa.html e dalle rispostedi "darkmanPPT" ho
avuto l'intuizione.
praticamente ho dovuto disinstallare qualsiasi cosa appartenesse ad alsa, ricompilare il kernel con i codec che non avevo messo, reinstallare tutto
alsa:
alsa-lib
alsa-oss
pyalsa
alsa-tools
alsa-utils
e alla fine e' andato tutto
grazie mille
;)))
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Nov 10, 2014 9:41 am    Post subject: Reply with quote

Ti ribadisco che OSS ormai è assolutamente inutile se non controproducente. E che con i driver intel c'è sempre da disperarsi.
Anche se non corrispondono comunque tentano di far funzionare la scheda sbagliata, da qui il mio suggerimento di disabilitare la gestione audio dell'interfaccia HDMI.
Opzioni come CONFIG_SND_HDA_CODEC_VIA, se non ti servono vanno disabilitate (in menuconfig basta digitare "/" per avere il prompt di ricerca e dalla variabile arrivare a dove va configurata). E, contrariamente a quanto suggerito nella documentazione, CONFIG_SND_DYNAMIC_MINORS=Y
Configurare correttamente
/etc/portage/make.conf wrote:
LINGUAS="it en"
ALSA_CARDS="hda-intel"
INPUT_DEVICES="..."
VIDEO_CARDS="..."
SANE_BACKENDS="..."
CAMERAS="..."
non è una cattiva idea :wink:
Come ti avevo detto non sono tanto presente ultimamente...
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
la papera
n00b
n00b


Joined: 18 Sep 2014
Posts: 14

PostPosted: Mon Nov 10, 2014 9:54 am    Post subject: Reply with quote

grazie per l'interresse, provvedo subito a rimuovere oss e disabilitare HDMI...



Djinniz il tempo e' prezioso per ogniuno di noi, ma basta una parola ogni tanto, messa al momento giusto che diventa una perla
per chi no ti sente da tempo!!!
grazie mille :))))
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum