Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED: how do I become uniform Xcursor themes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
shisbosd
n00b
n00b


Joined: 16 Jun 2014
Posts: 27

PostPosted: Mon Oct 27, 2014 6:00 am    Post subject: SOLVED: how do I become uniform Xcursor themes Reply with quote

My problem is probably easily fixed. I can't figure out how to keep my xcursor from switching from the theme I have set (gentoo-silver) in my ~/.Xresources to the default when I hover over different applications. It seems to be the default for gtk and my desktop, but take on the theme I want to apply in Firefox, skype, or my file manager. I've tried adding
Code:
Inherits=gentoo-silver
in usr/share/icons/default/index.theme, or ~/.gtkrc-2.0(and 3.0)/index.theme, or /etc/gtkrc/index.theme. I also tried moving the folder gentoo-silver to ~/.icons but that solved nothing, X already knew where to find them. I found gcursor, an application which is so old it doesn't exist. I have not tried gconf yet. I'm using the i3 window manager.

PS: off topic but if anyone could relinquish the knowledge of how to permanently change the font of dmenu, I could have a fully uniform desktop (if I solve the topic of this thread, of course)


I solved the problem by copying the theme from /usr/share/cursors/xorg-x11/ to ~.

I started having this problem last year. Excuse me while I sweatily palm my face.


Last edited by shisbosd on Sun Jan 18, 2015 2:14 am; edited 1 time in total
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Mon Oct 27, 2014 8:13 am    Post subject: Reply with quote

This is the kind of thing that makes X a pain sometimes, since each app/toolkit seems to think its way is the right way.

Most legacy X apps do use .Xdefaults, the problem is that for some reason not all of them seem to parse that file directly. To tell the truth, I never looked on how the thing works so take all I say with a grain of salt. I have found that, in order to activate the last changes you need to run this in any terminal inside X:

Code:
xrdb ~/.Xdefaults


In that file, you can put the cursor settings:

Code:

Xcursor.theme: ComixCursors-White
Xcursor.size: 48


This can, of course, be put into ~/.xinitrc or autostarted in a wrapper from whatever DE you are using. That depends on how to start the X session.

That will take rid of legacy apps. More modern ones (gtk and qt-based) attend to their tookit configuration but also to the mechanism configured under /usr/share/themes/default (or ~/.themes/default). Which is the "inherit" line you posted above.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
shisbosd
n00b
n00b


Joined: 16 Jun 2014
Posts: 27

PostPosted: Mon Oct 27, 2014 8:59 pm    Post subject: Reply with quote

I've tried all of this without success. Thanks for the suggestions though! I'm doubting whether I'll ever figure it out, I'm just going to use the regular X cursor for now.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Tue Oct 28, 2014 11:12 am    Post subject: Reply with quote

Ok, what applications do exhibit the problem? Which ones don't show the correct cursor theme? Are all of the problematic apps tied to a given toolkit (i.e. gtk+ or qt)?

Or maybe the theme is wrong only when you are not hovering a window (that's the root window)?

About dmenu, the font is configured in the application command line, for example, I use this script to launch my dmenu:

dmenu.sh wrote:
#!/bin/sh
export PATH="$PATH:$HOME/bin"
#dmenu_run -i -fn "xft:DejaVu Sans Mono:size=15" \
dmenu_run -i -fn "xft:Ubuntu Mono:size=15" \
-nb '#2e2c2e' -nf '#c0c0c0' -sb '#0E4E6F' -sf '#ffffff'


Note that dmenu has an xft use flag. You can't use true type fonts if that's disabled.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
shisbosd
n00b
n00b


Joined: 16 Jun 2014
Posts: 27

PostPosted: Tue Oct 28, 2014 5:27 pm    Post subject: Reply with quote

It looks like all the applications which use GTK use the default xcursor. Although Firefox uses the theme I set. My bare desktop and, window decorations, and status bar all use the default cursor. Thanks for the help with dmenu, I didn't know it was a script, so I thought that dmenu_run -fn was only usable from command line. I tried setting gtk-cursor-theme-name in /usr/share/icons/default.
Back to top
View user's profile Send private message
HerrSchafer
Tux's lil' helper
Tux's lil' helper


Joined: 18 May 2011
Posts: 139

PostPosted: Tue Oct 28, 2014 7:43 pm    Post subject: Reply with quote

A poor, dirty and not technical (but very quick) solution is to copy your cursors files over the default cursors as root.
_________________
“Long is the way, and hard, that out of hell leads up to light.”
― John Milton
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum