Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ck-launch-session can't start things properly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
KWhat
l33t
l33t


Joined: 04 Sep 2005
Posts: 620
Location: Los Angeles

PostPosted: Fri Oct 24, 2014 6:41 pm    Post subject: ck-launch-session can't start things properly Reply with quote

I am using a console login (no xdm) and startx to start my session. Everything use to work until a recent update and now kde does not have a shutdown or restart option in the "leave" sub menu. If I change my .xinitrc file to just startkde i get the menu items back but no integration. I have also tested with xterm instead of startkde and it also exhibits the same behavior. Please note that I am the only user logged into the machine. It doesn't matter if I start kde via xinitrc or XSESSION, it has the same result. Starting xterm also has the same result, the X session doesnt become the active session.

Update: This seems to be a problem in x11-apps/xinit-1.3.4. Bug 526762 was created.

.xinitrc
Code:
ck-launch-session dbus-launch --sh-syntax --exit-with-session /usr/bin/startkde


ck-list-sessions
Code:

Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ''
        x11-display-device = ''
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2014-10-24T18:37:14.818549Z'
        login-session-id = '2'
        idle-since-hint = '2014-10-24T18:37:50.297350Z'
Session2:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = FALSE
        x11-display = ':0'
        x11-display-device = '/dev/tty1'
        display-device = '/dev/tty1'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2014-10-24T18:37:24.903015Z'
        login-session-id = '2'
Back to top
View user's profile Send private message
equeim
n00b
n00b


Joined: 14 Jun 2014
Posts: 19

PostPosted: Sun Oct 26, 2014 11:00 am    Post subject: Reply with quote

I solved this problem by running 'startx -- vt7'
This is upstream change related to systemd-logind:
http://cgit.freedesktop.org/xorg/app/xinit/commit/?id=44915d6953076849b69a017f6fc8234b0f254362
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum