Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Postgrey crash on daemonize?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Wed Oct 22, 2014 6:27 am    Post subject: Postgrey crash on daemonize? Reply with quote

After an emerge update i could not receive email on my postfix. After some investigation it turns out the "postgrey" unix socket is not there, because postgrey has not started.

Trying to restart the service had no results, so i decided to investigate a bit more.

It turns out that the command:
/usr/sbin/postgrey --unix=/var/spool/postfix/private/postgrey --pidfile=/var/run/postgrey.pid --delay=180 '--greylist-text=Greylisted for %s seconds'

works perfectly, while the command:
/usr/sbin/postgrey --unix=/var/spool/postfix/private/postgrey --pidfile=/var/run/postgrey.pid --delay=180 '--greylist-text=Greylisted for %s seconds' --daemonize

just crash with NO output! It just does not start.

Can somebody help me out find out WHY this? For the time being i have disabled graylisting in postfix, but i would like to fix it...
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
Pearlseattle
Tux's lil' helper
Tux's lil' helper


Joined: 04 Oct 2007
Posts: 138
Location: Switzerland

PostPosted: Fri Oct 24, 2014 8:41 pm    Post subject: Reply with quote

Hi

I have currently...
Code:
eix mail-filter/postgrey
[I] mail-filter/postgrey
     Available versions:  1.34 1.34-r1 ~1.34-r2 1.34-r3 ~1.35 ~1.35-r1 {targrey}
     Installed versions:  1.34-r3(06:49:50 PM 08/24/2014)(-targrey)
     Homepage:            http://postgrey.schweikert.ch/
     Description:         Postgrey is a Postfix policy server implementing greylisting

...1.34-r3 installed and it starts with the command line...
Code:
ps -Af | grep -i postgrey
postgrey  2750     1  0 Oct10 ?        00:00:00 /usr/sbin/postgrey --inet=127.0.0.1:10030 --daemonize --pidfile=/var/run/postgrey.pid --delay=180 --greylist-text=Greylisted for %s seconds

...and I did not have any problems with it so far.

I don't have any fancy setup.
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Fri Oct 31, 2014 4:04 pm    Post subject: Reply with quote

Well, an emerge sync and upgrading postgrey has fixed it...
odn't know what was going on, but now itt works.
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum