Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] NVIDIA - Failed to initialize the GLX module
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Wintershade
n00b
n00b


Joined: 21 Jul 2007
Posts: 32
Location: Croatia

PostPosted: Tue Oct 21, 2014 9:52 am    Post subject: [SOLVED] NVIDIA - Failed to initialize the GLX module Reply with quote

Hi again,

after running emerge -uDN @world two days ago, I am no longer able to get hardware acceleration with my NVIDIA card.
I admit it's an old NVIDIA GeForce 9600, but it should still be supported (AFAIK). In short, I'm not using bumblebee, and even downgrading the driver to it's previous version didn't help.

What I am getting in Xorg.0.log is as follows:
Code:
[  1674.187] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[  1674.187] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[  1674.187] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[  1674.187] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[  1674.187] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
[  1675.622] (II) NVIDIA(0): Display (Seiko/Epson (DFP-0)) does not support NVIDIA 3D
[  1675.622] (II) NVIDIA(0):     Vision stereo.


My full Xorg.0.log can be found here.

I have eselected nvidia as my opengl and opencl implementation:
Code:
# eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11

# eselect opencl list
Available OpenCL implementations:
  [1]   nvidia *


I have put my xorg.conf in the pastebin. Note that I haven't changed anything in it recently - it has worked perfectly for the past 2 years.

this is my /etc/modprobe.d/nvidia.conf, also working fine for the past 2 years:
Code:
# Nvidia drivers support
alias char-major-195 nvidia
alias /dev/nvidiactl char-major-195

# To tweak the driver the following options can be used, note that
# you should be careful, as it could cause instability!! For more
# options see /usr/share/doc/nvidia-drivers-331.104/README
#
# !!! SECURITY WARNING !!!
# DO NOT MODIFY OR REMOVE THE DEVICE FILE RELATED OPTIONS UNLESS YOU KNOW
# WHAT YOU ARE DOING.
# ONLY ADD TRUSTED USERS TO THE VIDEO GROUP, THESE USERS MAY BE ABLE TO CRASH,
# COMPROMISE, OR IRREPARABLY DAMAGE THE MACHINE.

blacklist intel_agp
blacklist nouveau
blacklist nvidia

options nvidia NVreg_DeviceFileMode=432 NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=27 NVreg_ModifyDeviceFiles=1


...and I've put my lsmod output in the pastebin.


Essentially, I'm pretty confused. Can anyone at least tell me what is going on?
Thanks in advance!

edit: SOLVED. As in, nevermind, I fixed the 1D107 error.
I had... uhh, "mistakenly" set the "minimal" as a global USE flag in make.conf, and xorg-server got recompiled without the GLX. Removed the flag, recompiled, works fine now.
_________________
Only the best is good enough.

My make.conf file
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum