Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NetworkManager doesn't start ModemManager openrc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
EyeOfCat
n00b
n00b


Joined: 27 Jan 2011
Posts: 8
Location: Saint-Petersbourg,Ru

PostPosted: Thu Jun 26, 2014 11:23 am    Post subject: NetworkManager doesn't start ModemManager openrc Reply with quote

hello.
yesterday I'v updated ~280 packages (most of them was from kde) and today ModemManager didn't start with NetworkManager.
if I manually start ModemManager executing it's binary - networkmanager can see it over dbus and works correctly with broadband connections.

in /var/log/messages i didn\t see anything pointing that NetworkManager try to start ModemManager over dbus (as I suppose it was before)
dbus-monitor don't show anything about this. I downgrade dbus from 1.8.4 to 1.8.2 for some reaseon - makes no sense.

also I've encountered the same issue on my laptop. But that system uses systemd, so I just added ModemManager service to autostart.

here on openrc there is no service for ModemManager. And I didn't find anything about modemmanger in man pages for NetworkManager and NetworkManager.conf

I saw several topics here about "how make NetworkManager not to start ModemManager" but didn't find there a solution.

PS: sorry for my english )
Back to top
View user's profile Send private message
freifunk_connewitz
Apprentice
Apprentice


Joined: 08 Feb 2006
Posts: 181

PostPosted: Tue Sep 02, 2014 4:11 pm    Post subject: Reply with quote

Hi EyeOfCat,

thanks for opening my eyes on that. I had the very same problem of the broadband connection not being an option in NM anymore and was searching for the reason without success. But now I see it. Same prob like you, same solution (starting ModemManager manually). But actually that is only a workaround, not a solution.

I also noticed some time ago that NM-applet stopped to display signal strength on the GSM/UMTS connection (that was before it stopped activating it altogether). So maybe the connection between NM and MM was degrading slowly :)

However: I'm not sure if this is a NM issue or a Gentoo/openrc issue. My feeling says we should start with Gentoo...
Back to top
View user's profile Send private message
kavra
n00b
n00b


Joined: 22 Feb 2012
Posts: 29

PostPosted: Tue Oct 14, 2014 11:40 am    Post subject: Reply with quote

freifunk_connewitz wrote:
Hi EyeOfCat,

thanks for opening my eyes on that. I had the very same problem of the broadband connection not being an option in NM anymore and was searching for the reason without success. But now I see it. Same prob like you, same solution (starting ModemManager manually). But actually that is only a workaround, not a solution.

I also noticed some time ago that NM-applet stopped to display signal strength on the GSM/UMTS connection (that was before it stopped activating it altogether). So maybe the connection between NM and MM was degrading slowly :)

However: I'm not sure if this is a NM issue or a Gentoo/openrc issue. My feeling says we should start with Gentoo...


generate a init script

#cat /etc/init.d/ModemManager

Code:
#!/sbin/runscript
# Distributed under the terms of the GNU General Purpose License v2


description="ModemManager daemon. The service is marked as started only \
when a network connection is established."

depend() {
        need dbus
        provide net
}

start() {
    ebegin "Starting ModemManager"
    start-stop-daemon --background --start --exec /usr/sbin/ModemManager \
    --make-pidfile --pidfile /run/ModemManager/ModemManager.pid
    eend $?
}

stop() {
    ebegin "Stopping ModemManager"
    start-stop-daemon --stop --exec /usr/sbin/ModemManager \
    --pidfile /run/ModemManager/ModemManager.pid
    eend $?
}


#mkdir /run/ModemManager
#/etc/init.d/ModemManager start
#rc-update add ModemManager default
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6746
Location: Blighty

PostPosted: Tue Oct 14, 2014 2:09 pm    Post subject: Reply with quote

Wow, that's a lot of code.

openrc has a template system now

Code:
#!/sbin/runscript

command=/usr/sbin/ModemManager
command_background=yes
pidfile=/run/ModemManager/ModemManager.pid
name="ModemManager daemon"

depend()
{
   provide net
   need dbus
}


Totally untested, but does the same job.
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Wed Oct 15, 2014 2:56 pm    Post subject: Reply with quote

Hi Folks,

after updating my machine yesterday, I started today with having similar trouble regarding networkmanager.
After looking into elogv I read this message which could help you eventually fixing the problem in a different way. :wink:

Quote:

INFO: setup │
│Package: net-misc/networkmanager-0.9.10.0-r1 │
│Repository: gentoo │
│Maintainer: gnome@gentoo.org │
│USE: abi_x86_64 amd64 avahi consolekit dhclient elibc_glibc introspection kernel_linux modemmanager ncurses nss ppp │
│userland_GNU vala wext wifi │
│FEATURES: preserve-libs sandbox userpriv usersandbox │
│INFO: prepare │
│Applying networkmanager-0.9.10.0-arpingpath.patch ... │
│Fixing OMF Makefiles ... │
│Disabling deprecation warnings ... │
│Running elibtoolize in: NetworkManager-0.9.10.0/ │
│ Applying target-nm/2.4.2 patch ... │
│Running elibtoolize in: NetworkManager-0.9.10.0/build-aux/ │
│ Applying portage/1.2.0 patch ... │
│ Applying sed/1.5.6 patch ... │
│ Applying as-needed/2.4.2 patch ... │
│INFO: install │
│Removing unnecessary /usr/lib64/libnm-util.la (no static archive) │
│Removing unnecessary /usr/lib64/libnm-glib.la (no static archive) │
│Removing unnecessary /usr/lib64/libnm-glib-vpn.la (no static archive) │
│Removing unnecessary /usr/lib64/NetworkManager/libnm-device-plugin-adsl.la (module) │
│Removing unnecessary /usr/lib64/NetworkManager/libnm-wwan.la (no static archive) │
│Removing unnecessary /usr/lib64/NetworkManager/libnm-device-plugin-wwan.la (module) │
│Removing unnecessary /usr/lib64/NetworkManager/libnm-device-plugin-bluetooth.la (module) │
│Removing unnecessary /usr/lib64/NetworkManager/libnm-device-plugin-wifi.la (module) │
│Removing unnecessary /usr/lib64/pppd/2.4.7/nm-pppd-plugin.la (module) │
│INFO: postinst │
│Updating desktop mime database ... │
│Updating shared mime info database ... │
│WARN: postinst │
│Ifnet plugin is now disabled because of it being unattended │
│and unmaintained for a long time, leading to some unfixed bugs │
│and new problems appearing. We will now use upstream 'keyfile'
│plugin. │
│Because of this, you will likely need to reconfigure some of │
│your networks. To do this you can rely on Gnome control center, │
│nm-connection-editor or nmtui tools for example.


[Edit, after fiddling around for a while]

In my case, the networkmanager stays at rc-status as started, but inactive.
I can't setup a new connection via GUI, cause no nic/device was recognized or listed into the GUI.

Even after deleting (moving to a secure place) two config files in:
Code:
/etc/NetworkManager/NetworkManager.conf

and all connection files listed here:
Code:
/etc/NetworkManager/system-connections/Connection*


and after restarting my system *(or minimalistic restarting the NetworkManager service of course), everthing works as expected.

* I used the chance to get rid of LP/Sievers systemd optimized udev, with the (un)predictable Network Names and do a downgrade (which is a real upgrade) to eudev. :wink:

Best, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
kavra
n00b
n00b


Joined: 22 Feb 2012
Posts: 29

PostPosted: Sat Oct 18, 2014 7:32 am    Post subject: Reply with quote

UberLord wrote:
Wow, that's a lot of code.

openrc has a template system now

Code:
#!/sbin/runscript

command=/usr/sbin/ModemManager
command_background=yes
pidfile=/run/ModemManager/ModemManager.pid
name="ModemManager daemon"

depend()
{
   provide net
   need dbus
}


Totally untested, but does the same job.


thanks!!!

it works fine, it's better
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum