Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Intel sound cards not recognized
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
NP_complete
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2009
Posts: 101

PostPosted: Wed Oct 15, 2014 10:38 pm    Post subject: [SOLVED] Intel sound cards not recognized Reply with quote

My laptop has two sound cards:

# lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)

but 'aplay -l' returns an empty list, even though pulseaudio is up and running.

# journalctl | grep -i audio
Oct 15 18:17:14 gazelle-laptop pulseaudio[349]: Failed to find a working profile.
Oct 15 18:17:14 gazelle-laptop pulseaudio[349]: Failed to load module "module-alsa-card" (argument: "device_id="1" name="pci-0000_00_1b.0" card_name="alsa_card.pci-0000_00_1b.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1""): initialization failed.

# cat /proc/asound/cards
0 [HDMI ]: HDA-Intel - HDA Intel HDMI
HDA Intel HDMI at 0xf7e14000 irq 44
1 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7e10000 irq 43

Needless to say, there is no sound. Can somebody please help?

Many thanks.


Last edited by NP_complete on Sun Oct 19, 2014 10:47 am; edited 1 time in total
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1199
Location: Motown

PostPosted: Wed Oct 15, 2014 11:23 pm    Post subject: Reply with quote

If it's something that recently happened with the install of pulseaudio-5.0-r3 it may be the change to the zeroconf useflag in place of the avahi useflag. If I build pulseaudio-5.0-r3 without the zeroconf useflag it doesn't work for me.
_________________
WYSIWYG - What You See Is What You Grep
Back to top
View user's profile Send private message
NP_complete
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2009
Posts: 101

PostPosted: Thu Oct 16, 2014 12:55 am    Post subject: Reply with quote

darkphader, the install *is* fresh. However, does pulseaudio really support zeroconf flag?? This is what I got:

[ebuild R ] media-sound/pulseaudio-5.0-r2 USE="X alsa asyncns bluetooth caps dbus gdbm glib gnome gtk ipv6 orc ssl systemd tcpd udev webrtc-aec -avahi -doc -equalizer -jack -libsamplerate -lirc (-neon) (-oss) -qt4 -realtime (-system-wide) {-test} -xen" ABI_X86="(64) (-32) (-x32)" 0 kB

Am I missing something?
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1199
Location: Motown

PostPosted: Thu Oct 16, 2014 2:02 am    Post subject: Reply with quote

was a change from r2 to r3, r2 uses the avahi flag, r3 uses the zeroconf flag
_________________
WYSIWYG - What You See Is What You Grep
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Oct 16, 2014 3:50 am    Post subject: Reply with quote

:roll: :roll: :roll:
seriously...
NP_complete wrote:
but 'aplay -l' returns an empty list, even though pulseaudio is up and running

If 'aplay -l' is empty, pulseaudio can do shit about it.
The way you describe it, it's either a kernel problem or you somehow completely broke alsa.
As /proc/asound/cards isn't empty, instead of trivial greps, post 'lspci -k' for those two devices and the contents of /proc/asound/devices.
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1199
Location: Motown

PostPosted: Thu Oct 16, 2014 3:59 am    Post subject: Reply with quote

Adding that I didn't run 'aplay -l' at the time but attempting to play a file with aplay failed with some pulseaudio issue yet alsamixer worked just fine. Not saying this is/was your issue, just a heads up.
_________________
WYSIWYG - What You See Is What You Grep
Back to top
View user's profile Send private message
NP_complete
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2009
Posts: 101

PostPosted: Fri Oct 17, 2014 12:19 am    Post subject: Reply with quote

VoidMage,

After some kernel tweaking, this is was I am getting when I am in text-only mode, and GNOME is NOT running:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: VT1802 Analog [VT1802 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 2: VT1802 Alt Analog [VT1802 Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

When I run 'aplay -l' from GNOME Terminal, I get

aplay: device_list:268: no soundcards found...

No sound yet...


Many thanks!
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Oct 17, 2014 12:31 am    Post subject: Reply with quote

NP_complete wrote:
After some kernel tweaking, this is was I am getting when I am in text-only mode, and GNOME is NOT running:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: VT1802 Analog [VT1802 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 2: VT1802 Alt Analog [VT1802 Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

When I run 'aplay -l' from GNOME Terminal, I get

aplay: device_list:268: no soundcards found...

No sound yet...

Interesting...
Post 'ls -l /dev/snd/' and 'getfacl /dev/snd/*' for both console *and* Gnome case.
Also, as it's not quite clear, if the soundcard driver has been compiled as a module, post 'lsmod' for both cases.
Back to top
View user's profile Send private message
NP_complete
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2009
Posts: 101

PostPosted: Fri Oct 17, 2014 1:36 am    Post subject: Reply with quote

1. I compiled the ALSA support into the kernel.

2. The first command produced the same output In both cases:

$ ls -l /dev/snd/
total 0
drwxr-xr-x 2 root root 80 Oct 16 20:08 by-path
crw-rw----+ 1 root audio 116, 0 Oct 16 20:08 controlC0
crw-rw----+ 1 root audio 116, 32 Oct 16 20:08 controlC1
crw-rw----+ 1 root audio 116, 4 Oct 16 20:08 hwC0D0
crw-rw----+ 1 root audio 116, 36 Oct 16 20:08 hwC1D0
crw-rw----+ 1 root audio 116, 19 Oct 16 20:09 pcmC0D3p
crw-rw----+ 1 root audio 116, 23 Oct 16 20:09 pcmC0D7p
crw-rw----+ 1 root audio 116, 56 Oct 16 20:09 pcmC1D0c
crw-rw----+ 1 root audio 116, 48 Oct 16 20:49 pcmC1D0p
crw-rw----+ 1 root audio 116, 50 Oct 16 20:08 pcmC1D2p
crw-rw----+ 1 root audio 116, 1 Oct 16 20:08 seq
crw-rw----+ 1 root audio 116, 33 Oct 16 20:08 timer

FOR GNOME:

$ getfacl /dev/snd/*
# file: dev/snd/by-path
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

# file: dev/snd/controlC0
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/controlC1
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/hwC0D0
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/hwC1D0
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D3p
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D7p
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D0c
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D0p
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D2p
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/seq
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/timer
# owner: root
# group: audio
user::rw-
group::rw-
mask::rw-
other::---

FOR CONSOLE:

$ getfacl /dev/snd/*
# file: dev/snd/by-path
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

# file: dev/snd/controlC0
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/controlC1
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/hwC0D0
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/hwC1D0
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D3p
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC0D7p
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D0c
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D0p
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/pcmC1D2p
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/seq
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

# file: dev/snd/timer
# owner: root
# group: audio
user::rw-
user:user:rw-
group::rw-
mask::rw-
other::---

DIFF (console vs gnome):

12d11
< user:user:rw-
21d19
< user:user:rw-
30d27
< user:user:rw-
39d35
< user:user:rw-
48d43
< user:user:rw-
57d51
< user:user:rw-
66d59
< user:user:rw-
75d67
< user:user:rw-
84d75
< user:user:rw-
93d83
< user:user:rw-
102d91
< user:user:rw-

# diff /boot/config-3.14.14-gentoo /boot/config-3.14.14-gentoo.old
2424,2425c2424,2425
< CONFIG_SND_HDA_CODEC_VIA=y
< CONFIG_SND_HDA_CODEC_HDMI=y
---
> # CONFIG_SND_HDA_CODEC_VIA is not set
> # CONFIG_SND_HDA_CODEC_HDMI is not set
2433c2433
< CONFIG_SND_HDA_GENERIC=y
---
> # CONFIG_SND_HDA_GENERIC is not set

lsmod gives the same output everywhere:

Module Size Used by
iTCO_wdt 4967 0
r8169 57210 0
lpc_ich 13248 0
mfd_core 3065 1 lpc_ich
x86_pkg_temp_thermal 4717 0
iwlmvm 116277 0
iwlwifi 69224 1 iwlmvm
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Oct 17, 2014 3:32 pm    Post subject: Reply with quote

...Use unified diffs next time.

Anyway, this seems to be a permission problem, but there's something odd here (it'd be more common the other way around)...

How exactly is xserver run ?
Are you under systemd or not ?
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 271

PostPosted: Fri Oct 17, 2014 5:38 pm    Post subject: Reply with quote

@NP_complete, it seems to be we have the same audio-card
Quote:
lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
and I ran in the same issue.
I don't use neither systemd or pulseaudio.

A simple file solved the problem
/etc/asound.conf wrote:
pcm.!default {
type hw
card PCH
}

ctl.!default {
type hw
card PCH
}

_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
NP_complete
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2009
Posts: 101

PostPosted: Fri Oct 17, 2014 10:34 pm    Post subject: Reply with quote

VoidMage,

1. The way my X server is run is:

$ cat .xinitrc
exec gnome-session

2. Yes, I'm using systemd (and GNOME3).

3. I've had polkit-related permission problems before.

Jean-Paul,

I tried this out, didn't work. I may still need the config you suggested. This could be a multi-layered problem: several things are messed up at once.
Back to top
View user's profile Send private message
xliefssy
n00b
n00b


Joined: 30 Sep 2013
Posts: 2

PostPosted: Sat Oct 18, 2014 1:31 am    Post subject: Reply with quote

Could you provide the out put of following commands?

grep SND_HDA /usr/src/linux/.config

aplay -L
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sat Oct 18, 2014 2:24 pm    Post subject: Reply with quote

OK, I'm not on systemd and hope to keep away from it for as long as possible, nevertheless...

Check if systemd useflag is set on pulseaudio/gnome-session/gdm/etc. Also, some of the posts here suggest that that under systemd, your user should *not* be in audio group.
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1199
Location: Motown

PostPosted: Sat Oct 18, 2014 2:44 pm    Post subject: Reply with quote

VoidMage wrote:
Check if systemd useflag is set on pulseaudio/gnome-session/gdm/etc. Also, some of the posts here suggest that that under systemd, your user should *not* be in audio group.


Is that verifiable information? I moved to systemd some time ago and my user is in the audio group, however I have no experienced issues because of this.
_________________
WYSIWYG - What You See Is What You Grep
Back to top
View user's profile Send private message
NP_complete
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2009
Posts: 101

PostPosted: Sat Oct 18, 2014 5:02 pm    Post subject: Reply with quote

Thanks all of you guys very much for helping. I've been off Gentoo for a while, and this is the first time ever I want to set it up on a laptop. This is also the first time I am confronting systemd. Systemd used to win in the beginning, but now it looks more like a draw. Anyway...

Whatever I did, I'm now getting sound, through 'speaker-test', on the console only. No sound on GNOME3, but 'speaker-test' behaves identically in both environments. Adjusting the master volume through 'alsamixer' inside Gnome Terminal moves the sound level slider inside the Gnome Control Panel in the upper right corner.

HERE IS THE WEIRDEST PART:
1. In Gnome Terminal, I execute 'aplay -t wav sample.wav', which, if run through console, would play for a few seconds, then exit.
2. However, in Gnome Terminal, this command hangs indefinitely ...
3. ... until I hit Ctrl Alt F-something, which brings me to the log screen with a bunch of X server-related messages.
4. It is then that I finally hear the sounds from the aplay command above.

Can you believe this????


xliefssy,

$ grep SND_HDA /usr/src/linux/.config
CONFIG_SND_HDA_INTEL=y
CONFIG_SND_HDA_PREALLOC_SIZE=64
CONFIG_SND_HDA_HWDEP=y
# CONFIG_SND_HDA_RECONFIG is not set
# CONFIG_SND_HDA_INPUT_BEEP is not set
# CONFIG_SND_HDA_INPUT_JACK is not set
# CONFIG_SND_HDA_PATCH_LOADER is not set
# CONFIG_SND_HDA_CODEC_REALTEK is not set
# CONFIG_SND_HDA_CODEC_ANALOG is not set
# CONFIG_SND_HDA_CODEC_SIGMATEL is not set
CONFIG_SND_HDA_CODEC_VIA=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_I915=y
# CONFIG_SND_HDA_CODEC_CIRRUS is not set
# CONFIG_SND_HDA_CODEC_CONEXANT is not set
# CONFIG_SND_HDA_CODEC_CA0110 is not set
# CONFIG_SND_HDA_CODEC_CA0132 is not set
# CONFIG_SND_HDA_CODEC_CMEDIA is not set
# CONFIG_SND_HDA_CODEC_SI3054 is not set
CONFIG_SND_HDA_GENERIC=y
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0


Under GNOME3:
$ aplay -L
<No output>

Under GNOME3:
$ aplay -l
aplay: device_list:268: no soundcards found...

On the console:
$ aplay -L
hdmi:CARD=HDMI,DEV=0
HDA Intel HDMI, HDMI 0
HDMI Audio Output
hdmi:CARD=HDMI,DEV=1
HDA Intel HDMI, HDMI 1
HDMI Audio Output
sysdefault:CARD=PCH
HDA Intel PCH, VT1802 Analog
Default Audio Device
front:CARD=PCH,DEV=0
HDA Intel PCH, VT1802 Analog
Front speakers
surround40:CARD=PCH,DEV=0
HDA Intel PCH, VT1802 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
HDA Intel PCH, VT1802 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
HDA Intel PCH, VT1802 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
HDA Intel PCH, VT1802 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
HDA Intel PCH, VT1802 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

By the way, WELCOME! I see this was your first post.


VoidMage,

1. Per your instructions I enabled 'systemd' USE flag globally in /etc/portage/make.conf, and ran

emerge --update --newuse --deep @world

Nothing came up.

2. I'm *not* in the 'audio' group. Yes, I've read that publicity about staying out of it.
Back to top
View user's profile Send private message
xliefssy
n00b
n00b


Joined: 30 Sep 2013
Posts: 2

PostPosted: Sun Oct 19, 2014 12:05 am    Post subject: Reply with quote

The kernel config looks OK, and the output from aplay -L in console shows the correct info.
I have a latest stable gentoo install in virtualbox with gnome3 and systemd, audio just works. I use gnome/systemd profile.

It's very likely a permission problem. You may get some useful information from gentoo pulseaudio wiki page.

http://wiki.gentoo.org/wiki/PulseAudio
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun Oct 19, 2014 3:43 am    Post subject: Reply with quote

:roll: well, of course it's a permission problem, that "WEIRDEST PART" pretty much confirms it.

The thing is, Gnome has been suffering from systemd lock-in for a few releases already, so it'd be far more natural for things to go the other way around, that is not work in console.
With consolekit, the answer would heavily depend on the output of ck-list-sessions, I don't know the systemd equivalent of that query.
It's about figuring out which user systemd considers the active one.
Back to top
View user's profile Send private message
NP_complete
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2009
Posts: 101

PostPosted: Sun Oct 19, 2014 10:46 am    Post subject: Reply with quote

VoidMage,

I gotta say, your insights were quite helpful.

MY MESSAGE TO ALL GNOME3 USERS: YOU ARE *MUCH* BETTER OFF WITH GDM STARTING ON BOOT.

My habit (which I inherited from Gnome-2 era) was to boot in text-only mode and execute 'startx' manually. In theory, this is still possible under Gnome-3, but you will be in for A LOT of frustration. I had a related (it turns out) problem where the NetworkManager was not connecting to any WiFi when run as non-root. After approximately 2 months of searching and asking (https://bugzilla.gnome.org/show_bug.cgi?id=736206) I narrowed it down to a line in /etc/share/polkit-1/rules.d/01-org.freedesktop.NetworkManager.settings.modify.system.rule :

polkit.addRule(action,subject) {
.................
if (... && subject.active) ..... 'PROBLEM!'
.................
}

The 'subject.active' was false, and I had to take it out. Then, while I was fighting with the sound problem, I read your comment and figured the system might be seeing me as two different 'subjects' depending on the mode I was in: GNOME or console. This duality is quashed by enabling the GDM daemon. I was then able to re-add the 'subject.active' to the above predicate, and the NetworkManager remained functional.

SOLVED!!

PS Another reason to use GDM is that it's the only way Gnome-3 lets you lock the screen, now that they've phased some relevant legacy package out. This is also a Gnome-3 artifact: under Gnome-2 locking the screen was a simple feature that "just worked".
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Sun Oct 19, 2014 3:41 pm    Post subject: Reply with quote

NP_complete wrote:
PS Another reason to use GDM is that it's the only way Gnome-3 lets you lock the screen, now that they've phased some relevant legacy package out. This is also a Gnome-3 artifact: under Gnome-2 locking the screen was a simple feature that "just worked".

By "legacy", you actually mean "non-systemd" and by "Gnome-3 artifact" you actually mean "systemd quirk".
With such corrections, I sort of agree.
But for documentation purpose, would you mind checking my earlier question, that is "which command/dbus call returns the active session/seat/user under systemd ?".
Back to top
View user's profile Send private message
NP_complete
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2009
Posts: 101

PostPosted: Sun Oct 19, 2014 5:25 pm    Post subject: Reply with quote

Quote:
which command/dbus call returns the active session/seat/user under systemd ?

I'll definitely see what I can find out. I will edit this post. In the meantime, maybe some systemd folks can speak up??
Back to top
View user's profile Send private message
Arthanis
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 166

PostPosted: Tue Oct 21, 2014 11:45 pm    Post subject: Reply with quote

Jean-Paul wrote:
@NP_complete, it seems to be we have the same audio-card
Quote:
lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
and I ran in the same issue.
I don't use neither systemd or pulseaudio.

A simple file solved the problem
/etc/asound.conf wrote:
pcm.!default {
type hw
card PCH
}

ctl.!default {
type hw
card PCH
}


I can confirmd this fix, as I have the exact same sound card, although I do not use systemd
My /etc/asound.conf

Quote:

pcm.!default {
type hw
card 1
}

ctl.!default {
type hw
card 0
}




Although I cannot get hdmi sound to work.

Maybe you should try to get your card to work without pulse or systemd (if possible), then start from there.
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 271

PostPosted: Wed Oct 22, 2014 3:26 pm    Post subject: Reply with quote

Arthanis wrote:
Although I cannot get hdmi sound to work.
That's my situation too. I hear music via "HDA Intel PCH, VT1802 Analog"
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
geol
n00b
n00b


Joined: 18 Dec 2018
Posts: 10

PostPosted: Sun Feb 23, 2020 6:25 pm    Post subject: Reply with quote

Jean-Paul wrote:
@NP_complete, it seems to be we have the same audio-card
Quote:
lspci | grep -i audio
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
and I ran in the same issue.
I don't use neither systemd or pulseaudio.

A simple file solved the problem
/etc/asound.conf wrote:
pcm.!default {
type hw
card PCH
}

ctl.!default {
type hw
card PCH
}


This one helped me! Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum