Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unable to connect to a specific wireless network
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Oct 12, 2014 1:14 pm    Post subject: unable to connect to a specific wireless network Reply with quote

I can normally connect to wireless APs, there is one AP that I'm having difficulties with

I'm using networkmanager and the nm-applet(wifi use flag enabled), here's wpa_supplicant:
net-wireless/wpa_supplicant-2.2-r1 USE="dbus readline wps -ap -eap-sim -fasteap -gnutls -p2p (-ps3) -qt4 (-selinux) -smartcard -ssl -wimax" 0 kB

Cell 01 - Address: C0:3F:0E:21:43:AE
Channel:3
Frequency:2.422 GHz (Channel 3)
Quality=70/70 Signal level=-179 dBm
Encryption key:on
ESSID:"LinuxPlus-LAB2"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000005391ecb1d2
Extra: Last beacon: 1ms ago
IE: Unknown: 000E4C696E7578506C75732D4C414232
IE: Unknown: 010482848B96
IE: Unknown: 030103
IE: Unknown: 2A0100
IE: Unknown: 32080C1218243048606C
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Preauthentication Supported
IE: Unknown: DD180050F202010100000364000027A4000041435E0061322F00
IE: Unknown: DD890050F204104A00011010440001021041000100103B0001031047001034E3FC5B67A6B20F3894EAF77D47AD8B102100074E4554474541521023000844473833344776351024000844473833344776351042000A313233343536373839301054000800060050F20400011011001644473833344776352028576972656C65737320415029100800020086


when I try to connect;

$dmesg
[ 2319.647163] wlan0: authenticate with c0:3f:0e:21:43:ae
[ 2319.648330] wlan0: send auth to c0:3f:0e:21:43:ae (try 1/3)
[ 2319.650413] wlan0: authenticated
[ 2319.650520] wlan0: AP has invalid WMM params (AIFSN=1 for ACI 2), disabling WMM
[ 2319.650548] wlan0: associate with c0:3f:0e:21:43:ae (try 1/3)
[ 2319.655180] wlan0: RX AssocResp from c0:3f:0e:21:43:ae (capab=0x31 status=0 aid=1)
[ 2319.655724] brcmsmac bcma0:0: brcmsmac: brcms_ops_bss_info_changed: associated
[ 2319.655728] brcmsmac bcma0:0: brcms_ops_bss_info_changed: qos enabled: false (implement)
[ 2319.655735] wlan0: associated
[ 2329.651485] wlan0: deauthenticating from c0:3f:0e:21:43:ae by local choice (Reason: 3=DEAUTH_LEAVING)
[ 2329.652467] brcmsmac bcma0:0: brcmsmac: brcms_ops_bss_info_changed: disassociated
[ 2329.652472] brcmsmac bcma0:0: brcms_ops_bss_info_changed: qos enabled: false (implement)
[ 2329.653178] cfg80211: Calling CRDA to update world regulatory domain
[ 2329.655225] cfg80211: World regulatory domain updated:
[ 2329.655228] cfg80211: DFS Master region: unset
[ 2329.655229] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 2329.655231] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2329.655233] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2329.655234] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2329.655236] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2329.655237] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2342.344653] wlan0: authenticate with c0:3f:0e:21:43:ae
[ 2342.345698] wlan0: send auth to c0:3f:0e:21:43:ae (try 1/3)
[ 2342.348295] wlan0: authenticated
[ 2342.348483] wlan0: AP has invalid WMM params (AIFSN=1 for ACI 2), disabling WMM
[ 2342.348918] wlan0: associate with c0:3f:0e:21:43:ae (try 1/3)
[ 2342.354058] wlan0: RX AssocResp from c0:3f:0e:21:43:ae (capab=0x31 status=0 aid=1)
[ 2342.354539] brcmsmac bcma0:0: brcmsmac: brcms_ops_bss_info_changed: associated
[ 2342.354542] brcmsmac bcma0:0: brcms_ops_bss_info_changed: qos enabled: false (implement)
[ 2342.354551] wlan0: associated
[ 2343.831458] wlan0: deauthenticating from c0:3f:0e:21:43:ae by local choice (Reason: 3=DEAUTH_LEAVING)
[ 2343.832466] brcmsmac bcma0:0: brcmsmac: brcms_ops_bss_info_changed: disassociated
[ 2343.832472] brcmsmac bcma0:0: brcms_ops_bss_info_changed: qos enabled: false (implement)
[ 2343.833684] cfg80211: Calling CRDA to update world regulatory domain
[ 2343.835766] cfg80211: World regulatory domain updated:
[ 2343.835769] cfg80211: DFS Master region: unset
[ 2343.835770] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 2343.835774] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2343.835776] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2343.835778] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2343.835780] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2343.835782] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)


thanks
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Wed Oct 15, 2014 11:19 am    Post subject: Reply with quote

I was able to connect to the wireless network today(out of the blue), the kernel panics after using wireless for abit, the kernel only panics when I connect to this wireless network
I was unable to capture an image of the panic message, I'm working on it though
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum