Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to Upgrade KDE and Calligra-Suite Version [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Fri Oct 10, 2014 5:22 am    Post subject: Unable to Upgrade KDE and Calligra-Suite Version [Solved] Reply with quote

Hello, again, Gentoo forum members.

 :D

I have been unable to upgrade from KDE 4.12.5 to 4.14.1 (meta). I have searched through the forums and the wiki about upgrading, but I still can not get it to work. The main reason I am trying to upgrade, is because the drawing program Krita, version 2.7.5, is unstable, constantly crashes, and lacks the features that I am used to which are in the 2.8+ versions. I use Krita quite a bit for my digital art creation. So it is very frustrating not being able to use it. Gimp and MyPaint (I still use both) lack the drawing functionality that I need (am used to) in order to work at my art. However, in order to upgrade to the newer version, I need to upgrade to the higher version of KDE. Please bear in mind that the way Gentoo works and is managed is all new to me; it is almost starting to learn Linux all over again. To my understanding, I have not used any overlays. I am just beginning to learn how it works, but have not installed any programs because of my current difficulties (I don't need more errors).



So far what I have done/tried is:
Code:
emerge -u $(qlist -IC kde-base/)
to try to upgrade kde after I added:
Code:
>=kde-base/kde-meta-4.14.0 ~amd64
to my "package.accept_keywords", I "emerge --sync", "emerge -avNDu world", and pasted the dependencies that the output listed in the "package.use" file. However, with the world update, I keep getting this: https://gist.github.com/8a8d5d326522717e8446

This is my package.use: https://gist.github.com/0c7911bf2230726c5735
package.accept_keywords: https://gist.github.com/3649abaec825fd898175
package.mask: https://gist.github.com/4049c0d34ad48202c17b


Obviously I am having other issues besides not being able to update or upgrade which is causing the block; I am really having a hard time with this. I think that I dug myself into a hole on this one. I do not know if I should start un-installing programs or what?
So if anyone could help me out I would greatly appreciate it.


Thanks for your time.

Cheers!


Last edited by Tefrem34 on Thu Oct 23, 2014 1:00 am; edited 1 time in total
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 216
Location: Cali - Colombia

PostPosted: Fri Oct 10, 2014 4:46 pm    Post subject: Reply with quote

What happens if you do:

emerge -1av media-video/ffmpeg
_________________
abe
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Fri Oct 10, 2014 5:15 pm    Post subject: Reply with quote

Thanks for the reply bec.
Code:
emerge -1av media-video/ffmpeg

this is what I get: https://gist.github.com/aaf0ce14daa829c87da1
well I was looking at what was sent to pastebin and it isn't showing the whole message.
Quote:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-video/ffmpeg:0

(media-video/ffmpeg-2.2.8::gentoo, installed) pulled in by
>=media-video/ffmpeg-1.2.6-r1:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r2::gentoo, installed)

(media-video/ffmpeg-1.2.6::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)
!!! The following installed packages are masked:
- kde-base/nepomuk-4.12.5::gentoo (masked by: package.mask)
- media-libs/libaacplus-2.0.2-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 216
Location: Cali - Colombia

PostPosted: Fri Oct 10, 2014 7:51 pm    Post subject: Reply with quote

are you on stable ?
_________________
abe
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Fri Oct 10, 2014 10:11 pm    Post subject: Reply with quote

yes
I installed the kde-meta with the default dependencies. I am only just learning how to configure the accept_keywords and use files to chose versions.
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 216
Location: Cali - Colombia

PostPosted: Sat Oct 11, 2014 8:52 pm    Post subject: Reply with quote

I am using kde-4.14.1 in unstable, maybe someone with stable can give you more help.
_________________
abe
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sun Oct 12, 2014 4:24 am    Post subject: Reply with quote

Thanks :D
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Oct 18, 2014 7:18 am    Post subject: Reply with quote

okay, I have been trying to fix my dependency issues in order to upgrade my KDE environment. I think that I am close, but these dependencies are giving me trouble.
Quote:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libdrm:0

(x11-libs/libdrm-2.4.56::gentoo, installed) pulled in by
>=x11-libs/libdrm-2.4.56[video_cards_freedreno?,video_cards_nouveau?,video_cards_vmware?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/mesa-10.3.0::gentoo, ebuild scheduled for merge)

(x11-libs/libdrm-2.4.52::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

kde-base/kdelibs:4

(kde-base/kdelibs-4.12.5-r2::gentoo, installed) pulled in by
>=kde-base/kdelibs-4.12.5:4[aqua=,semantic-desktop] required by (kde-base/kaddressbook-4.12.5::gentoo, installed)
>=kde-base/kdelibs-4.6.4:4[aqua=,semantic-desktop?] required by (app-office/calligra-2.7.5::gentoo, installed)
>=kde-base/kdelibs-4.12.5:4[aqua=,semantic-desktop] required by (kde-base/akonadiconsole-4.12.5::gentoo, installed)

(kde-base/kdelibs-4.14.1::gentoo, ebuild scheduled for merge) pulled in by
>=kde-base/kdelibs-4.14.1:4[aqua=] required by (kde-base/drkonqi-4.14.1::gentoo, ebuild scheduled for merge)
(and 282 more with the same problem)

kde-base/liboxygenstyle:4

(kde-base/liboxygenstyle-4.11.12::gentoo, ebuild scheduled for merge) pulled in by
>=kde-base/liboxygenstyle-4.11.12:4[aqua=] required by (kde-base/kwin-4.11.12::gentoo, ebuild scheduled for merge)

(kde-base/liboxygenstyle-4.11.9::gentoo, installed) pulled in by
kde-base/liboxygenstyle:4/4.11.9= required by (kde-base/kstyles-4.11.9::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- kde-base/kaddressbook-4.12.5::gentoo (masked by: package.mask)
- app-office/calligra-2.7.5::gentoo (masked by: package.mask)
- kde-base/akonadiconsole-4.12.5::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

If someone could point me in the right direction I would greatly appreciate it.
Thanks
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Sat Oct 18, 2014 11:51 pm    Post subject: Reply with quote

...:sigh:...
For the moment, let's go back to your first post in this thread.

I hope that you've already dealt with the bogus downgrades and ran etc-update.

Now, while I don't use KDE, the package description is quite clear - baloo is the successor of nepomuk.
So the question is "what was still pulling nepomuk during the original emerge run ?".

Weren't there any interesting lines after the last one in that emerge pastebin ?
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Tue Oct 21, 2014 7:11 pm    Post subject: Reply with quote

Thanks for the reply. :)
Quote:
I hope that you've already dealt with the bogus downgrades and ran etc-update
Yes I have ran etc-update every time that I made any changes to fix the conflicts. I even downgraded ffmpeg, which some how messed up my video codec in vlc and all the other media players. Clementine no longer works either. I think this is because I can't rebuild anything because of the kde version conflicts.
I had read about baloo replacing nepomuk, so I expected that.
Quote:
what was still pulling nepomuk during the original emerge run ?
Quote:
[uninstall ] kde-base/nepomuk-4.12.5:4/4.12 USE="handbook (-aqua) -debug"
[blocks b ] <kde-base/nepomuk-4.12.50 ("<kde-base/nepomuk-4.12.50" is blocking kde-base/baloo-4.14.1)
(kde-base/kdelibs-4.14.1::gentoo, ebuild scheduled for merge) pulled in by
>=kde-base/kdelibs-4.11.12:4[aqua=,nepomuk?] required by (kde-base/plasma-workspace-4.11.12::gentoo, ebuild scheduled for merge)
>=kde-base/kdelibs-4.14.1:4[aqua=] required by (kde-base/kshisen-4.14.1::gentoo, ebuild scheduled for merge)
(and 282 more with the same problems)
I think that the other messages where conflicts with ffmpeg version, so I changed it to a previous version and so I no longer have that message. It is just the kde dependencies now.
I have the 3 packages in the mask file but I still get the conflict with the kdelibs,
Quote:
!!! The following installed packages are masked:
- kde-base/kaddressbook-4.12.5::gentoo (masked by: package.mask)
- app-office/calligra-2.7.5::gentoo (masked by: package.mask)
- kde-base/akonadiconsole-4.12.5::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
should I just uninstall them do the update and reinstall? I will give it a try anyways and see what it does.
I hope that I answered your questions.
thanks again.


Last edited by Tefrem34 on Wed Oct 22, 2014 6:18 am; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue Oct 21, 2014 11:33 pm    Post subject: Reply with quote

'b' is a soft block, so that's not the problem.
As for package mask, those look like your own entries.

What exactly did you put into your package.mask ?
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Wed Oct 22, 2014 5:40 am    Post subject: Reply with quote

Currently, I commented out most of it to see if it would help with my blocked packages. But I think that I will try uninstalling some of the programs to see if that will help.
Quote:
As for package mask, those look like your own entries
Yes, I am still trying to figure out how to manage my system, I am still a bit mutled by the new way of managing each application in gentoo; which I really like more than packaged programs that I have used with other distros. Trial and error for me.
Here is my package.mask https://gist.github.com/20d837944e3af13c0500
Thanks again for the assistance. :D
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Wed Oct 22, 2014 7:07 am    Post subject: Reply with quote

Well it looks like I did something right, so far. I unmerged kmail, kdelibs, and kaddressbook, (there might have been one more but I can't remember right now, I didn't write it down) and in between, emerge automatically had me add some programs to the use and mask files. I etc-update'd the changes for each one and then ran
Code:
emerge -avNDu world
after I did that, it finally started to do the updates. There are quite a few programs to compile, so it will probably take several hours before I know whether or not it was a success. :?: I will post when it does.
Thanks.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Thu Oct 23, 2014 1:00 am    Post subject: Reply with quote

It looks like that did it.
I have been reinstalling some of the applications in order for them to work, but that is easy enough.
There is one thing that I did notice that was odd, was after I rebooted my system as it loaded the text, after grub loaded, there was a long list of ntfs notices that ran for a minute and a half, before I got to my terminal prompt. Usually it only takes a few seconds to load into the tty. Does anyone have an idea why it did it. I haven't rebooted yet, so I don't know if it will be persistent or not.

Thanks again for the help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum