Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto]problema con eth
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
la papera
n00b
n00b


Joined: 18 Sep 2014
Posts: 14

PostPosted: Wed Oct 08, 2014 9:24 am    Post subject: [risolto]problema con eth Reply with quote

giorno a tutti, piccolo problema con eth non riconosciute come eth ma :
ifconfig le rileva come
enp4s0
enp4s6
e poi cè il classico
lo

non mi era mai capitato ...... che faccio?


Last edited by la papera on Thu Oct 09, 2014 9:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
la papera
n00b
n00b


Joined: 18 Sep 2014
Posts: 14

PostPosted: Wed Oct 08, 2014 9:48 am    Post subject: Reply with quote

capito.... è il nuovo modo imposto da udev
ma cosa cambia nella configurazione perche nn riesco a connettermi ad internet
Back to top
View user's profile Send private message
nollo
n00b
n00b


Joined: 15 Mar 2013
Posts: 33
Location: Ferrara - Italy

PostPosted: Wed Oct 08, 2014 4:19 pm    Post subject: Reply with quote

Ciao
allora per prima cosa dai questo comando

Code:
ls /sys/class/net


poi

Code:
cat /sys/class/net/device_name/address

verrà fuori una stringa tipo la mia
c8:60:00:61:45:46

crea una regola per udev
Code:
echo "SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="c8:60:00:61:45:46", NAME="net0"" > /etc/udev.d/10_network.rules


poi segui la guida di Gentoo

devi modificare anche il file /etc/conf.d/net

ecco il mio:

Code:

config_net0="192.168.1.101 netmask 255.255.255.0 brd 192.168.1.255"
routes_net0="default via 192.168.1.1"



Code:
cd /etc/init.d
ln -s net.lo net.net0
rc-update add net.net0 default


nota che l'interfaccia di rete adesso si chiama net0 e non eth0
ricordati di controllare il file /etc/resolv.conf

Spero che sia chiaro.

Ciao
Back to top
View user's profile Send private message
la papera
n00b
n00b


Joined: 18 Sep 2014
Posts: 14

PostPosted: Thu Oct 09, 2014 9:15 pm    Post subject: Reply with quote

problema risolto , grazie mille nollo !!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum