Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED: sa-update fails with Perl API mismatch error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
dieter.76
n00b
n00b


Joined: 07 Oct 2014
Posts: 3

PostPosted: Tue Oct 07, 2014 8:13 pm    Post subject: SOLVED: sa-update fails with Perl API mismatch error Reply with quote

Hi,

when running "sa-update" as root, I am getting the following error message:

--

# sa-update
Perl API version v5.16.0 of HTML::Parser does not match v5.18.0 at /usr/lib64/perl5/5.18.2/XSLoader.pm line 92.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/5.18.2/Mail/SpamAssassin/HTML.pm line 27.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/5.18.2/Mail/SpamAssassin/HTML.pm line 27.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/5.18.2/Mail/SpamAssassin/Message/Node.pm line 43.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/5.18.2/Mail/SpamAssassin/Message/Node.pm line 43.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/5.18.2/Mail/SpamAssassin/Message.pm line 50.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/5.18.2/Mail/SpamAssassin/Message.pm line 50.
Compilation failed in require at /usr/local/lib64/perl5/5.16.3/Mail/SpamAssassin.pm line 75.
BEGIN failed--compilation aborted at /usr/local/lib64/perl5/5.16.3/Mail/SpamAssassin.pm line 75.
Compilation failed in require at /usr/local/bin/sa-update line 92.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 92.

--

Any ideas? I tried re-emerging spamassassin, dev-perl/HTML-Parsner and all other dev-perl modules but that did not work. Also, perl-cleaner did not improve the situation - any suggestions?

Many thanks.

Kind regards
Dieter


Last edited by dieter.76 on Wed Oct 08, 2014 6:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
dieter.76
n00b
n00b


Joined: 07 Oct 2014
Posts: 3

PostPosted: Wed Oct 08, 2014 6:01 pm    Post subject: SOLVED: Edited sa-update directly Reply with quote

Hi,

line 92 of sa-update was the problem with a hard-coded perl lib path pointing to a 5.16.3 or something which basically was no longer valid.

Kind regards
Dieter
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum