Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]problemi dopo un emerge --sync
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Mon Sep 29, 2014 8:04 am    Post subject: [RISOLTO]problemi dopo un emerge --sync Reply with quote

Salve,
qualcuno mi può suggerire come risolvere questi conflitti emersi dopo un
Quote:
emerge --sync

uno riguarda il portage in
Quote:
emerge portage

Code:

Calculating dependencies... done!
[ebuild     U  ] sys-apps/portage-2.2.8-r2 [2.2.8-r1] PYTHON_TARGETS="(-python3_2*)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-2.2.8-r1::gentoo, installed) pulled in by
    sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (app-admin/webapp-config-1.52-r1::gentoo, installed)

  (sys-apps/portage-2.2.8-r2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


e anche per il perl ho problemi di questo tipo
Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Tty-1.110.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/TimeDate-2.300.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-db/mytop-1.6-r4::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-File-Temp-0.220.0-r3::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (net-analyzer/net-snmp-5.7.3_pre3::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (mail-filter/razor-2.85-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-1.25-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-Tail-0.99.3-r1::gentoo, installed)
    dev-lang/perl:0/5.16= required by (net-print/cups-filters-1.0.53::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Geo-IP-1.420.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Mail-DKIM-0.400.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (mail-filter/spamassassin-fuzzyocr-3.6.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/MIME-tools-5.504.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Encode-2.470.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/String-Approx-3.270.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/version-0.990.100-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    (and 3 more with the same problems)

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-Scalar-List-Utils-1.270.0-r2::gentoo, installed)
    (and 16 more with the same problem)


grazie in anticipo,
Maurizio


Last edited by pigreco on Tue Sep 30, 2014 9:02 am; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 671

PostPosted: Mon Sep 29, 2014 9:43 am    Post subject: Reply with quote

Code:
# perl-cleaner --all


:?:
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Mon Sep 29, 2014 11:03 am    Post subject: Reply with quote

questo il risultato
Code:
per perl-cleaner --all


Code:
perl-cleaner --all

 * Beginning a clean up of .ph files
 * Excluding files for 5.16.3 and 5.16.3/i686-linux from cleaning

 * Locating ph files for removal

 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: File o directory non esistente
Can't open sys/_types.h: File o directory non esistente
Can't open gnu/stubs-64.h: File o directory non esistente
Can't open gnu/stubs-x32.h: File o directory non esistente
Can't open gnu/stubs-64.h: File o directory non esistente
Can't open gnu/stubs-x32.h: File o directory non esistente
Can't open gnu/stubs-64.h: File o directory non esistente
Can't open gnu/stubs-x32.h: File o directory non esistente
Can't open gnu/stubs-64.h: File o directory non esistente
Can't open gnu/stubs-x32.h: File o directory non esistente

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 * No package needs to be reinstalled.

 * Finding left over modules and header

 * The following files remain. These were either installed by hand
 * or edited. This script cannot deal with them.

/usr/lib/perl5/vendor_perl/5.12.4/XML/SAX/ParserDetails.ini
/usr/lib/perl5/5.12.4/CPAN/Config.pm
/usr/lib/perl5/5.12.4/CPAN/Config.pm~
/usr/lib/perl5/5.12.4/i686-linux/Encode/ConfigLocal.pm
/usr/lib/perl5/5.12.4/i686-linux/perllocal.pod
/usr/lib/perl5/site_perl/5.12.4/Carp/Clan.pm
/usr/lib/perl5/site_perl/5.12.4/Carp/Clan.pod
/usr/lib/perl5/site_perl/5.12.4/Test/Exception.pm
/usr/lib/perl5/site_perl/5.12.4/Sub/Uplevel.pod
/usr/lib/perl5/site_perl/5.12.4/Sub/Uplevel.pm
/usr/lib/perl5/site_perl/5.12.4/i686-linux/Storable.pm
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Carp/Clan/.packlist
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Storable/.packlist
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Storable/Storable.so
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Storable/Storable.bs
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Bit/Vector/Vector.bs
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Bit/Vector/.packlist
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Bit/Vector/Vector.so
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Test/Exception/.packlist
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Sub/Uplevel/.packlist
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Cache/Cache/.packlist
/usr/lib/perl5/site_perl/5.12.4/i686-linux/auto/Date/Calc/.packlist
/usr/lib/perl5/site_perl/5.12.4/i686-linux/Bit/Vector.pod
/usr/lib/perl5/site_perl/5.12.4/i686-linux/Bit/Vector/Overload.pod
/usr/lib/perl5/site_perl/5.12.4/i686-linux/Bit/Vector/String.pod
/usr/lib/perl5/site_perl/5.12.4/i686-linux/Bit/Vector/Overload.pm
/usr/lib/perl5/site_perl/5.12.4/i686-linux/Bit/Vector/String.pm
/usr/lib/perl5/site_perl/5.12.4/i686-linux/Bit/Vector.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/SharedMemoryBackend.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/NullCache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/SizeAwareMemoryCache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/MemoryBackend.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/BaseCache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/SharedMemoryCache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/MemoryCache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/CacheTester.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/SizeAwareFileCache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/BaseCacheTester.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/CacheUtils.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/CacheSizer.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/CacheMetaData.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/FileBackend.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/SizeAwareCacheTester.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/SizeAwareSharedMemoryCache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/Cache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/Object.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/SizeAwareCache.pm
/usr/lib/perl5/site_perl/5.12.4/Cache/FileCache.pm
/usr/lib/perl5/site_perl/5.12.4/Date/Calc/PP.pm
/usr/lib/perl5/site_perl/5.12.4/Date/Calc/PP.pod
/usr/lib/perl5/site_perl/5.12.4/Date/Calc/Object.pod
/usr/lib/perl5/site_perl/5.12.4/Date/Calc/Object.pm
/usr/lib/perl5/site_perl/5.12.4/Date/Calc.pod
/usr/lib/perl5/site_perl/5.12.4/Date/Calc.pm
/usr/lib/perl5/site_perl/5.12.4/Date/Calendar/Profiles.pod
/usr/lib/perl5/site_perl/5.12.4/Date/Calendar/Year.pod
/usr/lib/perl5/site_perl/5.12.4/Date/Calendar/Profiles.pm
/usr/lib/perl5/site_perl/5.12.4/Date/Calendar/Year.pm
/usr/lib/perl5/site_perl/5.12.4/Date/Calendar.pod
/usr/lib/perl5/site_perl/5.12.4/Date/Calendar.pm


e non risolve

Code:
emerge -uaD www-servers/apache

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/timezone-data-2014f [2014d] USE="-right_timezone%"
[ebuild     U  ] sys-libs/gdbm-1.11 [1.8.3-r4] USE="nls%* -exporter% -static-libs%"
[ebuild     U  ] dev-lang/perl-5.18.2-r1 [5.16.3]
[ebuild     U  ] virtual/perl-Storable-2.410.0-r1 [2.390.0]
[uninstall     ] perl-core/Storable-2.390.0-r1
[blocks b      ] <perl-core/Storable-2.410.0 ("<perl-core/Storable-2.410.0" is blocking virtual/perl-Storable-2.410.0-r1)
[ebuild     U  ] dev-perl/DBD-mysql-4.20.0-r1 [4.20.0]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Tty-1.110.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/TimeDate-2.300.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-db/mytop-1.6-r4::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-File-Temp-0.220.0-r3::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (net-analyzer/net-snmp-5.7.3_pre3::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (mail-filter/razor-2.85-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-1.25-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-Tail-0.99.3-r1::gentoo, installed)
    dev-lang/perl:0/5.16= required by (net-print/cups-filters-1.0.53::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Geo-IP-1.420.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Mail-DKIM-0.400.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (mail-filter/spamassassin-fuzzyocr-3.6.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/MIME-tools-5.504.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Encode-2.470.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/String-Approx-3.270.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/version-0.990.100-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    (and 3 more with the same problems)

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-Scalar-List-Utils-1.270.0-r2::gentoo, installed)
    (and 16 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
k01
Arch/Herd Tester
Arch/Herd Tester


Joined: 13 Feb 2008
Posts: 617
Location: Milano

PostPosted: Mon Sep 29, 2014 6:32 pm    Post subject: Reply with quote

un problema per volta, portage prima di tutto

Quote:
!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


hai provato ciò che ti suggerisce? quindi emerge -uN portage oppure emerge =sys-apps/portage-2.2.8-r2
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Tue Sep 30, 2014 12:55 am    Post subject: Reply with quote

no non ha aiutato

Code:
emerge --newuse --update  portage

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

WARNING: One or more updates have been skipped due to a dependency conflict:

sys-apps/portage:0

  (sys-apps/portage-2.2.8-r2::gentoo, ebuild scheduled for merge) conflicts with
    sys-apps/portage[python_targets_python2_7(-),python_targets_python3_2(-),-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (app-admin/webapp-config-1.52-r1::gentoo, installed)

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.


e il portage l'ho aggiornato rimuovendo app-admin/webapp-config e riemergendolo successivamente

ho provato una cosa simile per il perl

con un
Code:
emerge --unmerge =dev-lang/perl-5.16.3


Code:
emerge =dev-lang/perl-perl-5.18.2-r1


di seguito

Code:
revdep-rebuild


per ristabilire le dipendenze che sono venute e mancare ma il realtà non è stato reinstallato nessun pacchetto

e avevo ancora problemi
Code:
emerge --backtrack=30 -avuDN @world

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)

  (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds built with USE flags to satisfy "dev-lang/perl[-build]".
!!! One of the following packages is required to complete your request:
- dev-lang/perl-5.18.2-r1::gentoo (Missing IUSE: build)
- dev-lang/perl-5.16.3::gentoo (Missing IUSE: build)
(dependency required by "dev-perl/Authen-Libwrap-0.220.0" [installed])
(dependency required by "app-admin/webmin-1.610" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])




ho pensato di reinstallare quelli legati al precedente perl

Code:
emerge -auv dev-perl/Error dev-vcs/git dev-perl/IO-Socket-SSL dev-perl/Net-SSLeay


alla fine invece di aver sciolto mi trovavo così

Code:
emerge -avuDN @world

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "dev-lang/perl[-build]".
!!! One of the following packages is required to complete your request:
- dev-lang/perl-5.18.2-r1::gentoo (Missing IUSE: build)
- dev-lang/perl-5.16.3::gentoo (Missing IUSE: build)
(dependency required by "dev-perl/Authen-Libwrap-0.220.0" [installed])
(dependency required by "app-admin/webmin-1.610" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])



adesso ho in esecuzione
Code:
emerge -uaDN =dev-lang/perl-5.18.2-r1

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-kernel/linux-headers-3.13 [3.9]
[ebuild     U  ] sys-libs/ncurses-5.9-r3 [5.9-r2]
[ebuild     U  ] virtual/libintl-0-r1 [0]
[ebuild     U  ] sys-libs/gdbm-1.11 [1.8.3-r4] USE="nls%* -exporter% -static-libs%"
[ebuild   R    ] dev-lang/python-exec-2.0.1-r1  PYTHON_TARGETS="(-pypy2_0%*) (-python2_6%*)"
[ebuild     U  ] sys-devel/gnuconfig-20140212 [20131128]
[ebuild   R    ] sys-apps/file-5.17  PYTHON_TARGETS="(-python3_2*) (-pypy2_0%) (-python2_6%)"
[ebuild     U  ] sys-libs/cracklib-2.9.1-r1 [2.9.1]
[ebuild     U  ] sys-libs/timezone-data-2014f [2014a] USE="-right_timezone%"
[ebuild     U  ] media-libs/giflib-4.1.6-r3 [4.1.6-r2]
[ebuild     U  ] dev-libs/lzo-2.08 [2.06]
[ebuild     U  ] dev-libs/gobject-introspection-common-1.40.0 [1.38.0]
[ebuild     U  ] sys-devel/libtool-2.4.2-r1 [2.4.2]
[ebuild     U  ] virtual/perl-Module-Build-0.400.300-r1 [0.400.300]
[ebuild     U  ] dev-libs/openssl-1.0.1i [1.0.1g]
[ebuild     U  ] dev-util/pkgconfig-0.28-r1 [0.28]
[ebuild     U  ] virtual/pkgconfig-0-r1 [0]
[ebuild     U  ] sys-libs/glibc-2.19-r1 [2.17]
[ebuild     U  ] sys-libs/readline-6.2_p5-r1 [6.2_p1] USE="-static-libs%"
[ebuild   R    ] net-misc/curl-7.36.0  CURL_SSL="(-cyassl%)"
[ebuild   R    ] dev-libs/libxml2-2.9.1-r4  PYTHON_TARGETS="(-python3_2*) (-python2_6%)"
[ebuild     U  ] dev-libs/libpcre-8.35 [8.33]
[ebuild     U  ] app-shells/bash-4.2_p50 [4.2_p49]
[ebuild     U  ] dev-libs/libxslt-1.1.28-r3 [1.1.28-r1]
[ebuild     U  ] dev-lang/python-2.7.7 [2.7.5-r3]
[ebuild     U  ] dev-python/setuptools-2.2 [0.8-r1] PYTHON_TARGETS="(-python3_2*) (-python3_4)"
[ebuild   R    ] dev-python/pyxattr-0.5.2  PYTHON_TARGETS="(-python3_2*) (-pypy2_0%) (-python2_6%)"
[ebuild     U  ] dev-lang/python-3.3.5-r1 [3.3.3]
[ebuild   R    ] dev-java/java-config-2.2.0  PYTHON_TARGETS="(-python3_2*) (-python2_6%)"
[ebuild     U  ] media-libs/jasper-1.900.1-r6 [1.900.1-r5]
[ebuild     U  ] sys-libs/db-4.8.30-r1 [4.8.30]
[ebuild   R    ] net-misc/rsync-3.0.9-r3  USE="xattr*"
[ebuild     U  ] sys-apps/acl-2.2.52-r1 [2.2.51]
[ebuild     U  ] sys-libs/e2fsprogs-libs-1.42.10 [1.42.7]
[ebuild     U  ] sys-devel/flex-2.5.39-r1 [2.5.37]
[ebuild   R    ] sys-apps/coreutils-8.21  USE="(xattr*)"
[ebuild     U  ] app-admin/perl-cleaner-2.16 [2.7]
[ebuild     U  ] sys-libs/pam-1.1.8-r2 [1.1.6-r2]
[ebuild     U  ] virtual/pam-0-r1 [0]
[ebuild     U  ] sys-apps/util-linux-2.24.1-r3 [2.24.1-r2] PYTHON_TARGETS="(-python3_2*)"
[ebuild     U  ] sys-fs/e2fsprogs-1.42.10 [1.42.7]
[ebuild   R    ] app-arch/libarchive-3.1.2-r1  USE="xattr*"
[ebuild     U  ] dev-util/cmake-2.8.12.2-r1 [2.8.12.2]
[ebuild     U  ] media-gfx/graphite2-1.2.4-r1 [1.2.1]
[ebuild     U  ] media-libs/openjpeg-1.5.2 [1.5.1]
[ebuild     U  ] dev-libs/glib-2.40.0-r1 [2.38.2-r1] USE="mime%* xattr*"
[ebuild     U  ] dev-libs/gobject-introspection-1.40.0-r1 [1.38.0]
[blocks b      ] <dev-libs/gobject-introspection-1.40.0 ("<dev-libs/gobject-introspection-1.40.0" is blocking dev-libs/gobject-introspection-common-1.40.0)
[ebuild   R    ] x11-libs/cairo-1.12.16
[ebuild     U  ] x11-libs/gdk-pixbuf-2.30.8 [2.30.7-r1]
[ebuild     U  ] dev-libs/atk-2.12.0-r1 [2.10.0]
[ebuild     U  ] media-libs/harfbuzz-0.9.28 [0.9.23] USE="introspection* {-test%}"
[ebuild     U  ] x11-libs/pango-1.36.5 [1.36.3]
[ebuild     U  ] x11-libs/gtk+-2.24.24 [2.24.23]
[ebuild     U  ] net-print/cups-1.7.5 [1.7.1-r1] LINGUAS="-pt_BR%"
[ebuild     U  ] dev-java/icedtea-bin-6.1.13.3-r3 [6.1.12.7] USE="(-selinux) -webstart%"

!!! The following installed packages are masked:
- app-editors/xemacs-21.4.22-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Would you like to merge these packages? [Yes/No] yes


vi farò sapere
Back to top
View user's profile Send private message
pigreco
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 223
Location: Italia

PostPosted: Tue Sep 30, 2014 9:01 am    Post subject: Reply with quote

buondì aggiornamento: sono in fase di risoluzione l'update del perl è andato a buon fine
così come un
Code:
emerge @preserved-rebuild

richiesto dall'emerge ed un successivo aggiornamento generale da me eseguito
Code:
emerge -avuDN @world


qualche modulo perl da reinstallare ma tutto andato a buon fine.

saluti e grazie a tutti,
Maurizio
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum