Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Impossibilité de monter la partition /boot (mount /boot)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
NoDataFound
n00b
n00b


Joined: 01 Aug 2011
Posts: 25

PostPosted: Sat Sep 27, 2014 8:18 pm    Post subject: Impossibilité de monter la partition /boot (mount /boot) Reply with quote

Hello,

emerge n'arrive pas à appliquer une mise à jour (grub beta) car la partition /boot n'est pas accessible.

J'ai donc voulu la monter à la main (qu'est-ce que j'aime la francisation du terme "mount" :P), et j'ai l'erreur suivante :

Code:

$> mount /boot/
mount: wrong fs type, bad option, bad superblock on /dev/sda1,  missing codepage or helper program, or other error

In some cases useful info is found in syslog - try dmesg | tail or so.


Par contre, si je fais:

Code:

mount -t auto /dev/sda1 /boot


Pas d'erreurs.

La ligne du fstab:

Code:

25 # /dev/sda1: UUID="be4fc009-bf09-4a74-a6ee-22a8687dfd2e"
26 UUID=be4fc009-bf09-4a74-a6ee-22a8687dfd2e /boot  ext2 noauto,noatime,discard  1 2


Il y a un truc que je loupe et qui justifierai la différence de traitement entre la mount /boot et l'autre ?
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Sat Sep 27, 2014 9:52 pm    Post subject: Reply with quote

T'aurais pas mis a jour ton kernel récemment?

Peux-tu poster
Code:
cat /usr/src/linux/.config | grep CONFIG_EXT
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sun Sep 28, 2014 7:02 am    Post subject: Reply with quote

Si en spécifiant le device ça monte et en passant par l’uuid dans le fstab non, je vois qu’un truc : l’uuid est faux.

Si tu spécifies le device dans le fstab ça devrait marcher. Si tu veux conserver l’uuid, doit falloir le fixer :
Code:
blkid /dev/sda1

_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
NoDataFound
n00b
n00b


Joined: 01 Aug 2011
Posts: 25

PostPosted: Mon Sep 29, 2014 7:47 pm    Post subject: Reply with quote

Dans l'ordre :)

Pour info, le /dev/sda c'est un SSD Intel dont j'ai mis les firmware à jour récemment, vu que ça me faisait un autre problème => https://forums.gentoo.org/viewtopic-t-940500-highlight-.html
Depuis passage au nouveau firmware Intel, j'ai plus le problème de COMRESET.

sebB wrote:
T'aurais pas mis a jour ton kernel récemment?


Je te fournis plutôt le zcat de config.gz:

Code:
$> zcat /proc/config.gz | grep CONFIG_EXT
CONFIG_EXTRA_FIRMWARE=""
# CONFIG_EXTCON is not set
CONFIG_EXT2_FS=y
CONFIG_EXT2_FS_XATTR=y
CONFIG_EXT2_FS_POSIX_ACL=y
CONFIG_EXT2_FS_SECURITY=y
# CONFIG_EXT2_FS_XIP is not set
CONFIG_EXT3_FS=y
CONFIG_EXT3_DEFAULTS_TO_ORDERED=y
CONFIG_EXT3_FS_XATTR=y
CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_EXT3_FS_SECURITY=y
CONFIG_EXT4_FS=y
CONFIG_EXT4_FS_POSIX_ACL=y
CONFIG_EXT4_FS_SECURITY=y
# CONFIG_EXT4_DEBUG is not set


guilc wrote:
Si en spécifiant le device ça monte et en passant par l’uuid dans le fstab non, je vois qu’un truc : l’uuid est faux.

Si tu spécifies le device dans le fstab ça devrait marcher. Si tu veux conserver l’uuid, doit falloir le fixer :
Code:
blkid /dev/sda1


Comme tu peux le voir ci-dessous :

Code:
$> blkid /dev/sda1
/dev/sda1: UUID="be4fc009-bf09-4a74-a6ee-22a8687dfd2e" TYPE="ext2" PARTUUID="00010f59-01"
$> grep  be4fc009-bf09-4a74-a6ee-22a8687dfd2e  /etc/fstab
# /dev/sda1: UUID="be4fc009-bf09-4a74-a6ee-22a8687dfd2e"
UUID=be4fc009-bf09-4a74-a6ee-22a8687dfd2e /boot  ext2   noauto,noatime,discard  1 2
Back to top
View user's profile Send private message
NoDataFound
n00b
n00b


Joined: 01 Aug 2011
Posts: 25

PostPosted: Mon Sep 29, 2014 9:45 pm    Post subject: Reply with quote

Je pense que je vais reprendre ma question: outre ce problème, je vois que mon /boot n'a que 32GiO disponibles. Ce qui fait que passé 2 images de kernel + initramfs, ben y a plus de place.

Et au passage, le mount /boot qui foire fait aussi planter genkernel.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Tue Sep 30, 2014 3:53 pm    Post subject: Reply with quote

NoDataFound wrote:
Je pense que je vais reprendre ma question: outre ce problème, je vois que mon /boot n'a que 32GiO disponibles. Ce qui fait que passé 2 images de kernel + initramfs, ben y a plus de place.

T'es sur de toi là? Car avec 32 Go de libres tu peux en mettre des images du kernel...
Peux tu poster ton fstab, fdisk -l, df-h
Que dis?
Code:
mount -t auto -v /dev/sda1 /boot

Une fois ta partition montée peux tu poster dumpe2fs /dev/sda1

EDIT: T'es sur de pas avoir trifouillé un truc car le probleme n'est pas apparu du jour au lendemain? Tu aurais du avoir ce probleme a chaque maj du kernel.
Back to top
View user's profile Send private message
nutsi
n00b
n00b


Joined: 13 Jul 2012
Posts: 38

PostPosted: Tue Sep 30, 2014 4:44 pm    Post subject: Reply with quote

sebB wrote:
NoDataFound wrote:
Je pense que je vais reprendre ma question: outre ce problème, je vois que mon /boot n'a que 32GiO disponibles. Ce qui fait que passé 2 images de kernel + initramfs, ben y a plus de place.

T'es sur de toi là? Car avec 32 Go de libres tu peux en mettre des images du kernel...


Je pense qu'il voulait dire 32mo
Back to top
View user's profile Send private message
NoDataFound
n00b
n00b


Joined: 01 Aug 2011
Posts: 25

PostPosted: Tue Sep 30, 2014 7:54 pm    Post subject: Reply with quote

32M. J'ai fumé la taille :)

En lisant vos demandes, j'ai - je crois - trouvé le fautif via etckeeper :

Code:
 # /dev/sda1: UUID="be4fc009-bf09-4a74-a6ee-22a8687dfd2e"
-UUID=be4fc009-bf09-4a74-a6ee-22a8687dfd2e /boot         ext2   noauto,noatime  1 2
+UUID=be4fc009-bf09-4a74-a6ee-22a8687dfd2e /boot         ext2   noauto,noatime,discard  1 2


Sans le discard, le mount passe tout seul.
Là, je tente après redémarrage dés fois que ça soit une blague :)

J'avais ajouté ce paramètre car j'ai un SSD, et bien que j'efface pas tous les jours mes kernels (ben sauf là), je voulais quand même qu'il fasse le trim (c'est curieux que l'option soit par partitions et pas global par rapport au device).

Sauf que c'est ext4 seulement, et la partition de boot est ext2 (j'avais suivi à l'époque le Gentoo Handbook).

man mount wrote:
discard/nodiscard
Controls whether ext4 should issue discard/TRIM commands to the underlying block device when blocks are freed. This is useful for SSD
devices and sparse/thinly-provisioned LUNs, but it is off by default until sufficient testing has been done.



Après, pour le reste, j'allume pas tous les jours cette bécane, et je me tape des gentilles mis à jour conflictuelles dans le genre perl 5.18 & 5.20.


:arrow: est-ce judicieux pour grub2 de passer en ext4 ?
:arrow: sinon, ne faut-il pas que je m'inquiète du TRIM sur mon SSD ?
:arrow: est-ce qu'il y a un moyen simple ... et sans pertes si possible ... d'augmenter la taille de la partition quitte à changer le type de partitions ?

Mon lsblk donne ça: j'avais fait en sorte de pas tout perdre si jamais je devais aller vers ce genre ... de cas :p

Code:
NAME    MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda       8:0    0  37.3G  0 disk <-- SSD
├─sda1    8:1    0    32M  0 part  /boot
└─sda2    8:2    0  37.2G  0 part  /
sdb       8:16   0 298.1G  0 disk <-- HDD
├─sdb1    8:17   0    16G  0 part  [SWAP]
├─sdb2    8:18   0     1K  0 part
├─sdb5    8:21   0    32G  0 part  /tmp
├─sdb6    8:22   0    96G  0 part  /home
└─sdb7    8:23   0    64G  0 part  /var
sdc       8:32   0   1.8T  0 disk <-- HDD
└─sdc1    8:33   0   1.8T  0 part
  └─md0   9:0    0   7.3T  0 raid5 /mnt/raid5
sdd       8:48   0   1.8T  0 disk <-- HDD
└─sdd1    8:49   0   1.8T  0 part
  └─md0   9:0    0   7.3T  0 raid5 /mnt/raid5
sde       8:64   0   1.8T  0 disk <-- HDD
└─sde1    8:65   0   1.8T  0 part
  └─md0   9:0    0   7.3T  0 raid5 /mnt/raid5
sdf       8:80   0   1.8T  0 disk <-- HDD
└─sdf1    8:81   0   1.8T  0 part
  └─md0   9:0    0   7.3T  0 raid5 /mnt/raid5
sdg       8:96   0   1.8T  0 disk <-- HDD
└─sdg1    8:97   0   1.8T  0 part
  └─md0   9:0    0   7.3T  0 raid5 /mnt/raid5
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum