Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
conflicting dependencies when emerging xfce4-meta
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dky
n00b
n00b


Joined: 01 May 2009
Posts: 64

PostPosted: Thu Sep 25, 2014 5:56 pm    Post subject: conflicting dependencies when emerging xfce4-meta Reply with quote

Hi guys,
I would emerge xfce4-meta and remove completely kde, but I have these
conflicting dependencies:

Code:

[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1.9-r2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.40.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.37:2 required by (gnome-base/gvfs-1.20.2::gentoo, ebuild scheduled for merge)

  (dev-libs/glib-2.36.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.38:2 required by (sys-auth/consolekit-0.4.6::gentoo, installed)

dev-util/gtk-doc-am:0

  (dev-util/gtk-doc-am-1.19::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-util/gtk-doc-am-1.20::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-util/gtk-doc-am-1.20 required by (dev-libs/glib-2.40.0-r1::gentoo, ebuild scheduled for merge)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-208::gentoo, installed) pulled in by
    >=sys-fs/udev-208[abi_x86_64(-),gudev,introspection,kmod] required by (virtual/udev-208::gentoo, installed)

  (sys-fs/eudev-1.9-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-1.3:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/eudev-1.3:0/0[abi_x86_64(-)]) required by (virtual/libudev-215-r1::gentoo, ebuild scheduled for merge)
    >=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1::gentoo, ebuild scheduled for merge)


I thought to remove udev and install eudev, but I don't want to break my system.
Can anyone suggest me what do I do?

Thanks
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Sep 26, 2014 7:41 am    Post subject: Reply with quote

there were endless topics about udev and eudev here recenty. I think they can not both exists.

do you have both installed currently? if so i may recommend remove eudev. just in case have a livecd ready before you do that.


You may use the search function of the forum first and read portage output. Your issue has nothing to do with xfce. It is an issue about udev / eudev which I would say it is a core package. Because that de depends on it does not make it mainly a xfce issue.
e.g. https://forums.gentoo.org/viewtopic-t-1000520-highlight-eudev.html

Please search the forum for udev / eudev and than report back if the issue is not covered there. thank you
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Fri Sep 26, 2014 8:19 am    Post subject: Reply with quote

Nothing to do with xfce, as said. Search around, there's even a guide to migrate from udev to eudev.

The basic procedure consists of unmerging udev (and virtual/udev), then emerge -1 eudev and then continue from there. But check the guide and do the migration properly just in case.

That is, if you want to migrate to eudev. If not, then just unmerge eudev and go back to udev.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Fri Sep 26, 2014 9:10 am    Post subject: Reply with quote

This looks more like an out of date virtual, than anything else.
Updated virtual/udev would require other virtuals, not those specific useflags on udev ebuild.
It might be mixed with package.use.stable.mask on multilib useflags too.

Finally, obviously, you need to update consolekit too.

First thing to try: 'emerge -1pv virtual/udev consolekit'.
Back to top
View user's profile Send private message
SamuliSuominen
Retired Dev
Retired Dev


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Fri Sep 26, 2014 2:50 pm    Post subject: Reply with quote

The output means dev-libs/glib needs to be upgraded first:

Code:

# emerge -1 ">=dev-libs/glib-2.38-r1"


or even

Code:

# emerge -1 ">=dev-libs/glib-2.40"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum