Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help tracking down glitch in redraw for XFCE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
halpo
n00b
n00b


Joined: 15 Sep 2014
Posts: 1
Location: Salt Lake City

PostPosted: Thu Sep 25, 2014 5:18 pm    Post subject: Help tracking down glitch in redraw for XFCE Reply with quote

I'm using XFCE and recently there turned up a redraw issue. Occasionally, and apparently at random the screen redraws incompletely. Windows disappear as well as the panels. when I mouse over a window and it changes that portion will redraw correctly.

I've not found any solution to this through Google. I have combed through my logs repeatedly without seeing anything that might be related to something triggering this behavior. It does seem to happen more often when running more intense applications such as thunderbird, chrome with video, and a remote desktop through Citrix Receiver. I'm sorry it is repetitive but not reproducible.

I'm at a loss of where to look to fix this. Please help.

I'm running:
Kernel: linux-3.16.2
Nouveau graphics driver
Intel i7 970
nVidia GTX480
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Sep 25, 2014 9:58 pm    Post subject: Reply with quote

make sure you have latest xf86-video-nouveau

which includes
http://cgit.freedesktop.org/nouveau/xf86-video-nouveau/commit/?id=f0fa8313714c2a5b16e784b257b5ff79da3a443b
http://cgit.freedesktop.org/nouveau/xf86-video-nouveau/commit/?id=54dfbb2fed393b65d846e6ed9672acb47e0f19de
http://cgit.freedesktop.org/nouveau/xf86-video-nouveau/commit/?id=4d92001ebe6bec8c5eaab8156421e62a7e4dedc8


this ensures sync of bufferswaps to vblank and a doubled framerate == smoother operation (this was very noticable with kwin & compositing)



are you using compositing with xfwm4 ? if not enable it whether that helps

you could also switch compositors and see whether that changes things (kwin, xfwm4, compiz; fusion-icon is very useful in this regard)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum