Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Awesome WM unable to identify .png file[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 391

PostPosted: Tue Sep 23, 2014 7:32 pm    Post subject: Awesome WM unable to identify .png file[solved] Reply with quote

Hi all,

Last night I finished an emerge -uavDN world on my laptop. I currently use awesome as a WM, but when I run startx, it blanks and then the xorg server quits. To be sure it wans't X, I started
both twm and OpenBox, so that doesn't seem to be the problem. I pipe the awesome stderr output to a file and when I check that, it tells me that it can't recognize the format of /usr/share/awesome/themes/zenburn/zenburnbackground.png (my chosen theme). Unfortunatley, I am sitting at work - my computer with said problem isat home som I am typing from memory. I was hoping that someone might be able to give me some ideas from my description, otherwise when I get home tonight, I can post all the commands I use to start awesome as well as exact error output. I also posted to the awesome wm email list, but when they found I used gentoo, they just said why make things hard - try Debian. I didn't appreciate that :) and then some suggestions on editing the lua rc file, which I will try when I get home later.

Thanks!


Last edited by tenspd137 on Wed Sep 24, 2014 2:03 am; edited 1 time in total
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 391

PostPosted: Wed Sep 24, 2014 12:42 am    Post subject: Reply with quote

Here are my exact commands:

.xinitrc:
Code:

udiskie &
exec dbus-launch --sh-syntax --exit-with-session awesome >> ~/.awesome_stdout 2>> ~/.awesome_stderr


output of .awesome_stderror

    error while running function
    stack traceback:
    [C]: in function 'load_image'
    /usr/share/awesome/lib/gears/surface.lua:39: in function </usr/share/awesome/lib/gears/surface.lua:24>
    (tail call): ?
    (tail call): ?
    /usr/share/awesome/lib/gears/wallpaper.lua:128: in function 'maximized'
    /etc/xdg/awesome/rc.lua:76: in main chunk
    error: /usr/share/awesome/lib/gears/surface.lua:39: Couldn't recognize the image file format for file '/usr/share/awesome/themes/default/background.png'
    E: awesome: main:535: couldn't find any rc file


I am pretty sure the error is not in libpng as I can open the png file above with gimp.

emerge --info
    Portage 2.2.13 (python 3.3.5-final-0, default/linux/amd64/13.0, gcc-4.8.3, glibc-2.19-r1, 3.11.5-gentoo x86_64)
    =================================================================
    System uname: Linux-3.11.5-gentoo-x86_64-Intel-R-_Core-TM-_i5-2450M_CPU_@_2.50GHz-with-gentoo-2.2
    KiB Mem: 8121480 total, 6128464 free
    KiB Swap: 17825788 total, 17825788 free
    Timestamp of tree: Mon, 22 Sep 2014 00:30:01 +0000
    ld GNU ld (Gentoo 2.24 p1.4) 2.24
    distcc 3.1 x86_64-pc-linux-gnu [disabled]
    app-shells/bash: 4.2_p47
    dev-java/java-config: 2.2.0
    dev-lang/python: 2.7.8, 3.2.5-r4, 3.3.5-r1, 3.4.1
    dev-util/cmake: 3.0.2
    dev-util/pkgconfig: 0.28-r2
    sys-apps/baselayout: 2.2
    sys-apps/openrc: 0.13.1
    sys-apps/sandbox: 2.6-r1
    sys-devel/autoconf: 2.69
    sys-devel/automake: 1.10.3, 1.11.6, 1.13.4, 1.14.1
    sys-devel/binutils: 2.24-r3
    sys-devel/gcc: 4.6.4, 4.8.3
    sys-devel/gcc-config: 1.8
    sys-devel/libtool: 2.4.2-r1
    sys-devel/make: 4.0-r1
    sys-kernel/linux-headers: 3.16 (virtual/os-headers)
    sys-libs/glibc: 2.19-r1
    Repositories: gentoo science sunrise lisp interactive-fiction qt proaudio stuff x-portage
    ACCEPT_KEYWORDS="amd64 ~amd64"
    ACCEPT_LICENSE="* -@EULA"
    CBUILD="x86_64-pc-linux-gnu"
    CFLAGS="-march=corei7-avx -O2 -pipe"
    CHOST="x86_64-pc-linux-gnu"
    CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
    CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
    CXXFLAGS="-march=corei7-avx -O2 -pipe"
    DISTDIR="/usr/portage/distfiles"
    FCFLAGS="-O2 -pipe"
    FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch usersandbox usersync"
    FFLAGS="-O2 -pipe"
    GENTOO_MIRRORS="http://distfiles.gentoo.org"
    LANG="en_US.UTF-8"
    LDFLAGS="-Wl,-O1 -Wl,--as-needed"
    MAKEOPTS="-j5"
    PKGDIR="/usr/portage/packages"
    PORTAGE_CONFIGROOT="/"
    PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
    PORTAGE_TMPDIR="/var/tmp"
    PORTDIR="/usr/portage"
    PORTDIR_OVERLAY="/var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/lisp /var/lib/layman/interactive-fiction /var/lib/layman/qt /var/lib/layman/pro-audio /var/lib/layman/stuff /usr/local/portage"
    USE="X \ acl amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm heimdal iconv ipv6 mmx modules multilib ncurses nls nptl openmp pam pcre qt3support readline session sse sse2 ssl tcpd truetype unicode zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NGINX_MODULES_HTTP="stub_status lua rewrite access auth_basic autoindex browser charset empty_gif fastcgi geo gzip proxy referer scgi split_clients ssi upstream_ip_hash userid uwsgi xslt limit_conn limit_req map memcached" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fglrx radeon intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
    USE_PYTHON="2.7 3.2 3.3"
    Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC


awesome is only emerged with the dbus use flag. Thanks!
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2546

PostPosted: Wed Sep 24, 2014 1:41 am    Post subject: Reply with quote

Just a shot in the dark, but have you tried enabling png globally? I'd add it to your make.conf because formats tend to go through a bunch of libs and they are not always handled properly. After you set it, emerge -auND world should rebuild everything you need.

This is just a guess based on a similar problem I had a while ago.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 391

PostPosted: Wed Sep 24, 2014 2:03 am    Post subject: Reply with quote

Funny you should mention that - that was what I just got done doing and logging back in here to post the solution. Thank you for replying! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum