Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Can not startx with KDE and Nvidia card
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Sep 20, 2014 6:47 am    Post subject: [Solved] Can not startx with KDE and Nvidia card Reply with quote

Hello to the forum.

I have a fresh kde gentoo install and I am unable to get my xorg drivers/nvidia to work. I have fallowed the nvidia wiki on setting up the kernel and installing the xorg drivers. Before emerging my world, I made sure that in my VIDEO_CARDS="nvivda" was in my make.conf file make.conf: https://gist.github.com/bbb57dd999dfda96e2db
I have installed KDE and KDM. But when I run
Code:
startx
I get
Quote:
Fatal server error: no screens found...


Here is the /var/log/Xorg.0.log message: https://gist.github.com/ba1a3a1ade75c69b44c5
Another strange thing that I was unable to figure out, was why my system isn't configuring a /etc/X11/xorg.conf.d dir, it isn't there.
Code:
lspci

https://gist.github.com/9052d5dbcf5370f25a7a

Code:
emerge --info

https://gist.github.com/cec426741c1f1e7b7e77

Code:
rc-update show

https://gist.github.com/c84a0d2be6ed96f74fde

Code:
lspci | grep VGA

Quote:
01:00:0 VGA compatible controller: NVIDIA Corporation GK110B [GeForce GTX 780 Ti] (rev a1)


I know I am missing something, but I can't figure it out
Thanks


Last edited by Tefrem34 on Sat Sep 27, 2014 9:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
prozprcek
n00b
n00b


Joined: 18 Sep 2014
Posts: 26

PostPosted: Sat Sep 20, 2014 9:00 am    Post subject: Reply with quote

I found a similar post here: https://forums.gentoo.org/viewtopic-t-911402-start-0.html.
Maybe you can try that. I hope this helps.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Sep 20, 2014 9:49 am    Post subject: Reply with quote

did you follow gentoo wiki about nvidia-drivers? yes / no? http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers
there are also howtos of offical handbook about setting up an x-server.

please tell us what you have tried so far?

you need right kernel + settings + right nvidia-drivers + right xorg-server to get it working

you need the newest stuff for your hardware, it seems very new to me.

which version did you use? i am pretty sure you need to run ~ branch, not stable to get it to run.

did you install the latest nvidia-drivers? did you update your mainboard bios? did you searched the web for your hardware and similar problems? any related x-server issue on any linux distro basically applies to you too regarding a solution.

nvidia homepage has a list of supported devices. i highly recommend you search there your hardware and see what version supports your card!
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Sep 20, 2014 10:14 am    Post subject: Reply with quote

@prozprcek
Thanks for the reply.

To me, it looks like his build tries to use the nouveau drivers. I didn't have any error/notices saying that driver was missing/needed nouveau. I had the VIDEO_CARDS variable in the make.conf when I installed my gentoo system. I didn't see VIDEO_CARDS in his. I knew that I didn't want the nouveau drivers to install.

So do I need to make the xorg.conf.d then? I thought that xorg was supposed to generate that.
Quote:
Configuring files in xorg.conf.d should be seen as a "last resort" option
from the xorg wiki.

I made a .xinitrc file to startx before I attempted to startx, I am going to double check that it is in the home directory.

Thanks again.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Sep 20, 2014 10:49 am    Post subject: Reply with quote

@tw04l124 Thanks for the reply.
Quote:
did you follow gentoo wiki about nvidia-drivers?
yes!
I made sure that my kernel was configured according to the documentation, wiki and handbook. For the kernel I am using the 3.14.14, and the nvidia driver is the 340 I believe (I will have to back to you on that one). I would have preferred to use the beta, because my gpu is newer, but I didn't see the option to install it. This is my first time to have Gentoo as an OS, so I am still trying to figure it out.
What I have tried so far: I re-examined my kernel to ensure I had the proper settings, I re-installed xorg drivers and utils, I went through the xorg configuration wiki many times to insure that dbus was loaded and working in my USE flags, re-instsalled xorg-server, did evn-update, I added nvidia to my /etc/conf.d/modules, and I scowered for more info on xorg/nvidia.
It is late so I will get back with versions.
I haven't looked at branches.
Quote:
did you update your mainboard bios
? When I first built the PC, but I had a different GPU installed.
Quote:
did you searched the web for your hardware and similar problems
yes, and still serching.
Quote:
any related x-server issue on any linux distro basically applies to you too regarding a solution
I had issues with other distros, if that is what you mean. I got Arch to work on it. But a Mageia install ruined that partition.
Quote:
nvidia homepage has a list of supported devices
yes I did. Pheonix, that does reviews on GPUs benchmarking on Linux, reviewed it running Ubuntu.
Back to top
View user's profile Send private message
prozprcek
n00b
n00b


Joined: 18 Sep 2014
Posts: 26

PostPosted: Sat Sep 20, 2014 10:55 am    Post subject: Reply with quote

I found something on the wiki that might help, but I'm not sure.
http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers#Xorg_says_it_can.27t_find_any_screens
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Sep 20, 2014 5:43 pm    Post subject: Reply with quote

I looks like I have 340.32 installed. On the Nvidia sight, the newest release/stable is 343.22, which was released the 18 Sep 2014. How would I get the 343.22 drivers then for Gentoo?
The kernel versions look good, as far as I can tell.

well I found the article that I was looking for, "Mixing Stable with Testing" but I would like to see what versions are available before I make the /etc/portage/package.accept_keywords file. Is there a Gentoo package list for testing?
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Sep 20, 2014 6:17 pm    Post subject: Reply with quote

@prozprcek thanks for the link. :)
I wasn't ignoring your comment, I have been trying to figure out what tw04l124 suggested/pointed out.
Yes I did use those directions, several times. I think that the nvidia version installed is what is giving me grief.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Sep 20, 2014 6:46 pm    Post subject: Reply with quote

well so far I added the testing xorg/nvidia drivers with the /package.accept_keywords. I ran
Code:
emerge -avuND world
and it loaded/installed x11-drivers/nvidia-drivers-343.13-r1. I am going to reboot and see what I get.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Sep 20, 2014 6:53 pm    Post subject: Reply with quote

As per the nvidia wiki it suggests
Quote:
To prevent you having to manually load the module on every bootup, you probably want to have this done automatically each time you boot your system, so edit /etc/conf.d/modules and add nvidia to it.
I just want to make sure I did it correctly.
Code:
nano -w /etc/conf.d/modules

https://gist.github.com/d26915c638184c3fe028
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Sep 20, 2014 6:57 pm    Post subject: Reply with quote

I highly recommend you check nvidia homepage and check which driver you need. There is a device database with driver version there too.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sat Sep 20, 2014 7:57 pm    Post subject: Reply with quote

Yes sir.. I have revisited it several times. I looked at the driver that I had installed, to see if the 340.22 driver supported my card and it has it listed. But my problem is knowing what all to look for. I know that I am missing something, it is probably something stupid too. :) Thanks again.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sun Sep 21, 2014 12:07 am    Post subject: Reply with quote

Well I made a xorg.conf.d/20-nvidia.conf and got startx to run. But I am greeted with a black screen. But I am able to alt+ctl+F1 back into the terminal. I see some errors that are displayed. I would like to know if I can wgetpaste the errors so I can see what is happening. Would
Code:
startx | wgetpaste -s gists
work for this, or there another command that I need to use?
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sun Sep 21, 2014 2:26 am    Post subject: Reply with quote

Here is my dmesg.
https://gist.github.com/anonymous/2bb991604342b0bcd163
I am not sure what to look for. If I could have someone who knows what to look at, that would be most helpful.
Thanks.
Back to top
View user's profile Send private message
prozprcek
n00b
n00b


Joined: 18 Sep 2014
Posts: 26

PostPosted: Sun Sep 21, 2014 8:37 am    Post subject: Reply with quote

I think you need to disable framebuffer.
Code:
[ 1.937576] vesafb: scrolling: redraw
[ 1.937579] vesafb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[ 1.937595] vesafb: framebuffer at 0xf9000000, mapped to 0xffffc90010100000, using 16000k, total 16000k

this is from your dmesg.

And as you can see on gentoo wiki:
Quote:
For x86 and AMD64 processors, the in-kernel framebuffer driver conflicts with the binary driver provided by nVidia. If you will be compiling your kernel for these CPUs,you must completely remove support for the in-kernel driver

you will need to disable this under Device drivers -> Graphics support -> Support for frame buffer devices
Code:
< >   nVidia Framebuffer Support
 < >   nVidia Riva support

As described here:
http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers#Required_kernel_options
Or you can switch to uvesafb if you need high res on the console. As described in uvesafb article you will need to enable:
Code:
 [*]   Enable firmware EDID
<*>   Userspace VESA VGA graphics support

in Device drivers -> Graphics support -> Support for frame buffer devices, and install sys-apps/v86d as described here:
http://wiki.gentoo.org/wiki/Uvesafb
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sun Sep 21, 2014 8:39 pm    Post subject: Reply with quote

@prozprcek, Thanks for the help. :)
Quote:
I think you need to disable framebuffer.

That is weird. When I checked the genkernel before installing gentoo, and even afterwards, I used the Nvidia wiki guide to make sure that I selected/unselected the appropriate settings. I know that I made sure that framebuffer support wasn't selected.

As per the the last two options I am going into the kernel and make sure that I have those checked. The Uvesafb sounds new to me, so I am unsure about that one as well. I just do not remember.

Again, thank you for the pointers. :)
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sun Sep 21, 2014 9:09 pm    Post subject: Reply with quote

I just chrooted into my gentoo from the live cd, and here is a screen shot of the framebuffer selections. Which I
Code:
cd /usr/src/linux
then ran
Code:
genkernel --menuconfig all

Here is what it looks like.
http://tefrem34.deviantart.com/art/Show-no-screenbuffer-483805140
I couldn't figure out how to post an image, so I used my deviant account to post it.
I am now fallowing the uvesafb instructions, to see if that will help.
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Sun Sep 21, 2014 10:03 pm    Post subject: Reply with quote

Well I noticed something else that is strange, I tried to update my grub configuration after going through my kernel by
Code:
grub2-mkconfig -o /boot/grub/grub.cfg
and I get an error
Quote:
No such file or directory

When I checked the directory, and in my /boot dir there is only config-3.14.14-gentoo System.map-3.14.14-gentoo vmliuz-3.14.14-gentoo.
I got to figure out how I can update my grub configuration.
But my system boots up fine. So something is wonky.

There is a grub configuration file in /etc/default/grub but nothing for /etc/grub.d

I ran
Code:
grub2-install --recheck /dev/sda3
(sda3 is the partition that I assigned for the bootloader) then
Quote:
Installing for i386-pc platform.
grub2-install: warning: files system 'ext2' doesn't support embedding.
grub2-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklisting. However, blocklists are UNRELIABLE and their use is discouraged..
grub2-install: warning: error: will not proceed with blocklists.

For one thing, I made /dev/sda3 ext3. I also wonder why would grub say i386-pc when my system is x86_64?
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Mon Sep 22, 2014 4:12 am    Post subject: Reply with quote

I gave up and I have done a fresh install.
So right now I am making sure that the versions that are to install are compliant with Nvidia's requirements for the driver 343.22 before I do my world update and install everything. However, there is one dependency that I have no idea that it is supported by the listed versions in the
Code:
/usr/portage/sys-libs/glibc
As the documentation states: http://us.download.nvidia.com/XFree86/Linux-x86_64/343.22/README/minimumrequirements.html glibc needs 2.0. How can I find out which version I am supposed to use? Because, as I can see, there is no 2.0 available in portage.
Thank you very much.

By the way... did I post this topic in the wrong category?
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Mon Sep 22, 2014 6:12 am    Post subject: Reply with quote

Tefrem34 wrote:
Here is my dmesg.
https://gist.github.com/anonymous/2bb991604342b0bcd163
I am not sure what to look for. If I could have someone who knows what to look at, that would be most helpful.
Thanks.


I think at this point you had a working X session, maybe you needed to configure your session or window manager properly. Can you see a mouse cursor that's shaped as an 'X'?

In any case, from your first post X log file, you could see that the nvidia driver wasn't even being probed, and that was because the closed source drivers do need an xorg.conf file, as you already discovered. X won't autodetect those.

In any case, and just to discard stuff, if you have both nvidia and nouveau installed you should always blacklist one of them and use the other. Just to avoid problems. Also, double check that eselect opengl list and xorg.conf matches whatever driver you are using at the moment.

You shouldn't need to disable framebuffer, as long as you are using a generic driver (i.e. not nvidiafb nor rivafb).
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Mon Sep 22, 2014 3:28 pm    Post subject: Reply with quote

@i92guboj Thanks the reply.
All I had was a blank screen, like when the monitor goes to sleep. There was no cursor of any kind.

I didn't allow any nouveau drivers in the kernel or in applications, because of the conflicts, especially the ones I had in other distros that don't give any choice whether to load them or not. So do I still need to a blacklist?

I am going to check the eselect opengl list and xorg.conf and make sure they match the 343.22 driver.
Thanks for the help, it was good to know that I was close to getting it.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Mon Sep 22, 2014 8:18 pm    Post subject: Reply with quote

Tefrem34 wrote:
@i92guboj Thanks the reply.
All I had was a blank screen, like when the monitor goes to sleep. There was no cursor of any kind.


Sorry if this has been answered before, but sere you able to change vt with ctrl-alt-f1?

Quote:

I didn't allow any nouveau drivers in the kernel or in applications, because of the conflicts, especially the ones I had in other distros that don't give any choice whether to load them or not. So do I still need to a blacklist?


If you are sure that nouveau is not installed then you don't need a blacklist.

Quote:
I am going to check the eselect opengl list and xorg.conf and make sure they match the 343.22 driver.
Thanks for the help, it was good to know that I was close to getting it.


Hard to say. If your machine was truly locked up there might be some kind of deeper issue. But, if your chip is listed as supported it should work.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Tue Sep 23, 2014 12:09 am    Post subject: Reply with quote

@i92guboj
Quote:
but sere you able to change vt with ctrl-alt-f1?
the whole screen changed its lighting and then loaded the fullscreen tty. After tty loaded, I got a prompt to login and I could use comands, but no GUI. (If that is what you are asking)

When I was reading from the different forums and wikis on the subject, what I found in one situation was that the screen resolution was being set to 0, producing a black screen, and had to be manually configured to the proper size with the config file. I still have some more to read about it, to see if this is what is happening with my gpu/drivers. I am still reading the nvidia manual to see if I can get a clue what might be causing the black screen after starting x.

Thanks again. :)
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Tue Sep 23, 2014 6:21 am    Post subject: Reply with quote

Tefrem34 wrote:
@i92guboj
Quote:
but sere you able to change vt with ctrl-alt-f1?
the whole screen changed its lighting and then loaded the fullscreen tty. After tty loaded, I got a prompt to login and I could use comands, but no GUI. (If that is what you are asking)


As you very well said, you might need to force the resolution in xorg.conf. Maybe it's one of those rare cases where the driver can't read the EDID information from your monitor properly.

Looking at the X log at this stage could be enlightening. Note that the log you posted in the first post only shows that the nvidia driver wasn't being loaded. And that was because you had not an xorg.conf by that time. You didn't post the X log before that (at least I can't find it right now). So that's a thing you should be checking when you reach at that stage again.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Tefrem34
Apprentice
Apprentice


Joined: 14 Sep 2014
Posts: 257
Location: USA, California

PostPosted: Tue Sep 23, 2014 11:21 pm    Post subject: Reply with quote

I have been trying to get my settings back to at least a blank screen, all I have gotten, so far, was the error after
Code:
$startx
:
Quote:
/var/log/Xorg.0.log
file out put.
https://gist.github.com/anonymous/f75cf2b48076ee5e2c24

Here is the: dmesg
https://gist.github.com/anonymous/29a3b58d2bfcdb6dc824

I found an empty
Quote:
/usr/share/X11/xorg.conf.d
, at least I have that this time.
Next I will manually make a conf file for the screen.
I also made a
Quote:
~/.xintirc


Are there any suggestions of something that I am missing? A tool that helps auto config or somthing?
I read on the Nvidia or xorg, not sure now, was install mesa. But doesn't mesa conflict with the nvidia drivers?

Thanks again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum