Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.4_rc2-love1 aka "Spread 'Em"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
d-fens
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2004
Posts: 87

PostPosted: Sun Mar 14, 2004 2:10 pm    Post subject: Reply with quote

sorry it wasn't udma , just dma under Device Drivers | ATA/ATAPI/MFM/RLL support
[*] Generic PCI bus-master DMA support
[*] Use PCI DMA by default when available

alsa: make sure you compiled the drivers as modules
pppoed: you should provide more specific information like what dmesg says about it or the output of lsmod
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Mar 14, 2004 9:03 pm    Post subject: Reply with quote

Rumil wrote:
evermind wrote:

After removing this line it works for me
Code:

/usr/src/linux-2.6.4_rc2-love1/fs/proc/generic.c
@@ -661,7 +661,6 @@
                          proc_alloc_map);
                proc_kill_inodes(de);
                de->nlink = 0;
-               BUG_ON(de->subdir);
                if (!atomic_read(&de->count))
                        free_proc_entry(de);
                else {


Yeah, works for me as well. Thanks!


hmm I have the same problem:
Code:
------------[ cut here ]------------
kernel BUG at fs/proc/generic.c:664!
invalid operand: 0000 [#1]
CPU:    0
EIP:    0060:[<c01827c9>]    Tainted: PF  VLI
EFLAGS: 00010282
EIP is at remove_proc_entry+0xe9/0x160
eax: dda3ce80   ebx: de4be830   ecx: 00000000   edx: de527c80
esi: 00000005   edi: ddb6a500   ebp: 00000000   esp: de831e54
ds: 007b   es: 007b   ss: 0068
Process rmmod (pid: 6338, threadinfo=de830000 task=df3353c0)
Stack: ddb6a500 ddb6a548 ddb6a500 dda3cf80 ddb6a548 e1a812f0 df393c98 00000880
       e1a772d7 ddb6a548 de4be800 dec39d60 dda3cfc8 dec39c14 dec39c14 dec39c14
       e1a76c35 df393c98 de4be800 00000880 00000000 dec39c14 00000000 e1a74ca7
Call Trace:
 [<e1a772d7>] snd_info_unregister+0x87/0xd0 [snd]
 [<e1a76c35>] snd_info_card_free+0x35/0xa0 [snd]
 [<e1a74ca7>] snd_card_free+0xd7/0x250 [snd]
 [<c016745e>] destroy_inode+0x4e/0x50
 [<c0168566>] iput_final+0x26/0x30
 [<e1db02a9>] snd_via82xx_remove+0x19/0x30 [snd_via82xx]
 [<c02b5adb>] pci_device_remove+0x3b/0x40
 [<c0304354>] device_release_driver+0x64/0x70
 [<c0304380>] driver_detach+0x20/0x30
 [<c03045ad>] bus_remove_driver+0x3d/0x80
 [<c03049c3>] driver_unregister+0x13/0x28
 [<c02b5cb6>] pci_unregister_driver+0x16/0x30
 [<e1db02cf>] alsa_card_via82xx_exit+0xf/0x13 [snd_via82xx]
 [<c01314dc>] sys_delete_module+0x13c/0x190
 [<c0145bab>] do_munmap+0x11b/0x150
 [<c04411bb>] syscall_call+0x7/0xb

Code: 01 00 00 00 89 44 24 0c 8b 47 04 89 44 24 08 8b 44 24 28 8b 40 04 c7 04 24 30 42 47 c0 89 44 24 04 e8 3c be f9 ff e9 77 ff ff ff <0f> 0b 98 02 90 c7 46 c0 eb b4 8b 44 24 28 66 ff 48 0a eb 86 8d
 <3>ALSA sound/core/pcm_lib.c:198: Unexpected hw_pointer value [1] (stream = 0, delta: -5669, max jitter = 8192): wrong interrupt acknowledge?
ALSA sound/core/pcm_lib.c:198: Unexpected hw_pointer value [1] (stream = 0, delta: -4095, max jitter = 8192): wrong interrupt acknowledge?
ALSA sound/core/pcm_lib.c:198: Unexpected hw_pointer value [1] (stream = 0, delta: -2047, max jitter = 8192): wrong interrupt acknowledge?


But if I remove the line
Code:
proc_alloc_map);


I got this compile error
Code:

fs/proc/generic.c: In function `remove_proc_entry':
fs/proc/generic.c:662: error: syntax error before ';' token
make[2]: *** [fs/proc/generic.o] Error 1
make[1]: *** [fs/proc] Error 2
make: *** [fs] Error 2



Whats wrong?
Back to top
View user's profile Send private message
bssteph
l33t
l33t


Joined: 26 Feb 2003
Posts: 651
Location: Wisconsin

PostPosted: Mon Mar 15, 2004 12:21 am    Post subject: Reply with quote

You removed the wrong line. You should remove the line with the - in front of it, that is,
Code:
BUG_ON(de->subdir);

_________________
Website - All sorts of nonsense (some of it actually Linux related)
Back to top
View user's profile Send private message
seppe
Guru
Guru


Joined: 01 Sep 2003
Posts: 431
Location: Hove, Antwerp, Belgium

PostPosted: Mon Mar 15, 2004 9:47 am    Post subject: Reply with quote

Matje wrote:

On a side note: I've disabled preemtible kernel now and it really makes a difference on my system. Before it seemed rather sluggish when there was heavy hard-drive activity, sometimes even disallowing me too take any action, now my box seems to respond faster when wanting to do multi-tasking. I've read some other reports about slowness, so I thought I'd just mention it :)


What?! So I should disable preëmptible kernel? People always told me this was the major advantage of the 2.6 kernel tree; it should speed things up. So should I disable this, or not?

Besides, what other things should I enable in my kernel to get more speed with love-sources?
_________________
nitro-sources, because between stable and experimental there exists only speed

Latest release I made: 2.6.13.2-nitro1
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Mar 15, 2004 10:58 am    Post subject: Reply with quote

bssteph wrote:
You removed the wrong line. You should remove the line with the - in front of it, that is,
Code:
BUG_ON(de->subdir);



ahh ok, thx :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5
Page 5 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum