Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Minor annoyance with vixie-cron and vcron...
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
swingarm
l33t
l33t


Joined: 08 Jun 2002
Posts: 627
Location: Northern Colorado

PostPosted: Tue Jan 06, 2004 2:26 am    Post subject: Minor annoyance with vixie-cron and vcron... Reply with quote

Through a routine I would rather not get into I now have this on boot up:
Code:

* Caching service dependencies...
* Service 'vcron' already provide 'cron'!;
* Not adding service 'vixie-cron'...

I have vcron installed not vixie-cron(yes, I realize that they are both the same thing now). My problem is that no matter how many times I use the rc-update command I can't get rid of the above message, is there another way to fix this?
Back to top
View user's profile Send private message
chocoba65
n00b
n00b


Joined: 08 Apr 2003
Posts: 33

PostPosted: Tue Jan 06, 2004 3:18 am    Post subject: Reply with quote

I forget exactly what I had to do to get mine to work, but try this (may not be in correct order):
Code:
emerge unmerge vcron
emerge vixie-cron
rm /etc/init.d/vcron
depscan.sh
rc-update del vcron
rc-update del vixie-cron
rc-update add vixie-cron default
Back to top
View user's profile Send private message
swingarm
l33t
l33t


Joined: 08 Jun 2002
Posts: 627
Location: Northern Colorado

PostPosted: Tue Jan 06, 2004 4:24 am    Post subject: Reply with quote

Thanks, that did it...
Back to top
View user's profile Send private message
KShots
Guru
Guru


Joined: 09 Oct 2003
Posts: 489
Location: Florida

PostPosted: Tue Jan 06, 2004 2:59 pm    Post subject: Reply with quote

Same problem - thanks for solution (worked) :)
_________________
Life without passion is death in disguise
Back to top
View user's profile Send private message
soth
Apprentice
Apprentice


Joined: 12 Sep 2003
Posts: 207

PostPosted: Thu Jan 08, 2004 1:09 am    Post subject: Reply with quote

same here *lovebomb*
Back to top
View user's profile Send private message
xswe
n00b
n00b


Joined: 10 Oct 2003
Posts: 10

PostPosted: Fri Jan 09, 2004 2:11 pm    Post subject: Same problem, works now Reply with quote

Thanks for the soulution! ;)
Back to top
View user's profile Send private message
lukej
n00b
n00b


Joined: 11 Jan 2004
Posts: 2

PostPosted: Sun Jan 11, 2004 2:44 pm    Post subject: Reply with quote

This was the first post I checked for a solution and it worked great.
Thanks.
Back to top
View user's profile Send private message
masseya
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 2602
Location: Baltimore, MD

PostPosted: Thu Jan 22, 2004 5:47 pm    Post subject: Reply with quote

Amazingly, tomk has found a plethora of people who were all asking about the vixie-cron / vcron thing. This is the official solution thread to that issue. If you have more problems with this, please post here. Also, I have made this post sticky in a desperate attempt to prevent more dups.

tomk wrote:
Noticed a few of these *cron posts recently. These are the dupes I've found:

https://forums.gentoo.org/viewtopic.php?t=114461
https://forums.gentoo.org/viewtopic.php?t=124942
https://forums.gentoo.org/viewtopic.php?t=124214
https://forums.gentoo.org/viewtopic.php?t=120640
https://forums.gentoo.org/viewtopic.php?t=119611
https://forums.gentoo.org/viewtopic.php?t=119166
https://forums.gentoo.org/viewtopic.php?t=115113
https://forums.gentoo.org/viewtopic.php?t=105625
https://forums.gentoo.org/viewtopic.php?t=104659
https://forums.gentoo.org/viewtopic.php?t=69621

This seems to be the definative answer:

https://forums.gentoo.org/viewtopic.php?t=121455

Edit: one more i missed

https://forums.gentoo.org/viewtopic.php?t=126998

_________________
if i never try anything, i never learn anything..
if i never take a risk, i stay where i am..
Back to top
View user's profile Send private message
petrjanda
Veteran
Veteran


Joined: 05 Sep 2003
Posts: 1557
Location: Brno, Czech Republic

PostPosted: Fri Jan 23, 2004 12:27 am    Post subject: Reply with quote

chocoba65 wrote:
I forget exactly what I had to do to get mine to work, but try this (may not be in correct order):
Code:
emerge unmerge vcron
emerge vixie-cron
rm /etc/init.d/vcron
depscan.sh
rc-update del vcron
rc-update del vixie-cron
rc-update add vixie-cron default

i dont think you even have to do that much, ive had the same problem but with kernel logger and solved it t his way:

Code:

/etc/init.d/sysklogd stop
rm /etc/init.d/sysklogd
rc-update del sysklogd default
emerge syslog-ng
rc-update add syslog-ng default


thats it
Back to top
View user's profile Send private message
charlieg
Advocate
Advocate


Joined: 30 Jul 2002
Posts: 2149
Location: Manchester UK

PostPosted: Fri Jan 23, 2004 2:18 am    Post subject: Reply with quote

chocoba65 wrote:
I forget exactly what I had to do to get mine to work, but try this (may not be in correct order):
Code:
emerge unmerge vcron
emerge vixie-cron
rm /etc/init.d/vcron
depscan.sh
rc-update del vcron
rc-update del vixie-cron
rc-update add vixie-cron default


IIRC, I did it a bit quicker:
Code:
# emerge unmerge vcron
# rc-update del vcron
(optional) # rm /etc/init.d/vcron
# emerge vixie-cron
# rc-update add vixie-cron default

_________________
Want Free games?
Free Gamer - open source games list & commentary

Open source web-enabled rich UI platform: Vexi
Back to top
View user's profile Send private message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Denmark

PostPosted: Fri Jan 23, 2004 9:03 am    Post subject: Reply with quote

cool, thx this did fix alot of problems for me :)
Back to top
View user's profile Send private message
rickj
Guru
Guru


Joined: 06 Feb 2003
Posts: 358
Location: Calgary, Alberta, Canada

PostPosted: Mon Jan 26, 2004 5:02 pm    Post subject: Reply with quote

If we must rename this thing, we need to do it everywhere. The entry for vcron in the online package database still says:

Quote:
vcron

Description: The Vixie cron daemon
Back to top
View user's profile Send private message
cybermans
Apprentice
Apprentice


Joined: 04 Apr 2003
Posts: 193

PostPosted: Fri Jan 30, 2004 8:58 am    Post subject: Reply with quote

I cant unmerge vcron because emerge unmerge vcron tells me that it cant find a match for vcron.
Back to top
View user's profile Send private message
masseya
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 2602
Location: Baltimore, MD

PostPosted: Fri Jan 30, 2004 6:07 pm    Post subject: Reply with quote

rickj wrote:
If we must rename this thing, we need to do it everywhere. The entry for vcron in the online package database still says:

Quote:
vcron

Description: The Vixie cron daemon
Have you posted a bug report?

cybermans wrote:
I cant unmerge vcron because emerge unmerge vcron tells me that it cant find a match for vcron.
What is the exact error message? Also, what does emerge -s vcron show?
_________________
if i never try anything, i never learn anything..
if i never take a risk, i stay where i am..
Back to top
View user's profile Send private message
cybermans
Apprentice
Apprentice


Joined: 04 Apr 2003
Posts: 193

PostPosted: Fri Jan 30, 2004 6:22 pm    Post subject: Reply with quote

meanmachine dev # emerge -s vcron
Searching...
[ Results for search key : vcron ]
[ Applications found : 0 ]
Back to top
View user's profile Send private message
masseya
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 2602
Location: Baltimore, MD

PostPosted: Fri Jan 30, 2004 10:18 pm    Post subject: Reply with quote

You can skip the step where you unmerge vcron as it is not installed on your system.
_________________
if i never try anything, i never learn anything..
if i never take a risk, i stay where i am..
Back to top
View user's profile Send private message
lmeadors
n00b
n00b


Joined: 24 Nov 2002
Posts: 24

PostPosted: Sat Jan 31, 2004 1:09 am    Post subject: Reply with quote

I can't unmerge it either. Is there a way to manually remove it?

Code:
larnyx vixie-cron # emerge -C vcron
 
!!! Couldn't find match for vcron
 
>>> unmerge: No packages selected for removal.
 
larnyx vixie-cron # depscan.sh
 * Caching service dependencies...
 *  Service 'vcron' already provide 'cron'!;
 *  Not adding service 'vixie-cron'...
Back to top
View user's profile Send private message
rickj
Guru
Guru


Joined: 06 Feb 2003
Posts: 358
Location: Calgary, Alberta, Canada

PostPosted: Sat Jan 31, 2004 6:15 pm    Post subject: Reply with quote

[quote="masseya"]
rickj wrote:
If we must rename this thing, we need to do it everywhere. The entry for vcron in the online package database still says:

Quote:
vcron

Description: The Vixie cron daemon
Have you posted a bug report?


Ouch! I intended to, but got distracted. It's now bug #39992 :oops:
Back to top
View user's profile Send private message
masseya
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 2602
Location: Baltimore, MD

PostPosted: Mon Feb 02, 2004 9:03 pm    Post subject: Reply with quote

lmeadors wrote:
I can't unmerge it either. Is there a way to manually remove it?
Try re-emerging it and then removing it.
_________________
if i never try anything, i never learn anything..
if i never take a risk, i stay where i am..
Back to top
View user's profile Send private message
zeek
Guru
Guru


Joined: 16 Nov 2002
Posts: 479
Location: Bantayan Island

PostPosted: Sat Feb 14, 2004 2:50 am    Post subject: Reply with quote

I think "Major Annoyance ..." or even better "Pointless Annoyance ..." would be a better title for this thread.

I wonder how many human hours were spent worldwide trying to figure out the vcron -> vixie-cron renaming?

I hope the Gentoo devs learned a lesson from this useless re-factoring of package names. Somehow, I doubt it tho.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3104
Location: Gainesville, Florida

PostPosted: Thu Feb 19, 2004 1:43 am    Post subject: Reply with quote

I'm sorry I can't seem to get this, but I've carefully done everything suggested here several times to make sure, and when one failed, I did the other, exactly as shown, again and again from scratch, and after every subsequent emerge I still get:

* Caching service dependencies...
* Service 'vcron' already provide 'cron'!;
* Not adding service 'vixie-cron'... [ ok ]
* Caching service dependencies...
* Service 'vcron' already provide 'cron'!;
* Not adding service 'vixie-cron'... [ ok ]
>>> Auto-cleaning packages ...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.

What am I missing here? I've even rebooted between various attempts, to make sure the ram cache is flushed, but none of the above solutions ever work. I hate to beat for what for some must be a dead horse, but apparently I'm just not getting it.

wrc1944
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.26-r3, gcc-7.2.0- kernel-4.14.5 gentoo USE=experimental
Back to top
View user's profile Send private message
zeek
Guru
Guru


Joined: 16 Nov 2002
Posts: 479
Location: Bantayan Island

PostPosted: Fri Feb 20, 2004 11:44 pm    Post subject: Reply with quote

wrc1944 wrote:
...after every subsequent emerge I still get:

* Caching service dependencies...
* Service 'vcron' already provide 'cron'!;

Perhaps
Code:
rm /etc/init.d/vcron

will do the trick?
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Fri Mar 05, 2004 12:09 pm    Post subject: Reply with quote

Code:
rm /etc/init.d/vcron

That's what I've did and it worked.


_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
oh207
n00b
n00b


Joined: 13 Mar 2003
Posts: 4
Location: NYC

PostPosted: Fri Mar 12, 2004 3:25 am    Post subject: Thanks for the solution Reply with quote

Thanks for the solution. This had me going for a while. Until i decided to do a seach in the forums.
Back to top
View user's profile Send private message
seemant
Retired Dev
Retired Dev


Joined: 16 Nov 2002
Posts: 61
Location: Oakland, CA

PostPosted: Fri Mar 26, 2004 9:11 pm    Post subject: Annoying Reply with quote

Hi All,

I was the one responsible for moving the package name. In the end the move's implementation obviously left much to be desired. Please accept my apology for this. Lesson learned. If I have to subject users to a move like this again, I'll be sure to make a cleaner path for you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum