Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
FINISHED: python3_11 entgültig loswerden
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2611
Location: Heidelberg - Germany

PostPosted: Sun Jun 30, 2024 3:28 pm    Post subject: FINISHED: python3_11 entgültig loswerden Reply with quote

Mein package.use/python sieht jetzt folgendermaßen aus:

Code:

dev-lang/python tk

*/* PYTHON_TARGETS: -* python3_12
*/* PYTHON_SINGLE_TARGET: -* python3_12


Meines Erachtens sollte es keine Anhängigkeiten mehr zu python2_11 geben. Dennoch löscht --depclean nichts dergleichen.

Ich habe es zusätzlich noch mir diesem Befehl versucht:

Code:

comm -23 <(equery -q hasuse python_targets_python3_11 | sort) <(equery -q hasuse python_targets_python3_12 | sort)


Es ergibt sich keine Ausgabe. Mein Verdacht, dass das was in der world Datei steht, hat sich nicht bestätigt.

Code:

kellerkind ~ # cat /var/lib/portage/world | grep python
app-eselect/eselect-python
dev-python/PyQt5
dev-python/pip
dev-python/pyserial


Was kann man noch tun um herauszufinden, warum python3_11 nicht von depclean gelöscht wird?
_________________
Desktop AMD Ryzen 9 5900X 32GB RAM, Asus GF GTX 1060.
Notebook Tuxedo Pulse 15 Gen1 AMD Ryzen 7 4800H mit Radeon Vega 7
Raspberry Pi 1 + 2 + 3B+ + Zero W


Last edited by Erdie on Sun Jul 14, 2024 4:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
firefly
Watchman
Watchman


Joined: 31 Oct 2002
Posts: 5257

PostPosted: Sun Jun 30, 2024 5:12 pm    Post subject: Reply with quote

Du hast vergessen das es auch python single target gibt. Bzw. Das manche pakte explizit python 3.11 in den deps haben ohne die PYTHON_TARGET/PYTHON_SINGLE_TARGET features zu nutzen.
Und bei der Umstellung auf python 3.12 hast du bestimmt doch ein paar pakete mit PYTHON_SINGLE_TARGET=python3_11 in package.use eintragen müssen.

Ansonsten sollte folgender befehl dir alle pakete liefern, welche python 3.11 brauchen:
Code:
emerge -cpv python:3.11

_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2611
Location: Heidelberg - Germany

PostPosted: Sun Jun 30, 2024 7:13 pm    Post subject: Reply with quote

Code:

emerge -cpv python:3.11

Calculating dependencies... done!
  dev-lang/python-3.11.9-r1 pulled in by:
    net-libs/nodejs-20.12.1 requires dev-lang/python:3.11[threads(+)]
    www-client/firefox-115.12.0 requires dev-lang/python:3.11[ncurses,sqlite,ssl]


Es ist nicht mehr viel übrig.
_________________
Desktop AMD Ryzen 9 5900X 32GB RAM, Asus GF GTX 1060.
Notebook Tuxedo Pulse 15 Gen1 AMD Ryzen 7 4800H mit Radeon Vega 7
Raspberry Pi 1 + 2 + 3B+ + Zero W
Back to top
View user's profile Send private message
pietinger
Moderator
Moderator


Joined: 17 Oct 2006
Posts: 4579
Location: Bavaria

PostPosted: Thu Jul 04, 2024 2:24 pm    Post subject: Reply with quote

Erdie wrote:
Es ist nicht mehr viel übrig.

Mit dem heutigen "emerge --sync" haben wir nun nodejs-22.3.0 als stable ... und konnte danach das alte python entsorgen:
Code:
# emerge -c

 * Always study the list of packages to be cleaned for any obvious
...

Calculating dependencies... done!
>>> Calculating removal order...

 dev-lang/python
    selected: 3.11.9-r1
   protected: none
     omitted: 3.12.3-r1

 dev-python/ensurepip-wheels
    selected: 100
   protected: none
     omitted: none

 dev-python/ensurepip-setuptools
    selected: 70.0.0
   protected: none
     omitted: none

_________________
https://wiki.gentoo.org/wiki/User:Pietinger
Back to top
View user's profile Send private message
kurisu
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 174
Location: Munich, Germany

PostPosted: Sun Jul 07, 2024 5:48 pm    Post subject: Reply with quote

Völlig korrekt, aber für diejenigen mit Firefox ESR dürfte es wohl noch eine Weile dauern.

Code:
~ $ emerge -cpv python:3.11

Calculating dependencies... done!
  dev-lang/python-3.11.9-r1 pulled in by:
    www-client/firefox-115.12.0 requires dev-lang/python:3.11[ncurses,sqlite,ssl]

>>> No packages selected for removal by depclean
Packages installed:   1378
Packages in world:    144
Packages in system:   49
Required packages:    1378
Number to remove:     0

_________________
#1 Ryzen 7 2700 | Asus ROG Strix X470-F Gaming | G.Skill 32 GB DDR4-3000 | PowerColor Radeon RX 5700 Red Dragon | Samsung SSD 970 EVO Plus 1TB NVMe
#2 Ryzen 5 2400G | ASRock B450 Steel Legend | G.Skill 16 GB DDR4-3000 | Samsung SSD 850 PRO 512GB SATA
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2611
Location: Heidelberg - Germany

PostPosted: Mon Jul 08, 2024 4:18 pm    Post subject: Reply with quote

kurisu wrote:
Völlig korrekt, aber für diejenigen mit Firefox ESR dürfte es wohl noch eine Weile dauern.


Auf meinem Notebook bin ich schon sauber, der Desktop hat den Firefox und das wird, wie Du schon sagst, noch dauern.

Ich habe mal versucht, auf firefox-bin zu wechseln. Leider nutzt das ebuild andere Konfigurationpfade, so dass alles verschwindet: Bookmarks, Passwörter, Konfiguration usw. Da habe ich mir das geschenkt und bin auf die source Version zurückgegangen. So eilig habe ich es dann auch nicht.
_________________
Desktop AMD Ryzen 9 5900X 32GB RAM, Asus GF GTX 1060.
Notebook Tuxedo Pulse 15 Gen1 AMD Ryzen 7 4800H mit Radeon Vega 7
Raspberry Pi 1 + 2 + 3B+ + Zero W
Back to top
View user's profile Send private message
firefly
Watchman
Watchman


Joined: 31 Oct 2002
Posts: 5257

PostPosted: Tue Jul 09, 2024 4:02 am    Post subject: Reply with quote

Falls man 3.11 wegen "kein offizieller Support upstream mehr" entfernen möchte, dann ist das aktuell eine Fehleinschätzung.
Das python Projekt unterstützt die version 3.11 noch bis 2027-10 erst dann ist diese version EOL

Quelle:
https://devguide.python.org/versions/
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2611
Location: Heidelberg - Germany

PostPosted: Wed Jul 10, 2024 9:35 am    Post subject: Reply with quote

Das ist nicht meine Motivation. Aber wenn man mit geringem Aufwand eine Python Version weniger auf dem Rechner hat, ist es wenigstens aufgeräumt. Priorität hat das Ganze allerdings nicht.
_________________
Desktop AMD Ryzen 9 5900X 32GB RAM, Asus GF GTX 1060.
Notebook Tuxedo Pulse 15 Gen1 AMD Ryzen 7 4800H mit Radeon Vega 7
Raspberry Pi 1 + 2 + 3B+ + Zero W
Back to top
View user's profile Send private message
b3rT
n00b
n00b


Joined: 09 Jun 2003
Posts: 72
Location: Germany

PostPosted: Wed Jul 10, 2024 12:45 pm    Post subject: Reply with quote

Wenn Du von Firefox esr auf rapid wechselst, bist du python 3.11 los. rapid ist auch im regulären gentoo-repo - nur halt ~amd64, auch wenn rapid aus Sicht von Firefox deren Standardversion ist.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2611
Location: Heidelberg - Germany

PostPosted: Wed Jul 10, 2024 1:29 pm    Post subject: Reply with quote

Danke für den Hinweis. Ich habe allerdings jetzt wieder Kicad emerged, welches weitere python3_11 Abhängigkeiten mitbringt. Von daher wird mir der Firefox nichts nützen. Ich möchte nur auf Kicad nicht verzichten, weil ich mich damit beschäftigen wollte. Es wird deshalb noch eine Weile dauern.
_________________
Desktop AMD Ryzen 9 5900X 32GB RAM, Asus GF GTX 1060.
Notebook Tuxedo Pulse 15 Gen1 AMD Ryzen 7 4800H mit Radeon Vega 7
Raspberry Pi 1 + 2 + 3B+ + Zero W
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2611
Location: Heidelberg - Germany

PostPosted: Sun Jul 14, 2024 4:04 pm    Post subject: Reply with quote

Kicad war in einer neueren Version kein Thema mehr. Firefox habe ich in der "rapid" Version installiert. Ich brauche ihn ohnehin nur für Spezialfälle. Jetzt bin ich tatsächlich python3.11 losgeworden.
_________________
Desktop AMD Ryzen 9 5900X 32GB RAM, Asus GF GTX 1060.
Notebook Tuxedo Pulse 15 Gen1 AMD Ryzen 7 4800H mit Radeon Vega 7
Raspberry Pi 1 + 2 + 3B+ + Zero W
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum