Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Need to instakll Xfce.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
gardenair
n00b
n00b


Joined: 05 Oct 2021
Posts: 72

PostPosted: Mon Jul 08, 2024 5:39 pm    Post subject: Need to instakll Xfce. Reply with quote

hi,
In my Oracle Virtualbox, I am using Gentoo Linux amd64/23.0/desktop/systemd (stable) with Gentoo Linux 6.6.35 and 6.6.32 -gentoo-dist.
I normally boot from 6.6.32 -gentoo-dist . My question is what are the key steps to install Xfce? I want to use a keyboard mouse, and sound volume and when I mount USB it may show on the desktop as well in my Guest Gentoo Linux.
Well, you can view my "emerge--info " output at https://bpa.st/IWLQ and "/etc/portage/make.conf " output at https://bpa.st/3ITA Any change you think to add or remove in my "/etc/portage/make.conf " guide me.
Please guide me on what key steps I may take.
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 31080
Location: here

PostPosted: Tue Jul 09, 2024 4:51 am    Post subject: Reply with quote

You have already selected a desktop profile and this should enable the minimum use flags for a graphical environment.
To install xfce you can start by looking at the related gentoo wiki page.
An other interesting wiki page is gentoo as guest on virtualbox.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lars_the_bear
Apprentice
Apprentice


Joined: 05 Jun 2024
Posts: 180

PostPosted: Tue Jul 09, 2024 7:26 am    Post subject: Reply with quote

Hi

I found that installing as described in the documentation worked fine, except that I had to disable the pre-compiled binary for libxfce4ui, and force it to build from source. That's because the binary requires Wayland support, but says it doesn't. There's a bug open for this, as I recall.

EMERGE_DEFAULT_OPTS="--usepkg-exclude 'xfce4-base/libxfce4ui'"

If you want USB drives to auto-mount, you'll need `gvfs` or something similar, in addition to whatever configuration VirtualBox needs to show the USB to the guest OS. There's some stuff in the Thunar documentation[1] about having Thunar being able to mount/unmount drives dynamically.

If you're using Pulse, there's a Pulse applet for Xfce that should take care of volume controls. I don't use Pulse, so I don't know how well it works. I just map the keys manually to `alsactl` commands. I guess you could do the same with `pactl` if the applet doesn't work.

In general, I find that Xfce4 works pretty well in Gentoo, but it needed a lot more tweaking than it does on Ubuntu. But the Ubuntu install includes a heap of Gnome stuff, which I'm excluding in Ubuntu, so I expected the extra work.

BR, Lars.

[1] https://wiki.gentoo.org/wiki/Thunar
Back to top
View user's profile Send private message
gardenair
n00b
n00b


Joined: 05 Oct 2021
Posts: 72

PostPosted: Wed Jul 10, 2024 5:28 am    Post subject: Reply with quote

Well, I have removed USE flags from /etc/portage/make.conf as I was already using systemd desktop profile. I apply
Code:
emerge-websync
Code:
 root #emerge --ask --verbose --update --deep --newuse @world
When I apply the command
Code:
 root #emerge --ask xfce-base/xfce4-meta

after few mints the system does't respond. There is no resources issue.
A screenshot is here https://ibb.co/RcZmHSP

I boot my system by 6.6.32 -gentoo-dist. In my opinion there may be a a kernel issue (May be i am wrong) What you suggest me ? How may I fix the problem.
Back to top
View user's profile Send private message
lars_the_bear
Apprentice
Apprentice


Joined: 05 Jun 2024
Posts: 180

PostPosted: Wed Jul 10, 2024 6:43 am    Post subject: Reply with quote

I'm afraid I don't know why this happens -- it will need somebody with more expertise than me to figure that out, I think. I find that Gentoo on VirtualBox just hangs sometimes, and it's nearly always while I'm compiling a big package. Sometimes I have to take two or more tries, to get these packages to build.

I've tolerated this because I don't really expect to use VirtualBox in the long term -- I used it to experiment before setting up real hardware.
Back to top
View user's profile Send private message
pietinger
Moderator
Moderator


Joined: 17 Oct 2006
Posts: 4579
Location: Bavaria

PostPosted: Wed Jul 10, 2024 10:30 am    Post subject: Reply with quote

Try:
Code:
# MAKEOPTS="-j1" emerge -1Dv boost

If this works then try again to install xfce4-meta.
_________________
https://wiki.gentoo.org/wiki/User:Pietinger
Back to top
View user's profile Send private message
gardenair
n00b
n00b


Joined: 05 Oct 2021
Posts: 72

PostPosted: Thu Jul 11, 2024 4:43 pm    Post subject: Reply with quote

Thanks all for your replies. Well, I increased the amount of RAM in my VM and eventually, I was able to install Xfce. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum