Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Upgrade to version 23.0 help needed. **SOLVED**
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
todd93
l33t
l33t


Joined: 30 Oct 2006
Posts: 620
Location: Missouri

PostPosted: Sat Mar 23, 2024 11:31 am    Post subject: Upgrade to version 23.0 help needed. **SOLVED** Reply with quote

While following the directions in the news item on upgrading to profile 23.0, I'm running into problems. I was pretty sure that I have an openrc system. I was on profile
Code:
[5]   default/linux/amd64/17.1/desktop (exp)
So following the directions, I switched to the corresponding 23.0 profile
Code:
[23]  default/linux/amd64/23.0/desktop (stable) *
Following the directions, I did not have /var/cache/binpkgs/*, nor do I have a directory /etc/portage/binrepos.conf. So, I started to rebuild the packages in order and got stopped on the first one with the following errors:
Code:

emerge --ask --oneshot --getbinpkg sys-devel/binutils
!!! /etc/portage/binrepos.conf is missing (or PORTAGE_BINHOST is unset), but use is requested.
!!! /etc/portage/binrepos.conf is missing (or PORTAGE_BINHOST is unset), but use is requested.

These are the packages that would be merged, in order:

Calculating dependencies... done!
Dependency resolution took 3.10 s (backtrack: 0/20).

[ebuild   R    ] sys-devel/binutils-2.41-r5  USE="cet* zstd*"

Would you like to merge these packages? [Yes/No] Yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-devel/binutils-2.41-r5::gentoo
 * binutils-2.41.tar.xz BLAKE2B SHA512 size ;-) ...                      [ ok ]
 * binutils-2.41-patches-5.tar.xz BLAKE2B SHA512 size ;-) ...            [ ok ]
 *
 * Your profile is of type merged-usr, but your directories
 * on-disk are of type split-usr.
 * Please switch back to your last valid profile setting and
 * read the documentation about merged-usr and profile changes.
 *
 * ERROR: sys-devel/binutils-2.41-r5::gentoo failed (setup phase):
 *   ERROR: 23.0 merged-usr profile, but disk is split-usr
 *
 * Call stack:
 *        ebuild.sh, line 606:  Called __source_all_bashrcs
 *        ebuild.sh, line 426:  Called __try_source '/var/db/repos/gentoo/profiles/releases/23.0/profile.bashrc'
 *        ebuild.sh, line 487:  Called __qa_source '/var/db/repos/gentoo/profiles/releases/23.0/profile.bashrc'
 *        ebuild.sh, line 123:  Called source '/var/db/repos/gentoo/profiles/releases/23.0/profile.bashrc'
 *   profile.bashrc, line   9:  Called die
 * The specific snippet of code:
 *         die "ERROR: 23.0 merged-usr profile, but disk is split-usr"
 *
 * If you need support, post the output of `emerge --info '=sys-devel/binutils-2.41-r5::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/binutils-2.41-r5::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/binutils-2.41-r5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/binutils-2.41-r5/temp/die.env'.
 * Working directory: '/var/tmp/portage/sys-devel/binutils-2.41-r5/empty'
 * S: '/var/tmp/portage/sys-devel/binutils-2.41-r5/work/binutils-2.41'

>>> Failed to emerge sys-devel/binutils-2.41-r5, Log file:

>>>  '/var/tmp/portage/sys-devel/binutils-2.41-r5/temp/build.log'

 * Messages for package sys-devel/binutils-2.41-r5:

 *
 * Your profile is of type merged-usr, but your directories
 * on-disk are of type split-usr.
 * Please switch back to your last valid profile setting and
 * read the documentation about merged-usr and profile changes.
 *
 * ERROR: sys-devel/binutils-2.41-r5::gentoo failed (setup phase):
 *   ERROR: 23.0 merged-usr profile, but disk is split-usr
 *
 * Call stack:
 *        ebuild.sh, line 606:  Called __source_all_bashrcs
 *        ebuild.sh, line 426:  Called __try_source '/var/db/repos/gentoo/profiles/releases/23.0/profile.bashrc'
 *        ebuild.sh, line 487:  Called __qa_source '/var/db/repos/gentoo/profiles/releases/23.0/profile.bashrc'
 *        ebuild.sh, line 123:  Called source '/var/db/repos/gentoo/profiles/releases/23.0/profile.bashrc'
 *   profile.bashrc, line   9:  Called die
 * The specific snippet of code:
 *         die "ERROR: 23.0 merged-usr profile, but disk is split-usr"
 *
 * If you need support, post the output of `emerge --info '=sys-devel/binutils-2.41-r5::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/binutils-2.41-r5::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/binutils-2.41-r5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/binutils-2.41-r5/temp/die.env'.
 * Working directory: '/var/tmp/portage/sys-devel/binutils-2.41-r5/empty'
 * S: '/var/tmp/portage/sys-devel/binutils-2.41-r5/work/binutils-2.41'

I know I have had to have missed something, but I honestly don't know what, or how to correct it. Any help would be deeply appreciated!

Thanks!!

Todd


Last edited by todd93 on Sat Mar 23, 2024 3:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
flysideways
Guru
Guru


Joined: 29 Jan 2005
Posts: 437

PostPosted: Sat Mar 23, 2024 12:08 pm    Post subject: Reply with quote

I have only been reading the instructions, but reading this
Code:
Note 1: The use of binary packages is completely optional, and also not
as much tested as the source-based upgrade path yet. If you prefer to
only use the traditional source-based installation, omit the "--getbinpkg"
parameter in all emerge invocations.

which leaves me thinking that I will not use the "--getbinpkg" parameter when invoking emerge on any of my Gentoo installs, as none use any binary packages.


Last edited by flysideways on Sat Mar 23, 2024 12:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
flysideways
Guru
Guru


Joined: 29 Jan 2005
Posts: 437

PostPosted: Sat Mar 23, 2024 12:10 pm    Post subject: Reply with quote

The instructions from news are also found here: https://wiki.gentoo.org/wiki/Project:Toolchain/23.0_update_instructions
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 54236
Location: 56N 3W

PostPosted: Sat Mar 23, 2024 1:02 pm    Post subject: Reply with quote

todd93,

Code:
[5]   default/linux/amd64/17.1/desktop (exp)   
[23]  default/linux/amd64/23.0/desktop (stable) *


Your misread the instructions. All the 17.1 OpenRC profiles are split-usr., so your correct 23.0 profile is
Code:
[46]  default/linux/amd64/23.0/split-usr/desktop (stable)


Code:
[23]  default/linux/amd64/23.0/desktop (stable)
is for merged-user OpenRC installs.
For systemd, there are only merged-user 23.0 profiles.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
todd93
l33t
l33t


Joined: 30 Oct 2006
Posts: 620
Location: Missouri

PostPosted: Sat Mar 23, 2024 3:25 pm    Post subject: Reply with quote

NeddySeagoon wrote:
todd93,

Code:
[5]   default/linux/amd64/17.1/desktop (exp)   
[23]  default/linux/amd64/23.0/desktop (stable) *


Your misread the instructions. All the 17.1 OpenRC profiles are split-usr., so your correct 23.0 profile is
Code:
[46]  default/linux/amd64/23.0/split-usr/desktop (stable)


Code:
[23]  default/linux/amd64/23.0/desktop (stable)
is for merged-user OpenRC installs.
For systemd, there are only merged-user 23.0 profiles.


I feel so foolish, I missed that! Thanks, NeddySeagoon! Saved me yet again!!

Todd
Back to top
View user's profile Send private message
Carlosk465
n00b
n00b


Joined: 29 May 2022
Posts: 69

PostPosted: Sat Mar 23, 2024 10:29 pm    Post subject: Reply with quote

I have the same problem, select this profile:

of: default/linux/amd64/17.1 (exp)
to: default/linux/amd64/23.0/split-usr (stable)

Code:
!!! /etc/portage/binrepos.conf is missing (or PORTAGE_BINHOST is unset), but use is requested.
!!! /etc/portage/binrepos.conf is missing (or PORTAGE_BINHOST is unset), but use is requested.

These are the packages that would be merged, in order:

Calculating dependencies... done!
Dependency resolution took 5.45 s (backtrack: 0/20).

[ebuild   R    ] sys-devel/binutils-2.41-r5  USE="cet* zstd*"



I could just continue, but I already broke gentoo once by accidentally uninstalling the package. :lol:
_________________
Sorry for my way of writing, I try to ensure that the translator translates correctly and does not change the words.
Back to top
View user's profile Send private message
flysideways
Guru
Guru


Joined: 29 Jan 2005
Posts: 437

PostPosted: Sat Mar 23, 2024 11:26 pm    Post subject: Reply with quote

Carlosk465 wrote:
I have the same problem, select this profile:

of: default/linux/amd64/17.1 (exp)
to: default/linux/amd64/23.0/split-usr (stable)

Code:
!!! /etc/portage/binrepos.conf is missing (or PORTAGE_BINHOST is unset), but use is requested.
!!! /etc/portage/binrepos.conf is missing (or PORTAGE_BINHOST is unset), but use is requested.

These are the packages that would be merged, in order:

Calculating dependencies... done!
Dependency resolution took 5.45 s (backtrack: 0/20).

[ebuild   R    ] sys-devel/binutils-2.41-r5  USE="cet* zstd*"



I could just continue, but I already broke gentoo once by accidentally uninstalling the package. :lol:


Try the merge without the "--getbinpkg" parameter.
Back to top
View user's profile Send private message
Carlosk465
n00b
n00b


Joined: 29 May 2022
Posts: 69

PostPosted: Sun Mar 24, 2024 12:21 am    Post subject: Reply with quote

flysideways wrote:
Try the merge without the "--getbinpkg" parameter.



It works, thank you
_________________
Sorry for my way of writing, I try to ensure that the translator translates correctly and does not change the words.
Back to top
View user's profile Send private message
sam_
Developer
Developer


Joined: 14 Aug 2020
Posts: 1678

PostPosted: Sun Mar 24, 2024 9:15 am    Post subject: Reply with quote

We believe we've fixed that issue as well so binpkgs should work now, just need to emerge --sync first. Thanks.
Back to top
View user's profile Send private message
gordonp
Tux's lil' helper
Tux's lil' helper


Joined: 23 May 2005
Posts: 102

PostPosted: Tue Apr 02, 2024 9:09 pm    Post subject: Reply with quote

Yeah ... well...
I was running 17.1/hardened and using OpenRC
I 'eselect'ed 23/hardened.

I did read (MISREAD) the instructions ... and in Step 2 I saw that square-bracket [3] as 13 ... so I went to Step 13 :oops:
... and I emerge
... until I couldn't

and now I can't.

Code:

# ./eselect profile list
/usr/share/eselect/libs/core.bash: line 138: gsed: command not found

# ls
-bash: ls: command not found

These commands *do* exist under /bin

I've been running Gentoo on this specific box since ~2007 through many, many migrations and updates. Many. But I don't think I've failed so hard as I did today, after 17 years :-(
I could use any and all pointers ... because, you know, this is a virtual-machine host running several crucial VMs
Back to top
View user's profile Send private message
grknight
Retired Dev
Retired Dev


Joined: 20 Feb 2015
Posts: 1660

PostPosted: Tue Apr 02, 2024 9:59 pm    Post subject: Reply with quote

gordonp wrote:
Yeah ... well...
I was running 17.1/hardened and using OpenRC
I 'eselect'ed 23/hardened.
Code:

# ./eselect profile list
/usr/share/eselect/libs/core.bash: line 138: gsed: command not found

# ls
-bash: ls: command not found

These commands *do* exist under /bin

Prepend PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin" to that eselect command and make sure to choose 23.0/split-usr/hardened. Then try to rebuild baselayout.
Back to top
View user's profile Send private message
gordonp
Tux's lil' helper
Tux's lil' helper


Joined: 23 May 2005
Posts: 102

PostPosted: Thu Apr 04, 2024 4:42 pm    Post subject: Reply with quote

Thanks @grknight for your suggestion; independently I did similar.
And now my system is again working as it should, new 23.0 profile in-place.
Subsequent servers are going much more smoothly (now that I read more-carefully :D )
Back to top
View user's profile Send private message
Frautoincnam
Apprentice
Apprentice


Joined: 19 May 2017
Posts: 294

PostPosted: Mon Apr 15, 2024 6:22 pm    Post subject: Reply with quote

I have the same problem:
Code:
>>> Emerging (1 of 1) sys-devel/binutils-2.41-r5::gentoo
 * binutils-2.41.tar.xz BLAKE2B SHA512 size ;-) ...                                                        [ ok ]
 * binutils-2.41-patches-5.tar.xz BLAKE2B SHA512 size ;-) ...                                              [ ok ]
 *
 * Your profile is of type merged-usr, but your directories
 * on-disk are of type split-usr.
 * Please switch back to your last valid profile setting and
 * read the documentation about merged-usr and profile changes.
 *
 * ERROR: sys-devel/binutils-2.41-r5::gentoo failed (setup phase):
 *   ERROR: 23.0 merged-usr profile, but disk is split-usr

switching profile from
Code:
  [8]   default/linux/amd64/17.1/desktop/plasma (stable)

to
Code:
  [27]  default/linux/amd64/23.0/desktop/plasma (stable) *


That's a gentoo install in a chroot to make binaries for a slow machine.
I don't know anything about merged-usr and split-usr
Should I prefer
Code:
  [48]  default/linux/amd64/23.0/split-usr/desktop/plasma (stable)

?

Code:
emerge --info
Portage 3.0.61 (python 3.11.8-final-0, default/linux/amd64/23.0/desktop/plasma, gcc-13, glibc-2.38-r11, 6.6.21-gentoo x86_64)
=================================================================
System uname: Linux-6.6.21-gentoo-x86_64-Intel-R-_Core-TM-_i5-9600K_CPU_@_3.70GHz-with-glibc2.38
KiB Mem:    32813776 total,  21839332 free
KiB Swap:   33560756 total,  33560756 free
Timestamp of repository gentoo: Mon, 15 Apr 2024 13:45:00 +0000
Head commit of repository gentoo: 54f9f4e0810c8984f625eb20450856afe1533947

sh bash 5.1_p16-r6
ld GNU ld (Gentoo 2.41 p5) 2.41.0
distcc 3.4 x86_64-pc-linux-gnu [enabled]
ccache version 4.9.1 [enabled]
app-misc/pax-utils:        1.3.7::gentoo
app-shells/bash:           5.1_p16-r6::gentoo
dev-build/autoconf:        2.13-r8::gentoo, 2.71-r6::gentoo
dev-build/automake:        1.16.5-r2::gentoo
dev-build/cmake:           3.28.3::gentoo
dev-build/libtool:         2.4.7-r4::gentoo
dev-build/make:            4.4.1-r1::gentoo
dev-build/meson:           1.3.2::gentoo
dev-java/java-config:      2.3.3-r1::gentoo
dev-lang/perl:             5.38.2-r2::gentoo
dev-lang/python:           3.11.8_p1::gentoo, 3.12.3::gentoo
dev-lang/rust:             1.75.0-r1::gentoo
dev-util/ccache:           4.9.1::gentoo
sys-apps/baselayout:       2.14-r2::gentoo
sys-apps/openrc:           0.54::gentoo
sys-apps/sandbox:          2.38::gentoo
sys-devel/binutils:        2.41-r5::gentoo
sys-devel/binutils-config: 5.5::gentoo
sys-devel/clang:           17.0.6::gentoo
sys-devel/gcc:             13.2.1_p20240210::gentoo
sys-devel/gcc-config:      2.11::gentoo
sys-devel/lld:             17.0.6::gentoo
sys-devel/llvm:            17.0.6::gentoo
sys-kernel/linux-headers:  6.6-r1::gentoo (virtual/os-headers)
sys-libs/glibc:            2.38-r11::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://coffee.novazur.fr/gentoo-portage
    priority: -1000
    volatile: True
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 3
    sync-rsync-extra-opts:

Installed sets: @kde, @net_gkrellm
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/sddm/scripts/Xsetup /usr/share/sddm/scripts/Xstop"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --keep-going --buildpkg --buildpkg-exclude 'virtual/* sys-kernel/*-sources */*-bin www-client/google-chrome www-plugins/adobe-flash sys-kernel/linux-firmware net-misc/synchro'"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GDK_PIXBUF_MODULE_FILE GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR XDG_STATE_HOME"
FCFLAGS="-march=nocona -O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg buildpkg-live ccache clean-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox pkgdir-index-trusted preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=nocona -O2 -pipe"
GENTOO_MIRRORS="http://mirrors.rit.edu/gentoo/ http://gentoo.netnitco.net http://gentoo.mirrors.pair.com/ http://gentoo.mirrors.tds.net/gentoo"
LANG="fr_FR.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,pack-relative-relocs"
LEX="flex"
LINGUAS="fr fr_FR"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages/medion"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
SHELL="/bin/bash"
USE="X a52 aac acl activities alsa amd64 branding bzip2 cairo caps cdda cdr cet crypt cups dbus declarative dri dts dvd dvdr eds elogind encode exif fbcon ffmpeg flac gdbm gif gphoto2 gtk gui iconv icu imlib java jpeg kde kwallet lcms libnotify libsamplerate libtirpc mad matroska mng mp3 mp4 mpeg multilib ncurses networkmanager nls ogg openal opengl openmp pam pango pcre pdf pipewire plasma png policykit portaudio ppds pulseaudio qml qt5 readline scanner screencast sdl seccomp sndfile sound speex spell ssl startup-notification svg test-rust theora tiff truetype udev udisks unicode upower usb v4l vorbis vulkan wayland widgets wxwidgets x264 x265 xattr xcb xcomposite xft xinerama xml xpm xv xvid zlib" ABI_X86="64" ADA_TARGET="gcc_12" ALSA_CARDS="hda-intel nvidia" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_anon authn_dbm authn_file authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir env expires ext_filter file_cache filter headers include info log_config logio mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 ntrip navcom oceanserver oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 tsip tripmate tnt ublox" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev libinput" KERNEL="linux" L10N="fr fr_FR" LCD_DEVICES="bayrad cfontz glk hd44780 lb216 lcdm001 mtxorb text" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php8-1" POSTGRES_TARGETS="postgres15" PYTHON_SINGLE_TARGET="python3_11" PYTHON_TARGETS="python3_11" RUBY_TARGETS="ruby31" SANE_BACKENDS="net" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipp2p iface geoip fuzzy condition tarpit sysrq proto logmark ipmark dhcpmac delude chaos account"
Unset:  ADDR2LINE, AR, ARFLAGS, AS, ASFLAGS, CC, CCLD, CONFIG_SHELL, CPP, CPPFLAGS, CTARGET, CXX, CXXFILT, ELFEDIT, EXTRA_ECONF, F77FLAGS, FC, GCOV, GPROF, INSTALL_MASK, LC_ALL, LD, LFLAGS, LIBTOOL, MAKE, MAKEFLAGS, NM, OBJCOPY, OBJDUMP, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PYTHONPATH, RANLIB, READELF, RUSTFLAGS, SIZE, STRINGS, STRIP, YACC, YFLAGS


Edit:
Seems that I just have to follow https://wiki.gentoo.org/wiki/Merge-usr migration before switching


Last edited by Frautoincnam on Mon Apr 15, 2024 6:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 54236
Location: 56N 3W

PostPosted: Mon Apr 15, 2024 6:29 pm    Post subject: Reply with quote

Frautoincnam,

Look at the name of your old 17.1 profile. It was split-user, as it did not explicitly say merged-user in the name.
Choose the 23.0 like your 17.1 profile but it must contain /split-user/ in the name.

Probably
Code:
[48]  default/linux/amd64/23.0/split-usr/desktop/plasma (stable)

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum