Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sway On RaspberryPi5 Help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
Johnson_YHX
n00b
n00b


Joined: 01 Apr 2024
Posts: 2
Location: China

PostPosted: Mon Apr 01, 2024 1:56 am    Post subject: Sway On RaspberryPi5 Help Reply with quote

I installed gentoo on my raspberypi5 followed this guide https://wiki.gentoo.org/wiki/How_to_install_Gentoo_on_Raspberry_Pi_5, and everything look like nice, but I found that I couldn't launch swaywm(wayland).
When I use
Code:
dbus-run-session sway
on tty1, I got the error message
Code:
Failed to open any DRM device
and
Code:
unable to create backend
.
By the way, my x11-environment looks like good, and I can launch dwm with `startx`, So, please help me see how to solve it, thank you very much!

here is my /boot/config.txt
Code:
# have a properly sized image
disable_overscan=1

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# Automatically load overlays for detected cameras
camera_auto_detect=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Automatically load initramfs files, if found
auto_initramfs=1

# Enable DRM VC4 V3D driver
dtoverlay=vc4-kms-v3d
max_framebuffers=2

# Don't have the firmware create an initial video= setting in cmdline.txt.
# Use the kernel's default instead.
disable_fw_kms_setup=1

# Run as fast as firmware / board allows
arm_boost = 1

# LED
dtparam=eth_led0=4
dtparam=eth_led1=4
dtparam=act_led_trigger=none
dtparam=act_led_activelow=off

# I2C
# dtparam=i2c_arm=on

# SPI
# dtparam=spi=on

[all]
disable_splash=1

and my /boot/cmdline.txt
Code:

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p3 rootfstype=ext4 rootwait


and I have edited the config file `/etc/X11/xorg.conf.d/99-vc4.conf`
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 54236
Location: 56N 3W

PostPosted: Mon Apr 01, 2024 4:35 pm    Post subject: Reply with quote

Johnson_YHX,

Welcome to Gentoo.

I have
Code:
# Enable DRM VC4 V3D driver -pi5 for the Pi5
dtoverlay=vc4-kms-v3d-pi5

Notice the -pi5 on the end. Hopefully the automatics get that right anyway.

Disable
Code:
arm_boost = 1
until it works.
That's overclocking which brings its own problems.

Wayland does no use Xorg, so /etc/X11/xorg.conf.d/99-vc4.conf will not be consulted. Rather, wayland is an alternative to Xorg.

Post the command and complete output of
Code:
dbus-run-session sway


See the Wayland wiki page too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Johnson_YHX
n00b
n00b


Joined: 01 Apr 2024
Posts: 2
Location: China

PostPosted: Tue Apr 02, 2024 7:30 am    Post subject: Reply with quote

Finally I solved this problem, I reinstalled the package `wlroots` with USE `drm`
Code:

gui-libs/wlroots-0.17.2::gentoo was built with the following:
USE="X drm libinput session vulkan -liftoff -tinywl -x11-backend -xcb-errors"

then swaywm worked on my pi. Thanks for your reply!
Back to top
View user's profile Send private message
carfentanyl
n00b
n00b


Joined: 28 Dec 2023
Posts: 8

PostPosted: Tue Apr 09, 2024 8:20 am    Post subject: wlroots drm Reply with quote

That worked for me too!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum